Logbook lost/deleted after shutdown of xbox servers connection

Xbox version

Symptoms: logbook lost after disconnection from xbox services.

This week-end, I was flying at satursday night when the Xbox servers shutdown (may be overloaded - I was connected to the Europe West server). So I stopped my session, and restart on Sunday morning. All was OK, except that FS2020 didn’t automatically connect to the server. I had to manually set the DATA CONNECTION to ON.

Once done, this worked fine, all services (shop…) were active.

But on sunday night… shoot again! the Xbox servers shutdown (and probably again overloaded). OK, I stopped my session :confused:

Then, on Monday morning, I restart FS2020, but this time I forgot to set the DATA CONNECTION to ON. Thus, the simulator was working, but unconnected to my Xbox account. I noticed that some services were unavailable - like the “shop” not accessible, with a grayed tab - and also, no access to the details of my xbox account/profile. Nothing abnormal at this point.
And my error was to start a new flight, being unconnected…

Some time later, I looked at my profile and my logbook: WHAT A SURPRISE, now I have only ONE flight hour, while I had previously more that 25. But worse: the datas/logs are now unconsistent and illogical.

  • the reason is that my logbook has been cleared (and this is something you can’t do by yourself on an Xbox, as there is no file manager on the console - so the bug obviously come from FS2020).
  • the activities, and training sessions are still well recorded. My Xbox success list is also uncorrupted and my Xbox profle report correct values. As far I undestand, all that was located on Xbox cloud is safe, but not what is locally stored by FS2020.
  • in FS2020, the total logged hours is 1, and the counts of activities/learning are set to 0 :rage: :rage: :rage:

Now, my logbook contain only recent flights, but all olders flights has been deleted. This is of course, totally inconsistent with the flight time recorded in the profile page.

Even, that the activities counts are set to zero, the activities percentages are corrects (and details, I have three bush trips well recorded here):

Look like there is a total mess when FS2020 can’t connect to Xbox servers.

Zendesk ticket : #118094

UPDATE: This issue is even WORSE than you can imagine :nauseated_face:

Again, yesterday evening, the Xbox live servers were overloaded. I lost the connexion to my account. I’ve checked my fiber optic line, no problem… all my others machines worked fine, only the XBOX was unable to connect to the live account. I tested some others games (FORZA HORIZON 4, ROGUE SQUADRON) and the problem was similar: no acces to my account.

This morning I checked my LOGBOOK: nothing! erased again :rage: :rage: :rage:

But I also notice another problem, consecutive to the connexion lost:

Indeed: I ususally set the “units of measurement” to “hybrid” , and this setting revert to the default “U.S. system” :angry:

But I also usually set the “Music” level to 0, as I don’t want music… and when I start FS, oh, I have music ??? why ? because the level was reverted to 100. :scream:

I don’t tested all settings, but sure, when the Xbox servers are unavaible, FS has a totally weird behaviour. :eyes: Soon or later, every users on Xbox will encounter problem of connexion to servers, and thus, experiment this critical BUG :boom: :skull:

Happened to me too same weekend, I’m gutted, I was on 93hrs and that had been hard earned because of the amount of game crashes I have, I can’t have a longish flight without a interruption, it’s killing the game for me, I’m threatening to put my free flying time back to RFS, it really is a shame cos otherwise I love the game.

I’m sorry the same mishap happened to you, but at least that proves that there is a serious problem with data loss under certain conditions.

For my part, the problem has not recurred and I am crossing my fingers :crossed_fingers:, but I have also improved my network configuration. Previously, I used CPL equipments to connect my Xbox and also a temporary ethernet cable during large downloads (to have a good speed).
I replaced everything with a real Cat.7 cabling and since then I have not noticed any network error. It may be a coincidence, but I think that when possible, it is best to avoid CPL and Wifi, the speed and latency of which can vary.

At least with my new installation, I no longer need to change the connection for large downloads.

Of course, errors or network slowness cannot justify losing data from the logbook, but in my case it seems like the problem is gone (at least for now).

However, I remain very suspicious, especially when you see the number of incredible bugs in this product, and the monumental errors (there is even an error in the copyright message : Asobo is not an SARL, but an SAS - which changes a lot of things at the legal level!
this really denotes the very low level of quality control of MSFS 2020). :-1: :chart_with_downwards_trend:

A similar thing happened to me, I lost over 30 hours… I cannot confirm the cause is the connection, I just closed the game and when I restarted everything was gone. My achievements are also completely messed up now, the trackers did not reset so I’m completely lost as to what exactly I need to redo.

Happened to me as well! I am looking for solution but didnt find any…

same here, I clicked on sign-out a then after reconnecting some settings are set to default and no flight in logbook, zero flight hours… very bad