Low FPS with RTX 3080

Hi,

I bought recently a new RTX 3080 12GB MSI which is running together with 32 GB RAM and a Ryzen 5 3600 CPU. Since today the sim is loadin verz slow and then I got 2 fps (yes 2) in the sim as you can see in the screenshot below. What is happening? I can’t figure it out. I also did a clean installation of either Windows and MSFS2020. Please any idea? Thanks

1 Like

To see your best performance, turn off Online Functionality in Data, turn all AI to zero in Traffic, set your desktop and game resolution to 1080p, and select High-End graphics preset. For an added boost, turn off Texture Supersampling, Terrain Shadows, Contact Shadows, and Ambient Occlusion. Restore defaults in the Global and Program Settings for Flightsimulator.exe in Manage 3D settings in the Nvidia control panel. This should give you an idea if nothing major is wrong. You can always adjust the settings later.

I would say from your FPS counter that the computer is working hard in the background with I/O tasks and Simconnect tasks. As you can see your GPU frame times are good, but your CPU is struggling with too much work.

1 Like

Check your processor speed and temperature. Your CPU is clearly throttling for some reason - you have close to a 1300ms render time on the CPU. My first guess: high temperatures are causing your processor to throttle down. HWInfo is a great free tool to check this.

Also check your Power Mode setting in Windows and make sure it’s not set to Best Power Efficiency, as that will prevent your CPU from boosting to it’s full speeds.

I have the same setup - RTX 3080 + 32GB Ram + R5 3600 and have very good FPS in pancake mode.
In VR, it is another story.

So you shouldn’t be having this low FPS - there are settings which need to be tweaked.
My Ryzen processor runs at 60 deg max when in VR - i upgraded my case to have proper cooling and it boosts quite high.

Thanks everybody for the help. I will try to check and monitor speed and temperatures of the CPU. I have a question? Is it possible that the new GPU (it was a 2060 now I have a 3080) did make the CPU temperature to increase? Do you think I need to think a new way of cool down the CPU ?

@Skyvertical thanks, this give me a little bit of hope, because some people told me that the GPU is bottleneck the CPU and that is too weak for that and i was scared need to change also the CPU which I dont want at the moment. Hope the find a solution. Keep you advice in the next days.

1 Like

Always turn off Motion Blur

Check out this thread as well

you can see “limited by mainthread”… thus try to reduce the tLOD setting to e.g 150.

If you assume its temporary ( because you wrote ‘since today’ ) , you can also test the photogrammetry setting ( try with Off for a test-case ).

what pc case do you have and which CPU cooler are you using?

In my previous setup, I had a GTX 1080 in a mini itx setup and using the stock ryzen cooler. The temperatures were shooting up to 75-80 deg, even 90 at times.

Now, I have a larger ATX case, with a decent AIO cooler. The max temp for the RTX 3080 is 73 deg and the CPU never goes above 60 deg. At idle, it stays at 45 deg.

Pc components, airflow, room temperatures, etc make a big difference.

Are you using DX11 or DX12?

I am using DX 11 but I have some updates again.

I did change my build and now I have since few days a Ryzen 9 5600X with 64 GB RAM and RTX 3080 MSI but sill have issues with FPS which are very strange. The issue are with any kind of configuration (Ultra or Low) and with different airplanes. Temperatures are normal range. Before I was limited by mainthread but now sometimes I got Limited by GPU but it’s very frustating. I think I need to open a ticket.

During the loading the FPS are very low (2 fps)

I did a clean install of Windows 11 and Flight Simulator 2020.


I have an update turned OFF photogrammetry and now it worked normal with solid 50-60 fps

So my question is , why? Any idea?

MS Server overload

we not realy checking now fps while loading into the flight, or ???

Its absolutly unimportant and simple possible that a loading-screen, which show a blue-bar, not care about fps… Realy… close that Dev-Mode and all other kind of fps counters and enjoy the game.

PS.: and set your render-scale back from 200% to 100%

1 Like

Worked for me! Turned off photogrammetry and everything back to normal.

As I said before turning off the PG will make everything smoth. I’ve seen that Asobo has this issue under investigation. Now I will try to unisntall the PG for every city and then one by one install back and make some tests to understand where is the problem.

1 Like