Low photogrammetry quality since su5

hey i am getting bed photogrammetry quality after su5 this happens only for me?
because at this moment photogrammetry cities are not playable.


I think this might be related to server load - it’s the weekend after launch on xbox. Popular photogrammetry destinations are likely heavily populated.

Make all the usual checks of course.
Online data functionality on? check.
photogrammetry on? check.
rolling cache deleted (and if you want to keep one - reset) check?


I’m having the same issues. When taking off from JFK the photogrammerty is not visible, when i come closer i start to see strange spikes instead of buildings. By the time they actually look like buildings i have to be unrealistically close (for an airliner).

Hopefully it’s just because of server load. But i think this shouldn’t happen as they should be able to spawn as many cloud servers as they want.

1 Like

Photogrammetry has never been real good. Fix photogrammetry has been on the wish list for a while. I had a feeling this would be an issue with xbox users. It wont be a nice and crisp graphic like most everything else they play.

1 Like

I changed my settings from ultra to medium and then back to ultra: better graphics!

1 Like

Am I online or offline ??

You can select your status. I think it only affects if friends can see you or similar, though.

i have the oppsosite, before the su5 i couldnt do potogram, gave long freezes.
now it runs smooth.
btw photogram is very different quality , try venice and other italian cities, these are great.

They reduced the radius of the LOD after SU5.Has nothing to do fully with server load.
Had to set LOD to 300 otherwise 200 I do not notice any Skylines from JFK

1 Like

No there definitely seems to be some server issues, along with the LOD reductions. I have been having major issues since installing SU5 with getting photogrammetry data to load and bing satellite images to load in also. Got a popup saying I had inadequte bandwidth to stream the data so I went to offline. Then tried to go in to data to re enable it and got an immediate CTD. Tried loading up a new flight and now been stuck on loading screen for 20 minutes. I am sorry, this is the worst SU ever.

There’s a thread specifically about Ediinburgh missing detail over here: SU5, before....and after

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.