Marketplace Greyed Out

I apologize to the members here and to Asobo for the length of this problem writeup. I have edited my original post, here, for correctness and action taken. I have taken every step recommended by MSoft and fellow Flight Simulator simmers to correct Marketplace Greyed Out and missing Photogrammetry but no luck. Below is everything I know, and have done, to try and correct this mess. I have submitted the following to Zendesk, but thought others with similar problems might like to know what I’ve tried to do to correct.

After update FS2020 (MS Store purchase), I experienced some major problems. Have never had problems before now. I’d say my system has been in the top 10% as far as FS2020 reliability until now, and I have immensely enjoyed this sim.

Problems: I have lost Photogrammetry and Marketplace is greyed out. Clouds, trees, bushes, grasses, vehicles, night lighting, and airport ground maintenance personnel all look and work as good as they ever did. The buildings, however, look like they are made from cardboard. Also from the air I see very vivid red colors sprinkled throughout the landscape (not GPU-related). Never saw this before either. Also all Garmin screens in all AC are blacked out. Could these problems all be related?
I am the owner of the software and I use no family sharing. On-line functionality is ON. I have no Data Cap. I was already logged in with the Xbox Live account that was used to purchase Microsoft Flight Simulator. I have signed out and back in again to refresh the connection.

What else I’ve done to no effect:

  1. Photogrammetry and Bing Data are ON in Data.
  2. In Data Connection, all options are ON. Status= On Line; On Line Services=OK
  3. Opened MS Store. All looks good there.
  4. Removed Mods from Community to Temp folder and rebooted into sim, many times. No joy. Also did this prior to installing the update!
  5. While in-game, signed out of Xbox Live and then back in. No joy.
  6. Tried to change servers from in-game but that is on Automatic, so can’t change.
  7. Checked internet connection=good
  8. In-game, signed out of Xbox Live and back in. Even changed password when entering on MS Account instead of my normal game account. No joy.
  9. Downloaded fresh Xbox app and booted into FS2020 from there. No Joy. Still no Marketplace or Photogrammetry. Dang, I can no longer purchase aircraft and airports in-game!
  10. Deleted Rolling Cache. Updated Rolling Cache. Increased rolling cache to 15GiB. No joy.
  11. Tried using Win10 app Repair Tool for Flight Simulator and XBox apps. No joy.
  12. Checked in-game Data Connection. All ON. Checked in-game 0n-Line Services=OK
  13. Checked every line of in-game Content Manager. All okay.
  14. Tried launching from MS Store=No joy.
  15. Reloaded XBox Live=No joy.

Can anyone help me here? Thanks in advance if you can see anything I missed.

Hi @BiaxialToast7,
Looks like you’ve tried most of what is done for troubleshooting.
See if any of these help:
Search results for ‘greyed out marketplace’ - Microsoft Flight Simulator Forums

When you read them, don’t post in any of the “Archives” topics. These will be closed on 22 January.

I’ve edit your topic as we only want one bug per topic.

1 Like

Do you think the Grayed out Marketplace and lack of Photogrammetry are related?

Update: I ended up having to reinstall the sim. All is well now. I must give credit to the Zendesk as they did send me a bunch of suggestions to correct. Alas non of those worked, but the reinstall did well. Not nearly as bad as I thought it would be and amazingly all my controller assignments, with the exception of two hat switch cockpit assignments were preserved. I spent way more time trying to fix the photogrammetry and marketplace problems than I spent on the install. Oh, almost forgot… I was pleasantly surprised to see that my flight log was still all there!

1 Like

Glad you got it working! :slight_smile:

These items are synced with the cloud and will pull back down on re-installing or even installing on another PC.

Exactly the same problem as myself. Before I read this I had already emailed Aerosoft, from whom I had purchased the disc set to see if there would be a problem with a complete uninstall/re-install. I think I read somewhere that Miscrosoft might reject the code I was given if it had been used before. But it was interesting to read you had exactly the same problems as myself.

1 Like

Cant access to buy from the marketplace for several days now. My internet is online and ive tried to log out and in but nothing helps. Any help? please

1 Like

The only thing I can think of is a complete reinstall, but I know how much of a pain that is.

I’ve recently had the same problem and I solve it by sign out from Xbox Game bar and then sign back in and it worked without reinstall anything.

1 Like

Tried that. Didnt help.

Tried everything i could find online to fix the problem. But nothing helped. Im trying the last step now by reinstalling the sim.

same issue here including the reinstall of the sim today.
still no go. I wouldn’t mind if it wasn’t for the fact that some 3PD’s sell their addon’s I want exclusively on MSFS Marketplace. Like Carenado.

I solved it by contacting zendesk support. It was a purchase that didnt finnish. They removed the it manualy and now it works again.

yeah that what I ended up doing, waiting on their response

Hi @Fheonix911,
How long ago did you put that ticket in at zendesk?

Since this is currently the top search result for “Marketplace greyed out”, I’d like to add for anyone who comes here searching for a solution: If you purchased via Steam, you must include the Steam app in the whole signing out/in process.

I had this error intermittently over the last few weeks and only today I discovered that my Steam client was crashing all the time (I had altered it while experimenting with Steam Link). When I restarted it and then started MSFS, all went smoothly. Worth noting that it was apparently not enough to start MSFS from the shortcut, despite Steam gets auto-launched when you do that. I had to re-launch the Steam client manually.

1 Like

This worked for me! Thx.

Marketplace has been greyed out for over a day …may have been longer but I only noticed it yesterday. I have tried all the suggestions from a google search (logging off and in, logging out of xbox account etc) but to no avail.
I suspect this is related to other issues people are having ahead of the UK update but can anyone confirm this for definite please? Thanks.

1 Like

Had been for me too for a few days, although it looked like it was available when I started up this morning, will check properly when I finish my current flight.

Thanks for the reply - I’ve just started the game again and market place is back.