Massive FPS drop because of SU9

Hi all!
I just wanted t oshare a tweak to the sim I was suggested from very unexpected source - Fenix A320 support, that fixed my FPS.
So from the beginning I was struggling with FPS getting to 5 within 40min from the start of the game, this morning I even managed to get 1 when I had aircraft in C&D parked at teh gate.
Anyways, I browsed lots of forums and tried turning V-sync and limiting FPS to 30 (no difference for me), I removed all world updates I had installed (apparently photogrammetry is causing lots of FPS loss - no change for me, I removed whatever I thought was causing problems from community folder - no difference).
Few hours ago I got a response from Fenix (I was in touch with them, because I initially thought that it was their update that caused by frames to drop) and they suggested turning OFF SCREEN TERRAIN PRE-CACHING to ULTRA (I had it on medium) - problem solved!!
I just finished flight with Fenix A320 EGLL-LJLJ with no problems what-so-ever!
Give it a go, who knows, maybe it will work for you too!

Clear skies!

Andrew

Yeah I dont know about that, the sim seems to run better here with it totaly disabled in the usercfg.opt file. I turned it back on the other day, and the sim started stuttering as I was flying along…turned it off and restarted the sim, and it was back to normal performance wise.

I think the big reason is the problem of connecting to the game server!!! So it’s hard for game developers to copy problems. Because the developer has excellent connection with the game server!!!

2 Likes

[BubbaBlitz7348] I’m trying to avoid messing about system files such as the one you mentioned. I turned this option to ultra in the sim options/general options/graphics.
Anyhow, I guess I just wanted to share solution that worked for me :slight_smile: Hope, it will work for few other sim-pilots as well allowing them to enjoy the sim again :slight_smile:

This. While not practical for everyone, I have seen no artifact pop-ins since switching from wifi to a wired connection last week, and panning around seems much smoother with no stutters. Even though wifi speeds look equivalent to wired gigabit, actually throughput is usually limited based on other users, distance from router, and structure interference, and not as stable as wired.

Running TLod just over 200, Object Load much higher (little to no performance impact jacking this up), and 1440p with render scaling set to the equivalent of 4k for pixel count, all graphics set to ultra. System is a 10700k with a 3090 FE.

1 Like

No problem with 5G WIFI from home router. 300Mbps.

4K Ultra, T LoD=5, O LoD=900 (custom UserCfg.opt)

So Ive actually been getting 26fps (3 times today), the last flight I was flying Tribal Air to Las Vegas, set it at a 12000’ altitude and set the autopilot and left to do errands, when I came back to the screen I was sitting at the desktop…Never had that happen before, so geee Shaggy a new mystery to unravel…

1 Like

I was just saying what works today for you may or may not work for other people, and from what Ive seen from the sim even things that you fix yourself today, all of a sudden dont work tomorrow anymore even though nothing has changed on your system… ;p

I get ~17 on the ground w/ FENX at either KBOS (FlyTampa) or KMCO (stock) w/ default ultra, no change for weather/traffic levels, 30 locked in the air (sim lock, I don’t play with nVidia control panel). I9-9900k w/ 3090ti and SSD drive. It’s weird how the fps jumps almost instantly on liftoff and dies either on short final or touchdown.

I guess I shouldnt of said anything just fired it back up and now were getting 12 fps refired the sim 3 times and every dam time 12 fps of less…FIX YOUR ■■■■ SIM ALREAY!!!

2 Likes

There is probably a kind of lottery on the server so that every user has a sense of achievement from time to time so as not to jump overboard. :joy:

Cortana, when is my Slot?

1 Like

Ive switched to using a helicopter for the first time and stopped using airliners for now, given me the opportunity to set everything to ultra and all the sliders to the max so i can have both quality and performance. The lake district in a chopper in VR is something else. Sometimes i get fed up of chasing stutter free performance rather than just focusing on going places.

Today’s flight: Cruise altitude, CPU 17%, GPU 48%. Jerky, jerky, jerky. Limited by main thread…what a joke. :frowning:

1 Like

performance is so bad now, unbelievable and no hotfix!!! This is so poor and I sam really sick of it, it is unplayable with high end rig. Get your act finally together Asobo, we paid for it.

What a joke

3 Likes

^^^ Totally agree. I built a gamer specifically for this. Spent a ton of cash: Ryzen9 5900x, RTX3080 10G, 32G 3600, and my machine is asleep at the wheel. Of course if I go into world map or Market place, I get 300+ fps and 100% utilization on GPU. Before the latest update, my GPU ran at 100% from loading the game to shutting it down. Now I get CPU usage in the teens and GPU in the 40-50% range and it’s jerky and ■■■■■■. So lame! Some people will say that I’m not being constructive and just complaining, but it’s not our job to make the sim work well. I didn’t change a thing and my performance crapped out. Nothing I did.

4 Likes

It seems like they have finally found the cause of this issue!
Status has changed from “Investigating” to “Started” in the recent Dev-Update.

5 Likes

I hope so, but I am not overly optimistic about the Started status. Items can stay in that state for a very long time.

1 Like

Sure, but at least they have found something they can fix.

I’ll believe it when I see it :wink:

Several performance issues are marked as started now, and some already were for a while.

2 Likes

A good point.

This could well be the case and one that should maybe get more attention.

It would make sense, I think, for at least some of the Asobo developers/testers to beta test stuff with a range of server connections but like you I bet this is not the case. :slightly_smiling_face: