Mouse cursor randomly DOESN'T REAPPEAR when moving around (translation) in the cockpit after last “mouse going to top left corner” fix

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No
Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
Mouse cursor went back to the top left corner when moving around (translation) in the cockpit
Provide Screenshot(s)/video(s) of the issue encountered:
Not needed
Detail steps to reproduce the issue encountered:
When using the camera inside the cockpit and you move around in a translation manner, the cursor goes to the top left corner.
By default, this kind of movement is done with the arrow keys in the keyboard.

In previous versions this issue doesn’t existed
PC specs for those who want to assist (if not entered in your profile)
Not applicable
Build Version # when you first started experiencing this issue:
1.18.13.0
Are you on the Steam or Microsoft Store version?
Steam
Did you submit this to Zendesk? If so, what is your ticket #?
Yes.
Request #113406 Mouse cursor went back to the top left corner when moving around (translation) in the cockpit

Very annoying bug :frowning:

2 Likes

Yes, same issue. Very frustrating. Sometimes I can solve it by pressing Esc and going back into the game.

I have to do that to un-bug my cursor so it appears again (because when translating it dissapears and sometimes it doesn’t appear anymore). And… no, the issue is still there in my case after pressing esc and going back.

Yupp same issue here. Pressing ESC doesnt help.

2 Likes

This still isn’t fixed in the latest hotfix.

(I know that the patch notes doesn’t acknoledge nothing about this bug, but is worth info that it’s still there)

Yeah I had hoped as well… but nope, nothing about the garbage interaction being fixed…

Agree to this - the mouse interaction is not fixed. Feels very strange and unnatural. Hope this gets fixed ASAP as it is just so annoying to move the camera around, not being able to find the mouse cursor or having it to drag it all the time from the left…

2 Likes

Same happens to me with the addition of the top bar never hidding 100%. Icons go away but the ribbon stays. Anybody else having this issue as well?

this is really annoying, need to fix this, makes it difficult when mouse flying as you have to recenter everytime…

Same here. Seems to me the developers have thrown away their PCs and only using Xboxes as this (along with a pile of other bugs) should have been stark staring obvious to anybody using the sim on a PC for more than 5 minutes. I think it good to bring in “fresh blood” (Xbox users) to the community but I feel like I’m paying a heavy price for them, to the point of leaving the simming community because I’m just fed up of stuff like this happening and the TERRIBLE degradation of visul quality. Maybe the devs should have been given more time for testing/fixing bugs seeing as you can’t actually buy an Xbox these days anyway!

Same here. Sometimes it disappears entirely sometimes it goes to the top left.

I’ve found that it mostly seems to happen if you move around the cockpit first, without right clicking the mouse. If you right click first, then move around while holding right click, it seems to do alright

Very frustrating

1 Like

Same thing for me… And another problem when I move the head with right click I can’t use any axis like, Yoke, Rudder, Throttle!!

1 Like

This is absolutely broken for me.
Decided to use the gamepad so I don’t have to install the whole HOTAS.

Every time the stick goes down or I press d-pad down, the mouse cursor disappears to the top left.
Game breaking overall for me since the controller overrules the mouse completely and some of the buttons, as explained above, move the cursor to the top left of the screen.

As someone specified above, anyone testing the sim on PC for a flight or two would’ve noticed that the mouse feels absolutely horrid. I’ll also throw the console tooltips for instrument names compared to before, which occupy an enormous amount of screen. Was nice to have them show whether a button is pressed or not instead of getting a wikipedia page for the button every time i look at something.

5 Likes

I kind of remember having a problem like this… being unable to control the aircraft in situations when I could before… but I don’t remember when it happened

Same for me!
Related: Mouse pointer jumping to the top left corner of the screen (after SU5)

1 Like

It’s the whole Keyboard&Mouse vs. Gamepad system which is broken.

Before SU5 I used the Keyb&Mouse to look around and interact with the systems of the airplane. I could switch seamlessly between them and the gamepad.

Now everything is broken. Whenever I touch the gamepad, the mouse cursor moves to the top left. I can open the game menu with ESC. But I can’t leave that same menu with ESC? ■■■?
The menus in general are broken because of this. I always get displayed the “key” to select a menu item, but this “key” is a controller bind. Other games do this way better and this game has done it okay before SU5. If you want an example look at rockstar and their GTA5/RDR2 games. If I’m in the menu, as soon as I touch the mouse, everything changes to keyboard&mouse inputs. Touch the controller? Change to that.

This is very sad and as others have said elsewhere it seems that this (and other problems) stems from the almighty new Xbox implementation. I hope that the developers try to fix this.

5 Likes

Yes, completely broken is an adept description.
I’m wondering if HOTAS + kb/mouse combo is as broken.

But gamepad + kb/mouse is right now just completely unplayable for me, which is super sad since I was fairly hyped for this update. Now I want to go back.

HOTAS and mouse is broken. When using the hat switch on the joystick to pan around in external view, the cursor disappears altogether making it virtually impossible to fly the aircraft

2 Likes

https://flightsimulator.zendesk.com/hc/en-us/requests/113406
they marked my ticket as solved .__.

I’m going to try again now but I’m pretty sure that I had this issue this morning and it isn’t solved yet

EDIT: Maybe they solved it but it isn’t released yet? They should say something about the status of the ticket

EDIT2: Yep, it isn’t solved.