Mouse lags in VR

This post describes perfectly the problem I am getting in VR mode
This does not happen in P3D, X plane or DCS so I do not think it’s a hardware issue to be perfectly honest. I really hope this can be sorted.

I am having this issue right now. It’s awful and making me not want to play…Ughh…

I was still having this issue on and off however I have found a kinda workaround.
I have a Saitek X52 and Saitek Rudder pedals.
If I switch to VR and notice the issue then I “Unplug” the controller wait 5 secs and plug it back in. Sometimes it will come back just as laggy but if you repeat unplugging 1 out of 5 attempts will resolve it.
Once it is resolved it will be fine for the remainder of the flight
(Until next time…)

1 Like

Exactly the same here.

Good to hear it’s not just me and let’s hope this issue will be addressed. Quite annoying the way it works (or not rather…) right now.

1 Like

To me, it’s very clear something changed in SU8 because I didn’t see this issue before and haven’t changed anything else over here.

So whatever they changed, it caused this issue for some of us if not all.

Now that’s god programming! :stuck_out_tongue_winking_eye:

Same problem, at times mouse gets stuck and then disappears. Once it gets that serious, VR jams and has to be forcefully quit.

Still having the same issue even in SU9 beta. Unbelievable that it’s not fixed yet…

still not working

I noticed that when the ATC window is open in VR the mouse gets blocked whenever a new message is displayed. It either ignores clicks or the mouse arrow remains invisible when you move the mouse. Looks like the windows grabs the focus in some way and keeps it locked even for quite a number of seconds after the message is displayed.
That makes it sometimes impossible to land an airliner with all that chat going on when approaching an airport.

This issue is still out there and not fixed in SU9.

problem still alive

Hello friends,

Been chasing the very same bug for a few hours, intermittently.
And I fixed - for me.

My Config

I’m using the TCA (Airbus version) but to fly GA Aviation aricraft. And I have bound the spoiler axis to the propeller. BUT ! I did not bound the axis. I’ve bound the “virtual buttons”, which are JOYSTICK BUTTON 27, 28, 29, 30 and 31, to Propeller Pitch LO / HI. It’s read like this (BTN 28/29 not assigned)


Note that 31 give “PROP LO” + “PROP REV”, because I need to get my prop in reverse when the axis is full down.
I did not bind anything else on the course of the axis : full down, one up, full front.

My bugfix

I have discovered that, for me, the mouse bug is when I’m full forward with my TCA Spoiler Axis; which, so, push and stay pushed on JOY BUTTON 27. The moment I do this, my mouse starts lagging. Whatever I’m doing (parked, in flight), it lags; if I release the lever (one position down), then the mouse’s doing okay.

I doesn’t have to be the BUTTON 27.
I’ve rebinded to BUTTON 28 (“not full forward, one click in the middle”) and it goes the very same way.
It’s like “Press-maintain the PROP LO button” is the issue there.

What about you ?

Problem is : this was MY issue.

It may not be yours.
I’ve seen people talking about A32nx in the thread.
TCA has no binding by default for the PROP LO.
Maybe the issue doesn’t only exists with PROP LO, but also with something else.

I’m missing time for more research, espcially to try to recreate the issue somewhere else.
Maybe we could all try to find which button and/or functionality causes that on our sims ?
What are the buttons that are engaged when you encounter the bug ?


Interesting. That would definitely help explain why it seems to be an intermittent problem.

1 Like

Ok, just passed 30 minutes trying to figure and…
mine is doing it because of any perifericals that has a little bit of shaking so when i took off the usb the bug stopped!

1 Like

instaled a HUB, so when i need to use mouse i turn off the joystick and then when i need to pilot i turn on ! hope to help u guys also

1 Like

Still there for me using a Warthog and Logitech G Saitek Pro Flight Rudder Pedals. Just tried to see if any button or axis caused the issue and nope. Just happens randomly.

Did you confirm that all the warthog throttle’s switches are in the position and whether that makes any difference?


Yeah looks totally normal there and no movement of the axis happen without me moving them.