MSFS will not change audio device after startup

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

NO

Have you disabled/removed all your mods and addons?

YES

Brief description of the issue:

I have several audio devices. After starting the sim, if I attempt to change audio device MSFS will remain on the one that was active when it started. All other software happily changes to other devices.

This is especially a problem for VR as I can not switch into VR and have the audio go to my headset. However I have tested in and out of VR and the problem is the same regardless… MSFS will not respect system sound device

This is a new problem – I think it is SU12, however I have not played in a few months and it could have started earler.

Provide Screenshot(s)/video(s) of the issue encountered:

N/A

Detailed steps to reproduce the issue encountered:

Start sim, change to a different audio device. System sound changes to new device, MSFS does not.

PC specs and/or peripheral set up if relevant:

9th gen i7, 32gb ram, Nvidia 3070Ti… Audio is Motherboard onboard ASUS, USB, and Valve Index

Build Version # when you first started experiencing this issue:

1.31.22.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I am having the same issue, so following here

3 Likes

please upvote too… helps visiblity.

3 Likes

Hi,
Just to be clear, when you say, “change to a different audio device”, are you talking about in the MSFS settings, or in the Windows mixer, or something else?

I mean changing devices in the windows audio settings, OR in the MSFS settings.

If I change them in MSFS it will start working after I shut down and restart MSFS but not before.

If I change them in windows it will not take effect in MSFS till the next time I start MSFS… THIS IS A PROBLEM… in the past, changing it in the Windows Audio settings was immediate (with MSFS set to system default)… Now it isn’t. MSFS is the only program I have that can’t seem to respect windows audio settings… It used to, but not now.

2 Likes

I want to say it might have been earlier than SU12 that I’d occasionally seen this. But with SU12 if I want to switch to headphones output, I have to shut down the SIM, switch audio outputs from speakers to headphones and then restart the SIM. Also do not have this issue with any other application.

2 Likes

I have set the audio device to “default” in the sim, it changes audio device no problem when switching to VR, Headphones or speakers.

I do not recall ever having this issue, but then I do not switch audio output that often when using MSFS. If I recall correctly the sim settings I use for audio are set to use the default Windows sound settings. When I do want to switch output I drop back to the desktop (I run the sim in full screen) and change the output device via the Razor app on the taskbar… maybe this is why it works for me, but I believe this is doing just the same as changing the windows audio output device :thinking:

I have the exact same issue.

It used to work that way for me too, but not anymore.

Disabling that does seem to work (will try with VR later, can’t get into it right now).

I’d love to mark your suggestion as ‘Solution’ but then MS/Asobo may not correct the core issue. However this does appear to be a functional work-around. Thanks!

1 Like

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

NO

Have you disabled/removed all your mods and addons?

YES

Brief description of the issue:

If I start the simulation with PC sound set to headphones and change sound output to external speakers the in game sound DOES NOT CHANGE. All other apps running like FSRealistic change to external. The same thing happens if the game is started with External Speaker as sound if switched to HEADPHONES the sim sound remains on headphones while all other running apps change to speakers. To change sound output in the sim the game has to be restarted.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Start sim then change Windows sound output from speaker to headphones or vice versa.

PC specs and/or peripheral set up if relevant:

HP Omen 30L nVidia 3060Ti Graphics using HDMI as sound

Build Version # when you first started experiencing this issue:

1.32.7.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I have exactly the same problem and the workaround worked correctly for me. Nevertheless, I am not very happy about losing the spatial sound option… Asobo should fix this.

Strange, i don’t have this problem, with or without ‘Active Spatial Sound’. I leave the MSFS-audio to ‘default’ and use SoundSwitch to switch between all my audio in/outputs. Never had any issues with that. Only GSX and FS2Crew engines sometimes need restart after switching audio.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

What is the workaround?

Deactivate spatial sound

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, exactly the same

Provide extra information to complete the original description of the issue:

OP is complete, no further details required

If relevant, provide additional screenshots/video:

N/A

Same here, switching default audio device in windows does not change sound output. Also manually selecting the device in sim does not work

I find it easiest to just switch to whatever device I need on the fly using Windows System > Sound settings. Lots of programs I have don’t switch automatically and I switch between outputs a lot. With MSFS I start it, switch to VR then just enable my wireless headset and it works.