New computer new Windows 10, new MSFS2020 install crash to desktop with USB joysticks plugged in

Everything was working fine on my old PC but after an upgrade to a new i9 10850k, Rog Strix 490Z-E, 64GB DDR4 this is what happens now.

Every time I start MSFS202 with any joystick or flight sim controller attached it CTDs as its loading

New M/B, CPU, Ram, so all new USB ports all 3.0 or above, no USB 2.0 ports on the board like my old one had, fresh install of Windows 10, Nvidia drivers and all M/B drivers updated.


TM Warthog
CH Rudder Pedals
Saitek Throttle Quadrant
Derek Spears button Box
Razer Orbweaver

Download game with or with out USB joysticks connected as it makes no difference.

Start, installed game and update.

No USB device connected except Keyboard, Mouse, HP G2 VR Headset and Logitech G333 dongle = start game, check for updates, boots up runs fine get in a plane and fly using keyboard and mouse

Plug in USB joystick, any joystick or joystick combo from the above list, in any USB port or in any of my 2 powered USB hubs = start game, gets to check for updates, starts to load, CTD with out warning.

Unplug Joysticks, start game wait for check updates, loads game, jump in plane fly, its repeatable every time.

Just some information about what I have done so far

I have tried each of my joysticks individually and it crashes with any combo /single item of the following Thrustmaster Warthog, CH Rudder Pedals, Logitech throttle combo.

Important info if you have the STEAM version.

Rinse repeat as many times as I want each with the same result, at first i thought it was corrupting the game but this was due to doing an integrity check of the game files through Steam, this check REMOVES all of the game files and you need to reinstall, its a well documented bug on the MSFS2020 forums but is a Steam issue not a Asobo issue.

I have set the USB devices in Device manager to not switch of fpower to any USB device>

I have set a high preformance power usage setting for the PC

I have no hardware failures on any of my HOTAS gear, it all works fine in every other sim with out issue on the new machine, DCS, IL2, Xplane 11 & BOB

Im at a total loss why this would happen, all I can put it down to is the USB ports on my new motherboard are different to my old mother board, but I cant see why this would make any difference at all.

I cant find any crashlog for MSFS2020 any where (Steam Version)


Check your…

Uninstall anything with a conflict red x. Or prevent it from working including services if needed.
I had issues with Razer software… uninstalled all good.

1 Like

It’s something to do with the the set up for joystick configuration I think. This problem CTD after latest update (Update #5) - #306 by OldFogeyPNW .

I think this is what happened.

The setup for your controls is kept online connected to your XBox ID. At some point this storage format was changed, and the upgrade only works sporadically. So the set up for joysticks got stuffed - mine was a very ordinary T16000, which displayed exactly the same characteristics of CTD that yours apparently does.

The setup is stored in XML files, one for each device, and when they are wrong, the simulator crashes when you plug in the stick- it tries to read them, and finds them wanting.

These config files exist somewhere in the FS2020 tree, and have to be amended or deleted (from memory, I just deleted mine and set the joystick up again, but I’m not sure you can just delete the lot - have a look at that thread and similar).

It’s a known problem, so it might maybe be fixed when they release the update tomorrow (?). It shouldn’t be a complex fix, if the file is corrupt, just bin it with a warning message rather than CTD.

1 Like

I had a similar issue with my headset, I have reinstalled the drivers and then was all good. See if there is any driver update for your joystick. I had one firmware update for my thrustmaster 16000 hotas for example.

Installed MSFS202 on my old machine using my computer parts that were running MSFS202 prior to the upgrade and same thing, 2 PCs exactly the same scenario as I have posted, crashes with joysticks connected and works with joysticks un-connected, I belive its something to do with the Xbox login and the joystick files being stored on the cloud and its not getting them.

Im going to create a new Xbox login as I have the Steam version so hopefully its not tied to my MS account, and see how it goes. If that doesnt work I will wait for the patch and if it doesnt work then I will wipe it off until the next patch as I have given up way too much time to this issue for now.

I can not find any XML files for any joysticks any where for my MSFS2020 version (Steam version)

Any idea what they are called ??

Well its fixed but what a nightmare of an issue to find information about.

I had heard mention of some joystick XML files that held the joystick data and if this became corrupt then MSFS2020 would crash with out and warning or error msgs on load up (this appeared to be my issue), how ever using the Steam version these files don’t exists as they are only for the MS store version, however I saw a post for some one looking for the Steam joystick files for MSFS2020, and after extensive looking he located them here.

C:\Program Files (x86)\Steam\userdata\23149991\1250410\remote

I backed up the files, and then deleted the contents of the remote folder, started MSFS2020 and it loaded as if I had just purchased the game today, asked me my experience settings, told me it had found all my controllers and loaded the game up fine with all my controllers showing but with clean bindings, rebooted and a steam msg came up saying my new created files were newer than the ones on the steam cloud and did I want to download my old files or replace with my new ones, so I replaced and now all is good.

So the issue was corrupted joystick files, 1 for each controller were corrupted and each time I started Steam it downloaded the corrupt files which brought MSFS2020 to a scream halt CTD>

So if you have the Steam version, back this folder up at least once a week or if you make any changes to joystick bindings just incase your Steam cloud files get corrupt.

C:\Program Files (x86)\Steam\userdata\23149991\1250410\remote

I like to say the people who programs this stuff needs to think a bit more of the end user, if files get corrupt just let the program bin them and take the user back to at least a fresh start, all I did was delete the folder and MSFS2020 started afresh, how hard would that check take to put in place instead of CTD’ing with out and logs


I did exactly what you said:

  1. Found my Steam data folder.
  2. Backed up all files
  3. Deleted all files in the above folder
  4. Started MSFS (I also had the above folder visible on my screen)(Note: It DID NOT respond the way yours did. It DID NOT act as if I had just purchased the game today, nor ask me my experience settings, and DID NOT tell me it had found all my controllers and DID NOT completely load the game.)
  5. As MSFS loaded up, I saw the files repopulate in the folder. All had old dates, but I was expecting to see the current date.
  6. MSFS still crashed while loading.

What did I do wrong here? Where are these files being copied from? Their source seems to be the problem. Thanks for your with this so far.

The only other thig I did was untick “Keep games saves in the Steam Cloud for Microsoft Flight Simulator” before starting the game.

This option is under Properties for Microsoft Flight Simulator and on the General Tab, then I restarted the game and thats when it went through as if I had just installed the game, and the next time I started it after setting up my controllers this otion was re ticked and then it asked me if I want to download my old files to replace the new ones, which of course I said no.

I think your just grabbed your old currupt files as you started it, im sorry I missed this step out.


You just helped me tackle three issues with your last post! First of all, unchecking the box worked like a charm! After unchecking the box in Steam, I erased all the files in my Steam data folder and proceeded to load MSFS (even with the suspected joystick plugged in that caused the program to crash before). Well, MSFS loaded up! I was also presented with initial option screens that I had never seen before too! (That was the second issue you helped me with). Another issue was that my version of MSFS proceeded to update to today’s UK version (something that it wouldn’t do earlier today before I unchecked that box in Steam and deleted the old files). I was very pleased with this third surprise. However, I must have also deleted my flight log, because my log showed zero entries. But you told me to backup everything before starting all of this, which I did, so I copied the old logbook file into the Steam folder and all is good! Thankyou for all of your efforts!!! Do you work for Microsoft or Asobo lol?!

1 Like

Ha ha glad it helped you out it took me 3 weeks to find this issue and I had basically given up.

Its such a stupid bug to CTD with corrupt joystick files, I cant call it clever programming.

1 Like

Wow, it turns out I am not the only one everyone else is having it too. I can’t even open my flight simulator

Same. None of my controllers work anymore. CTD straight away anytime one is plugged in. Definitely tied in with my profile. I can unplug all my devices, start MSFS, log out of my profile, plug my controllers in, and they work just fine. The second I log in and MSFS syncs to my profile, CTD all day. I can log in as a different user, no CTD. Asobo or Microsoft absolutely dropped the ball on this one. They said this fixed? Nope. Fresh Windows and MSFS install. The second I log in with my profile, done.

1 Like

had the same issue. Followed this POST and got it working again.


Well that was no fun, but it worked! Thank you very much.

Can you tell me where you found your logbook file?

Sorry for the delay. Note that your folder numbering may be slightly different, but you’ll find it.

1 Like

Thank you for your effords, but I have the CD version. Not one of these files is on my ssd.

I didn´t work here, somehow even deleting XML file, once you start it doesn´t ask for anything and crashes, i even tryied a new user. Did not work…

Hi, could you please help. Same problem here, i tryed every tip, formated PC 02 times with fresh windows, steam and MSFS install. Works but with no controller. Every time connect a controller - crash. and my pc is brand new - i9 10900, rtx 3090, 32 ddr and all the best. No way to work it here…