New Xbox Build

Downloaded something as I switched on Xbox. After that I started the sim. Planned EGNT to EGLL and stutter free, smooth flight, real weather, all players, flight plan followed - no way points, STARS followed and landed with no hiccups.

I use a V1 Tab but the indents did not work that’s all. All ground traffic on arrival

1 Like

Hello @MachXBOX6861,

Please try the steps described in this post:


Hello @lemonmen72,

Please try the steps in this post:


Ya me too. I’m not sure what I should do here, I still have no sound on flash screens, no spinning icon for update checking and the horrible turbulence with weather and wind turned off…?

Xbox series X

Wilst clearing the reserved space does indeed work ive had to do this 3 times over the past couple of months and redownloading 120Gb of stuff is a right royal pain on my internet thats about 5 hours .
Any one know if Its possible to put 2 copies on my xbox series X if one is on the internal hard drive and one is on the small 1TB plug in ssd drive and use that as a back up copy when one stops working Ive copied games from one drive to the other and thats done very quickly

1 Like

I hate to say this because I adore this sim…

Honestly, it’s not even worth trying the

Don’t get me wrong, it works.

But, prepp yourself for a multitude of random crashes or, in-cockpit screens not working, or ILS just not operating correctly, or VFR map not working (no zoom/scroll).

One day may be trouble-free.

Log in after a sleep, the thing is broken.

That said I do believe it will eventually get sorted. I have to believe it…


This recent action goes to show that Microsoft and Asobo are pro active and do respond to users criticisms. Within a few days they have put together a fix which cure many of the irritable problems of the previous offerings. All those grouchy MSFS users who wrote here that were ready to dump the product or ask for refunds need to take a deep breath and in the words of the great Douglas Adams - “Don’t Panic!”

MSFS might not be perfect at the moment, but we are at the two year start, of a ten year development. We’re here for whatever the bumpy ride might bring, but even so, we currently have the best jaw dropping graphics, and relatively inexpensive, domestic flight simulator our money can buy.

So again, thank you Microsoft and Asobo.


Its still not working for me, im using cloud gaming

I make a tiket, for helping with this, and this help me: I had to redownload a 98gb… (I have a lot of planes) and close totally FS. Restart a goes usually :sunglasses:

This patch seems to have resolved all (so far) of the CTDs that I was experiencing. More than that it also seems to have made the SIM more fluid with far less jitters.

I’ve tried several flights and landing challenges and these have gone flawlessly. It reminds me why MSFS is an amazing piece of software and also my favourite Xbox app.

We have such a strong and vocal community for this SIM that it would be a shame if Asobo didn’t make use of this as well as the exceptional developers they obviously have to prevent this kind of release problems happening again.

Basic content mandatory packages have you noticed that this module keeps constantly with a message saying restart the game to update from su 9 even after restarting the game, I am redownloading the modules as it was said but I see that on this module the same message appears

1 Like

although it does work now, it takes several minutes with the blue bar at 100% before the flight planning screen appears. In total it was 11 minutes from start of ‘Game of the Year’ screen to the flight planner (or rather the screen that is one before the flight planner – ie, with marketplace and training etc)

will clearing the reserved space and starting over help speed things up?

and why does a content update REQUIRE some sim update that apparently you (Asobo) can’t tell us about??? I appreciate the increase in communication but I personally would still like more info. What needed to be updated so that WU9 would work? DX12 code of some kind?
I feel like my XBS can’t handle any more updates.

Xbox Cloud Gaming

Tried multiple times to get in, always crashes 3/4 of blue line.

Oddly, I did manage early morning (UK) Saturday to get in and download the new World Update, but its crashed every single time since.

I feel your pain. I lost 268 hours then 453 hours on 2/28 with that update. I have or my have just lost 449 hours with this update. I don know for sure yet becausr i still can’t get into the game.

1 Like

I too agree 100%! Just let us know what is happening. Just a once a day notice would be nice.

1 Like

Hi @SeedyL3205 . Thanks for sharing. It seems this is for XBoxes, right? I use a Dell PC Inspiron15 with seemingly enough specs to run the game. So I don’t have the menus that you mention in that comment. I open the XBox app in Windows 10, and the options to change things are limited. I only have a “manage” option where I can either change drive for installation or uninstall the game. Any idea on what to do for us Windows users?

I’m on the beta and by loading a flight CTD every time. Saturday I done 2 flights without problems and since yesterday I can’t load the flight without CTD

Good morning MSFS. My FS will still not load. My game tag is UNDERDOG1728 and I’m an Xbox X user with the cloud.

still getting CTD when trying a flight from world map. XBSX

Downloaded all updates and working fine, just a few seconds of pausing before able to click on start flight. Once loaded all flights nice and smooth, no crashing.