New Xbox Build 1.25.12.0

KrispyCom
Xbox One S

EliteTitanXI

6755425965162453

Xbox Series X

KrispyCom
Xbox One S cloud gaming
Still not working

Ansetu

Xbox Series X

6966522117426159

Thank you to everyone who has helped verify our fixes and workarounds.

For any Xbox Series X|S users still experiencing crashes during loading before arriving at the main menu after installing the 1.25.12.0 update, we suggest clearing your reserved space as a next step. This has been confirmed by multiple players to resolve the crash on startup. Please note that performing these steps will delete some of your locally-installed content and settings including:

• Installs from the Marketplace
• Rolling cache
• Bush trip saves
• Graphic settings for HDR
• Local profile - data options
• Traffic settings

You will have to re-download and/or reconfigure these settings after completing the following steps to resolve the crash on launch:

To clear your reserved space:

  1. Exit out completely of Microsoft Flight Simulator
  2. Press the Xbox ‘Home’ button
  3. Highlight ‘Microsoft Flight Simulator’ and press ‘Menu’
  4. Select ‘Manage Game and Add-ons’
  5. Highlight ‘Saved Data’ and Press A
  6. Highlight ‘Reserved Data’ and press A
  7. Select ‘Clear Reserved Space’

If you are still experiencing crashes during launch (before arriving at the main menu) even after clearing your reserved space using the instructions above, please respond to this forum topic and let us know.

For players on Xbox Cloud Gaming, so far we have not seen any reports of anyone who is still experiencing this specific crash during startup after the deployment of today’s update. If you are a cloud player who still cannot launch Microsoft Flight Simulator because of this crash, please reply to this thread and we will follow up with you directly.

Thanks,
MSFS Team

8 Likes

All working for me on XCloud now!

2 Likes

so we have to delete and re download all the content we purchased. The game does not allow you to download content if the xbox is off, you have to have the game up and running for content to download and install.
Why we cannot download via the marketplace on xbox dashboard like other games is beyond believe. Since when do you have to be in game to download content anyway?

Me too. What’s weird, though, is that XBOX achievements related to certain flight hour thresholds still remember my previous progress. My guess would be that it’s because achievements are tracked and stored on the Microsoft servers separately from Flight Sim logbook data.

2 Likes

Yes same here, my next achievement is 400hrs but I’m back to only 27hrs

1 Like

GalvanicToe669
Xbox series X
6755425999562222

SeedyL3204,

I’m up and running but it was a struggle (Xbox x). Nothing worked for me (including the Beta) until I uninstalled and reinstalled the sim and restarted the console several times this morning. I DID NOT reinstall the WU9.

Seems to be working good now but I’m apprehensive on installing the WU9. What are your thoughts?

Thanks for the efforts and communication. I’m sure this wasn’t fun or easy for your team either. “This too shall pass.”

2 Likes

Hello @WorldwideGull8,

You should be fine to install WU9. The bug that was causing this Xbox loading screen crash was introduced with patch 1.25.9.0 that was required for WU9, not the World Update itself. This issue has been resolved with today’s 1.25.12.0 update.

Thanks,
MSFS Team

@SeedyL3205

Thank you.

Thank you for communicating with those folks who posted here.

My biggest frustration in my relationship with MSFS 2020 isn’t the bugs, or the workarounds, or the inconsistencies with performance, or the fear that the next SU/WU will break my working simulator — it has been the lack of communication with the people who own this IP and run this forum.

The way this situation has been handled is, by far, a massive step up by the entire team tasked with resolving this crisis.

This change in process has been most welcome and appreciated.

Please, pass my gratitude on to everyone involved.

:pray:t4:

11 Likes

Hi! I just installed MSFS for the first time ever. It took 12 hours to download and then when starting and showing the screens that say Italy and Malta has been added then the window just disappears. Like the game closes without even an error notification. I see from other posts that this update is giving problems. What shall I do? Wait for a few hours? Days? Weeks? I’m new to this and don’t know what’s the next step. Will it be solved by you without me knowing or will I have to re-download all again when you find the fix? Thanks!

I’m pretty sure people shouldn’t be posting their Global ID publicly…

I 100% agree. We users can live with just about anything if we knew what was going on. Not asking for inside infro just the knowledge that our concerns are being looked at and trying to be addressed. We all know this is a long term project with lots of moving parts.

Thank you.

dw

2 Likes

Is this still in beta? I ask because I’m still in the insiders beta.

oRizql

Xbox series x

Haven’t been able to get on for around a week

CTD as soon as I tried loading Heathrow and any plane. XBSX

It did not work for me, still crash on loading

Xbox series x