NO Photogrammetry loads in game

Hi all since I’ve got MSFS I have no photogrammetry appear in-game on any level. Even in the world map view I don’t get detailed world views just roads.
I have dropped a ticket ( Request #115225) to support but maddeningly they didn’t look at any of the ticket content and give me some spewed generic do this that etc. I have tried running everything on high, med, low Ultra also with no change.

I am currently using the Steam version
My system is:
Win 10 pro
i7 7700k 4.20ghz
48GB Corsair VENGEANCE DDR4 2133MHz
(Prime Z270-P motherboard)
Main drive is 1TB SAMSUNG PM961 M.2, PCIe NVMe
I have 2 other SSD, SATA 6Gb/s for game installations with MSFS installed on one of these
Corsair H80i V2 Hydro on my processor
Zotac GTX 1660ti graphics card

I have an ethernet connection through Virgin Media(UK) 200mbps (on average 213mbps down and just over 20mbps up)

Game mode is turned off in Windows settings and Hardware accelerated GPU scheduling is also off
I have attempted as many trobleshooting processes as I could find in other threads and generated ‘advice’ from support.
All options are turned on(turned off and on again with restarts) under data bing maps, photogrammetry , I have tried with turning off rolling cache, increasing rolling cache to 50gb and deleting manual cache.
My profile shows me as online and I have connected manually to a server in europe not using automatic, connection shows as roughly 35ms
All pending updates have been installed, in fact I’m on my 5th install due to other installation bugs freezing etc. (apart from the time to redo this, I’m semi ok with that)
I’ve removed all add-ons in my Community folder.
I am not using Developer Mode or made changes to it.
I have refresehed connections to Xbox PC app and MS Store
My time settings are always sycronised and I have also installed language packs used in game i.e. Eng US
I have disabled all programs that potentially cause issues from the ticket list
MSFS is whitelisted in Windows defender for all transations with the servers
I have also tried turning on teredo (very slow ping of 161ms, Nat type shows as open but connected)

When I’m in-game and keeping an eye on task manager, I see little to no attempt from the game connecting on the ethernet. I’ve included some screenshots from Rome as a photogrammetry city and others showing connection whilst in game and a speedtest from my ISP. Thanks for any help or advice.





Is photogrammetry actually available for where you’re flying? Check this topic.

Yeah Rome is definitely on the list. Even when I go to London I get some landmarks but default scenery otherwise

Sorry, I missed the reference to Rome in your first post, this doesn’t seem to make sense to me. My London looks vastly diffreent to yours with photogrammetry turned on so you have a definite problem.

Maybe your ISP is doing some throttling despite your good internet speeds, your DL speed is the same as mine and I don’t have this happening - though, for me, since the last update (and the extra XBox fliers) the quality of photogrammetry for me over Tokyo where I fly quite often has had a noticeable drop in quality.

I thought it might be interesting to see the difference, so I’ve gone to your approximate location and taken two screen captures. The one with photogrammetry turned on is different, but the difference is smaller than I expected. However, it clearly shows a difference from what you are seeing.

No photogrammetry

Photogrammetry on

1 Like

Rome has for sure very detailed photogrammetry.
See this video I made yesterday:

2 Likes

I can accept I need an upgrade on my card for sure but I don’t think that would bottleneck data being rendered in-game. That second screenshot is awesome. I took a couple of videos with ethernet performance and network statistics on. I’ve kept them sort as I can. You can see there is little communication for sending and receing data:


I have the same issue. 811 Mbps download internet speed, but no photogrammetry is downloading in London. The photogrammetry has been great before SU5. PG is ON in settings.
I have had problems earlier this year as well, so it seems there are problems at specific times.
I got warning that my internet connection couldn’t handle the PG, but as you can see, there is definitely not a problem with my Internet, which is super fast - Fibre.

2 Likes

I wonder if it’s worth trying to force the software to change what it’s storing in cache by changing your settings to very low, tunr off photogrammetry, clearr and delete your cache and then restarrt with the low settings and fly arouhd for a bit.

Next turn photogrammetry back on, set up your cache again (I use only 5Gb cache in case that’s any indication), return your settings to high, but not ultra and then close the sim and restart again.

Logicall, this shouldn’t make any difference; however, in the light of your difficulties I would give this a try if I was in the same situation.

Good luck.

1 Like

i have the same issue , being trying everything but no luck , even reinstalled the entire game

1 Like

Cheers for the replies guys. I’ll certainly give this a shot Pscaber. Although even before SU5 I have had this issue. Currently following TS’ing on another thread I seen (https://forums.flightsimulator.com/t/psa-photogrammetry-not-loading-quickly-a-fix/406363 ) which requires setting a static IP and opening certain ports. But everything is valid to try. I did try manually caching a particular area by pre-downloading and interestingly this never showed in game either

My biggest takeaway from my own videos is that either the Sim is not communicating properly on a rendering/request level from the servers or my ISP is somehow limiting/tracking this and keeping it low. Not sure how packets are requested from game to server. I know when I do speed tests the signal takes a couple of seconds to get passed the quoted 50mbps by MSFS tech ‘support’ (I dropped my original ticket on 01/08/21 and have just received ONE reply in 8 days).

Just as an added note i originally had MSFS on XBOX PC game pass and opted to purchase on Steam as the folders are hidden/locked through game pass and not easily accessible without changing admin permissions etc. so potentially there maybe ghost files in a residual form from the game pass version I had.

This makes me wonder if you should try deleting your cache and then adding it again in a different location - in case the system is trying to cache data where the Steam version had stored its cache.

1 Like

I did set up a Rolling cache folder specifically in a different location but I’m unsure if the sim is taking information from an old CFG file potentially and using the old one. I also just finished trying your suggestions to no avail unfortunately.

I did another flight over London today, with the same problem - the PG didn’t load in, and only melted blocks over the city. I then changed to Rolling Cache with a 50 GB rolling cache limit and then the PG started loading in. I still think the LOD of the PG is very bad as the melted blocks started appearing when I climbed to 6000 ft. At 1500 ft I also think the PG disappear to early and melted blocks appear instead.

3 Likes

Before I changed to Rolling cache:

1 Like


After I changed to Rolling Cache:

1 Like

I’ve tried absolutley everything, forwarding ports, checking language files. Even tried under a VPN to make sure my ISP wasn’t throttling my connection to the servers. Reinstalled on to a faster SSD Other than a fresh install of Windows which might not even solve it and customer support’s lack of trying to resolve anything. 9 days and 2 generic responses. The sim for me is a train wreck. I presume there is a network issue of some kind that is timing out my connection to get PG as you can see from these high pings on ports requesting information. I’ve tried running with a static IP and unticked any IPV6 boxes on the network.

Actually just checking here on Network monitor, I have 2 connections from MSFS running to these N America connections, is this potentially causing me an issue?

1 Like

Pinging 202.89.233.71 from CMD in admin mode shows as a timeout. 202.89.233.71 is the bing maps site when I put this IP into google. Checked all my firewall settings but nothig is blocked there and don’t know why this results in 100% packet loss. A potential cause of my issues and I’ve tried using different DNS such as 8.8.8.8 and 1.1.1.1 and is still happening.

I presume you’ve checked that there aren’t any rules in your modem/router for port forwarding or blocking sites/ip addresses.

Tried temporarily disabling your anti-virus software? I presume you’re only using windows defender, and aren’t running any other monitoring software?

This is a bit of a mystery, as it seems you’ve already tried everything I can think of.

The lack of response to pinging 202.89.233.71 also occurs on my Macbook so this is probably not relevant to your problem.

1 Like