Not Receiving Fire and Ice / Anemoi Achievements on Xbox Series X

Same here I completed the all the necessary bush trip flights with achievements except the Nevada one I’m on leg 12 and all of them still say 0% without me using Get me back on track feature. I used the autopilot nav but that shouldn’t effect getting the achievement.

Still broken Sept 2023


Same here. Just finished it, no achievement.

same here. please fix

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

i reseted my cloud data. but i have not achievement anemoi when i clear every course

If relevant, provide additional screenshots/video:

please fix this issue. i wait for 1 year.

Oh… i forget explain my situation. i play with PC. but. it is not only Xbox, but also PC bug too.


This bug is over a year old and needs offical acknowledgment, please.


Same problem. Have tried bush trips on Xbox fully and on PC fully and haven’t received an achievement. Frustrating to say the least.

It has been acknowledged already. They’re looking into it as of last dev stream.

1 Like

My post was merged from an alternate, unacknowledged, thread.

It seems a bit out of place here…

1 Like

Same problem here, I play laptop steam and with xbox account connected. Completed The Balkans Trip and The Patagonia Trip and no achievements… I did not use the “back on track”.

Same problem as everyone else.
Completed “Fire and Ice” Activity, says 100% in-game, never used the “back on track”: but no achievement recorded.

Very Frustrating. Also noting it’s almost 1.5 years since the original thread post.

PC, Steam, win11.

1 Like

They are hoping to have a fix done to go with next WU.

ok. I reply to keep this up, so Devs can hopefully see this and fix it.

It would be nice to at least hear that they are aware and at least plan to fix it.

Achievement popped without any issues.

Are you guys making sure you’re not using RNAV (GPS Navigation) with AP engaged? I didn’t fiddle with the PFD once since I started and never used autopilot therefore, just good old stick and rudder. Finished Balkan trip and updated it the second I came to full stop on last runway.

I did it all in a week, like 2-3 legs a day. After each landing I pressed Continue, then left to main menu and started again by selecting the activity (I wanted to make sure it is logged).

I don’t know tho, in my book, navigational assistance counts as using autopilot, which I did not use, but then again, as an airline pilot, that can be a vague phrase because the route is pre-selected in the PFD by eans of RNAV, there’s a flight plan in there, and RNAV navigation is also navigational assistance, so I don’t know, by all means I don’t want to force anyone to re-do all flying by hand.

Also, noticed that in Balkan trip the FPL is bugged at one point because each time I take off, when I check out the route (which is pre-inserted), the active leg keeps being stuck somewhere towards the initial phases of the flight.

Good luck guys

I did the Balkans trip with no assistance or use of autopilot exactly as you describe and didn’t get the achievement. I noticed the legs getting stuck on an early part of the route. Got the impression it might be fixed on the full release of sim update 15

I don’t know what to say (I played on Steam btw). I just flew from point to point, never got lost or overshot, I chose the correct runways to land on based on wind direction info. I mentioned the AP part because in so many places I see people refer to as using it and not getting it. Oh also worth mentioning, I timed my flights every single time as well on the left side of the screen but I doubt that’s what causes it to pop or not.

And also,I never crashed or froze or anything. (no post edit function, sorry for double-post).

Autopilot shouldn’t affect it. At least it did not with Patagonia, but just to be sure I did fly it without in the Balkans and it did not work. I had no trouble with anything, the whole thing went perfectly.

Flying around, even landing at wrong airports and restarting shouldn’t hurt either. I did that a lot on Nevada as the plane didn’t have an AP and I was very new to the game. It worked perfectly the first time (Patagonia took me 2, but I used AP both times). However in one spot it cut a corner rather far from the point. I think that caused it to fail the 1st time as that’s the only change between my two flights.

I think there may be some small thing that triggers or fails it and we just don’t know what that is. You got lucky, most of us don’t lol

It definitely needs a fix. Or at least a specification that tells us what we need to do or shoudn’t do.

Well, I had something way worse happen just now, so my whole profile was reset, everything lost, back to 0%. Sad.

Yikes! That’s no fun. At least you keep your achievements, yes?