Official Discussion: Hotfix

My first impressions are amazing!, clouds look so much better and the resolution from my 747 is fantastic too!

I have spotted that the dropdown menu in the flight planner when your trying to pick what runway/gate to start from doesn’t have any information though, it just shows blank, can anyone confirm this too?

EDIT: I’ve restarted the game and the dropdown boxes in the flight planner seem to be working again, on the whole, very happy with this one, cheers guys :slight_smile:


Just flew a flight in the Husky. The VFR Map showed the flight plan but no track showed in the Husky’s GPS. I was flying in VR at the time.

Strange as I see no change to the LOD!
I did some test before and after and the city buildings at Melbourn still pop in at the same distance as before this hot fix

1 Like

Mine auto updated ok, I’m in Perth WA

and the atc map is still weird. and the garmin doesnt show airport to airport.

I don’t know whether it helps, but I removed (and deleted) my rolling cache, and turned it on again after a restart.
Maybe that helps (but I don’t have any proove for that)

yep, mine was1

1 Like

Ha. Setup a simple LFMN - LFMN circuit but with enough waypoints to allow me to climb to 30,000. FBW 32NX. The sim stopped responding when I clicked the yellow fly now. Will try again now

Second attempt. It’s loaded in: I still get shocking performance when panning the camera and when changing for example from the normal cockpit view, then to the overhead panel and back to cockpit view. It almost freezes temporarily

This game is a joke. Finaly they fixed the weather and had no other problems. Now with this hotfix i have CTD after CTD. What a waste of time and money. I doubt if they can get this game stable ever. Can’t wait for XP12.

Not tested for very long, but looks promising here.

  • Did not see the update in the store, neither in the sim itself, but I was already in version, so aparently it was updated in the background. Checked in my updates and FS apeared as “updated a few minutes ago”.

  • Loaded the A32NX four times without a crash. I got maybe a 1/3 change of crashing before the patch.

  • Now I can pan around without performance degradation.

  • Ground textures at height and far away look very sharp.

  • In general, it was smoother than ever.

Hope in the next long flight it is still working stable.


That’s frustrating then. I was hoping that it would be something like that where the settings weren’t able to save.

It looks like that my CTD’s are solved in the 1.18.15 version.
I updated the game this morning and have no CTD’s when i’m loading big airports like Heathrow and Sydney.
Before this update I cannot load Heathrow and other big airports with standard and FBW A32NX airplanes.

ALT bug is not fixed…

I think my issue is that my 2080TI just isn’t good enough to be setting anything above High. I’ve brough lt terrain LOD and object LOD back to 200 (2 in cfg) and it’s better. Altitude temps seem ok so far

I took it out. Do the same. Its not updated yet

1 Like

just rename it to something else, run the sim, and when it works by itself correctly revert the name back. if you stumble into issues then it’s something in your community folder. easy.

My 2080Super works fine with Ultra settings…

1 Like

So I tested it now.

Without changing my Settings I lost at least half my frames (3080TI) but I’m pleased with the visuals again. The Temp bug seems to be fixed for me.
Clouds are set to Ultra but they look really unsharp and blurry

Overall I’m very pleased :slight_smile:

1 Like

I did not realise that there was an update. Suddenly I had the info in the top left corner that I am on 1.18.15. The update run in the background. Nice