[Optimum Performance Settings] For all Oculus CV1 Owners

Hi all, for those of us old school VR users who have stuck with the CV1 I have spent the evening finding some great settings to allow you to have a smooth and sharp VR experience with just modest hardware (lets face it, those of us still with CV1s probably aren’t packing the latest and greatest GPU/CPUs).

I am currently on an i7 6700k, 16gb ram and an RTX2070 (so pretty much the minimum spec for VR) and I was able to run with some pretty decent settings thanks to two main tricks detailed below.


Trick 1: Set your ASW (Asynchronus Spacewarp) to run at 30fps.

Yes it sounds gross to run VR at 30fps but nobody has the hardware to run at the 90fps native to the CV1 right now and the difference in re-projecting frames using ASW from 30fps vs 45fps is minimal and barely noticeable (in fact in my experience 30fps reprojection has been smoother!). It has been working great for those in Xplane, this is just a way to use this same trick in MSFS for now, until a plugin comes along.

To do this open the following folder ‘C:\Program Files\Oculus\Support\oculus-diagnostics’ and run the file ‘OculusDebugToolCLI.exe’. You will see a command line interface like the following:

image

Enter the following command: server:asw.clock30

If you have done it right you will see this confirmation:

image

I believe you will need to do this every time you start the Oculus service, I think it can be automated via a .bat file but I am not sure how, if anyone knows how feel free to add that in a reply and I will put it here.

This will now set the sim to run at 30fps in VR mode and re-project 2 frames for every 1 rendered frame, this saves A LOT of performance and is barely noticeable from 45fps reprojection.


Trick 2: Set the games internal render resolution to 50% and super sample it using the Oculus tools.

Thank you to CptLucky8 for this one! It is from his excellent 2070S settings guide, I just applied it to the Oculus Rift CV1.

Firstly set your in game render scaling to 50%:

Next, from the same folder as before (‘C:\Program Files\Oculus\Support\oculus-diagnostics’) open the file ‘OculusDebugTool.exe’ (this is the GUI version of the command line interface you used in trick 1). Here you need to set the ‘Pixesl Per Display Pixel Override’ to 2, as below:

image

Leave everything else the same.

There is a great explanation for what this does in CptLucky8’s thread but the short version is it uses MSFS’s great TAA upscaling as well as Oculus’ tools super sampling to render at a very low resolution but to output a nice crisp much higher resolution image to the headset displays. Again, this saves A LOT of performance

From here you can run the game and test the new performance. It should give you plenty of headroom to increase other settings whilst still keeping a pleasant VR experience.

For me I got a very sharp image (able to read most of the small text on cockpit buttons etc, about as good as can be expected from a CV1) and still had about 30% GPU headroom left on the following settings:

High clouds, decent shadows, ultra windshield effects (great for immersion) and even some reflections and AO, which is usually far out of reach for this hardware in VR.

Give it a try. I did a short test flight on a cloudy day in the Caribbean (no glass cockpit though, C152, my favourite!) and the GPU even had room to spare.

Let me know how you get on, but I hope my suggestions can help some fellow ‘hardware limited’ VR simmers our there too!

15 Likes

I’m slightly confused, if our registry entry is correctly pointing to oculus_openxr_64.json, do we need to do anything else with openxr? It says to make sure the latest version of OpenXR is installed from the windows store, but is that just for windows mixed reality headsets and the Oculus ASW settings are all handled from the Oculus end?

If reg point to oculus_x_64 your good. All headsets use openxr. It may ask you to download or update when you launch vr

Following as I also have a CV1 and I am experiencing some crashes for fs2020 apparently due to memory usage— I am using 16GB RAM…
Just did a test flight in Sedona with a Caravan with no issues- Trying the CDG Challenge and it crashes every time…

Thanks bud, good tips! Now i only wish i could actually read rhe gauges. Very grainy…as always with cv1 :grinning_face_with_smiling_eyes:

Thanks for the tips. Can definitely back the #1 up. Haven’t tried #2 yet. Did you make visual comparisons between 100%/100% MSFS/Oculus resolution and 50%/200%? I’m just wondering how much of the details are lost in the process.

Also the latest Oculus Tray Tool, 0.86.6.0 or later, can set the ASW to 30FPS and Super Sampling to 2.0, so you don’t have to enter things in an CLI.

1 Like

Did you verify headroom with the Oculus performance overlay? I applied both of these tweaks, and left the settings graphical settings more or less stock (medium/low for most things) and flying around DC I get something like -100% headroom with a 1080Ti and 7700k (which in theory should be a little better than what you’re running). Stuff far away looks fine, but the cockpit jitters around like mad because ASW can’t keep up. The only way I can get non-negative performance headroom is to lower EVERYTHING to low and and set render scale to 30%, and even then I can barely hold any performance headroom above 0%. It does seem to get rid of the cockpit jitter (as I would expect). Not sure what’s going on–I’m able to run the game a 4k (80% render resolution) with most settings high at 30-50fps depending on where I am, which is roughly what I’d expect for my hardware setup.

I’m using a CV1 with the latest PTC, 457.30 drivers, 1909 Windows 10. I’m running the windows store version, so Steam VR isn’t a factor. I’m using OTT to set supersampling and ASW, and I verfied using the performance overlay that I was locked to 30fps.

That’s awesome, I have marked this as a solution so others can see the easier way to do it, thanks for sharing!

1 Like

I was using the GPU usage shown in MSI Afterburner. By 30% headroom I meant that my GPU was mostly sitting at 70% utilisation although this wasn’t in a ‘heavy’ area. The Oculus performance overlay usually says something crazy like -150% headroom with these settings, I believe it’s because it is set to measure how far below/above 90fps you are rather than how much of your GPU you are actually using.

I believe the jittery cockpit is a bug with ASW and how it is interacting with OpenXR, I can get rid of the jitter by locking the game to 30fps and turning off ASW but it isn’t very playable like this (for obvious reasons) but frame-timing is a perfectly flat 33.2ms constantly. If I keep the same settings and just switch ASW back on the frame timings start jumping all over the place and the jitter re-appears. There is a thread about it over here, unfortunately it seems like something Oculus or Asobo must fix.

Many thanks @AaronEC and @CptLucky8. Your solutions work brilliantly.

I have automated the process as follows …

Go to the C:\Program Files\Oculus\Support\oculus-diagnostics folder and create a desktop shortcut to “OculusDebugToolCLI.exe”

Windows10 will probably prompt you to save it to the desktop.

Open the shortcut properties and add " -f Commands.txt " after the text in the target field

Create a text file named “Commands.txt” on the desktop and enter the following …
(leave out the “exit” if you want the window to stay open and allow you to check if it worked.)

Insert the following into the text file…

server:asw.clock30
service set-pixels-per-display-pixel-override 2
exit

Save it, then copy the file to the Oculus Debug folder (where the OculusDebugToolCLI.exe is)

Double click the shortcut you created to activate ASW30 and Pixel Override 2.0.

Load up FS2020 and enjoy greater clarity and smoothness.

Don’t forget to set your render scaling to 50% in the graphics settings while in VR mode.

6 Likes

Thx for the tips. I suggest you try out also without anti aliasing (no TAA etc) and render scaling 100% + oculus pixel override 1.5 or 2
I guess the sweet spot would be around 0.7 TAA and 1.4 pixel override while keeping most options on Low except resolution Ultra
Also have a look at the guide there for ideas of impact of each feature: VR Bang-For-Buck Performance Guide

1 Like

THIS! Thank you for these tips, they have worked amazingly well with my Rift CV1, RTX3090, i7-6700k, 32gb ram. With this I am able to get all settings to medium or higher (several of them on Ultra), looks and runs amazing. Thank you!!

1 Like

And would these instructions apply also to an Oculus Rift s?

1 Like

On the Rift CV1 I can’t beat the tearing of the edges of the glass and other vertical parts of the cockpit when moving the head, as happens when the vertical sync is turned off.

This works great. Now is there also a way to add “use FOV Stencil” to off … to your list?

1 Like

I dont seem to notice any difference when changing the ss. Is there some “apply” button or a specific flow to use it?

Well, I have been at this for 7 hours and I see no change in anything. I have read, read and read some more. Made change after change to everything I can. nVidia Control Panel - CHECK. Did everything above - CHECK! Back dated drivers - CHECK! Uninstalled OCULUS - CHECK! I’m so damned frustrated right now I could blow a fuse. I run VR in DCS flawlessly. Why should we, as consumers be forced to rip apart our systems so MS can make some money. I see nothing else on this forum that I have not tried.
System Specs:
Power Supply: Corsair RM850X
MB: MSI Gaming Pro Carbon
DUAL 2GB NVMe Drives. One in TURBO M.2 slot.
CPU: Intel i9-9900KF 3.60 ( I overclock MSFS2020 to 4.8 when possible.)
RAM: 32GB Corsair RGB RAM (No O/C of RAM)
Windows 10 64
GRAPHICS: nVidia GeFORCE RTX 2080 TI
Res: 2560X1040 (144Hx)
Dual DELL S2716DG Monitors.
Onboard Audio.
Oculus RIFT
All drivers up to date.

I am confused about this comment

There are render scaling settings in OpenXR and in MSFS2020 - which are you referring to and what is the recommended value in the OpenXR tool?
Also - wrt tools
Oculus Tray Tool has a Super Sampling setting - is that the same as Pixel Override in the Oculus Debug Tool?
Finally - I have tried to enable the HUD (Quest2 Link mode) using the Debug Tool but it doesn’t show - do I need to hit F11 or some other key?

Anyone know how to get OTT to work with MSFS. I cannot add MSFS to a profile as it will not accept the FLIGHTSIMULATOR.EXE in the C:\Users"me"\AppData\Local\Microsoft\WindowsApps\Microsoft.FlightSimulator_8wekyb3d8bbwe. How do I get OTT to work? HELP!!!

1 Like

I avoid the stencil by enabling the beta 24 via the oculus home setup window.

You could run the oculus cli tool and type help. It might have the stencil command which you can add to the commands.txt file.