Owners of GeForce 600/700/900 series cards, please chime in

Is this a new option with the patch? Does it retain the clouds? If yes that’s good to hear. Sadly I cannot test it for myself yet, still got around 8GB to download before I can play.

I tried your suggestion but it is not really a fix. All that seems to happen, at least for me, is that yes - there is no flickering, but - there are also no clouds, there seems to be just a haze in the sky.
Even if I change weather to storm or rain - still no actual clouds just a haze with light rain.

Yeah, that’s not really a fix. It’s a workaround that has been there all along. It just takes the clouds away all together.

If it’s the same option as before then that was known for quite some time, this eliminates the flickering but at the cost of completely removing the clouds. Pretty much the same workaround as flying with Clear Skies, but this can be useful in bush trips and landing challenges where you are not permitted to change the weather preset.

Ok understoood.

But you can still use Live weather, which gives live winds but no clouds. We have too many clouds in the UK, for free if you need some, but I won’t miss them ha ha

I’ve bought a used GTX 1060 with 6GB, which should be 2.7 times faster than my GTX-750TI. “I’m dreaming of a white christmas…”

1 Like

I hadn’t thought about the winds, that’s a good point.

Yep, live winds is a better compromise than clear skies and minimal winds.

Edit: live temperatures also

1 Like

I agree, it is. In fact, for my recent tour through Alaska, having no clouds has been a blessing in disguise…I can actually see the landscape lol

There is now a report of the GTX 1050 Ti experiencing the flashing clouds issue since the latest patch. Could owners of the GT 1030, GTX 1050, GTX 1050 Ti and maybe even the entire Pascal line-up chime in regarding this issue?

You can add the GTX 880M to this list. I have the problem too.

Ron

1 Like

I have a GTX970M in my Alienware laptop, it runs around 35+FPS and is using mostly higher settings. First I think that Nvidia should make a new driver to help combat this issue. Also before the latest patch, I was fine no flashing etc. Once the update was installed I started seeing the flashing/blinking screen. I found that turning off the “BLOOM” function fixes the issue for me, has anyone else tried that?

I tried that but did not make a difference for me.

I think yours might be a different issue, your GTX 970M is using the Maxwell 2.0 architecture which does not seem to be affected by the flickering clouds. Once someone suggested turning all settings down for a workaround which included Bloom as well, but it didn’t seem to do anything for me.

Check out the videos in the first post of the thread I’m linking below, are you seeing the same thing?

No sir not that bad

you are a lucky guy!

I second this cause I’m having the very same issues for now I’m flying without clouds wondering why I deleted the pervious fax before Msf fix there current bugs however it had improved a lot from day one.

Hey guys, I was recently told by Microsoft flight sim crew that they are gonna attempt to fix in next patch! For now turn volumetric clouds to off,

1 Like

Thanks for the update. Was that from a Zendesk support response or somewhere else? Can you post their exact response in here so we can compare them to previous ones? It was being suggested that they are fixing this but probably not for the next patch, though the Feedback Snapshot says that this is still being investigated which is very inconsistent…

Is it solved or not?Waiting for your response for dowload again