Owners of GeForce 600/700/900 series cards, please chime in

Yes CS I agree. I have run on my GTX770 since day 1 (Sep 18) with around half of my settings on Medium with a few on High and have enjoyed the experience with average of 20-35fps and only a handful of CTD in two months. If clouds graphics have not changed something has

1 Like

I have the ASUS ROG GL552VW with a 960M. It is unfortunate that the update invalidates all the support we have given to MSFS over the years. I purchased a PC clone (Seequa Chameleon) in 1981 and used Flight Simulator as the litmus test formPC compatibility. My only suggestion request short of asking Asobo/Microsoft to maintain compatibility with these older GPUs is to allow us the ability to revert to the last version so that we could have use of most of the features we paid for. It seems there are those of us who purchased MSFS 2020 who may not be able to upgrade our systems that would very much appreciate this option. It seems that during the automated update process this could be a decision point in deciding which sim version is installed. This is already being done by MS. My windows 10 will not update to 2004 yet due to my hardware. It seems that there are a significant number of us impacted by this.
FlyingFox

3 Likes

I have a GTX 960M, turning the TAA on doesn’t make a difference. Looks like I will be going back to Steam for refund.
Is there a way to download a version the FS2020 pre patch #5 update?

1 Like

He is talking about the AA of the Nvidia panel, not the AA of MSFS game. You need to turn the Nvidia ones OFF.

Same problem here since last FS2020 update.

GTX 750Ti.

1 Like

Unfortunately there is no way to download an older version of the game. The only thing we can do is submit a Zendesk report and hope they will change their mind on this. The more people send a report, the better our chances are.

2 Likes

Ditto, I have a GTX 750TI and cloud flashing started yesterday.

2GB gpu and 6GB mainboard ram, giving a total allocation of 8GB.

Xeon cpu, barely more than one core used (one thread + kernel overhead), 16GB ram.

With Xplane + Vulkan I was getting 40+ fps.

I was getting 20-30 FPS in MSFS with Render scaling at 70% and the rest of the settings a mix of low & medium. Not perfect, but was playable. (Kepler based Quadro K4000 in my system)

Now with the cloud flicker issue, it is only possible to fly with clear skies enabled.
This does not make the sim 100% obsolete for me, but close to it.
I have been simming a long time, and while flying in good weather is nice - the challenge and looks of “bad” weather are essential to a flight sim for me.

Fortunately I have another sim installed on my rig as well, which runs between 20-45 FPS at almost maxed settings and has weather…

I think it is great that ChaoticSplendid is trying to wake up Asobo not to forget about those of us with older, but still fairly good systems.

Just it would be nice if there was a few more replies to this topic. The more voices, the more likely we get a bit of a time extension till our systems become obsolete for MSFS…

2 Likes

There are a few duplicate topics…I think I’ve found all of them but I’m hoping there’s enough to be a ‘critical mass’ of users affected.

I too am currently flying in clear skies only. Not the same!

1 Like

Same over here. Gtx980Ti. DLAA got broken with the 1.10.7 update. In bright sunlight, clouds and horizon are awful. The bloom around the sun is no longer under “bloom” but under “lens flare” instead (really??)


No flickering clouds.

Those are the remaining ones I think, there were also a couple of replies in the Update #5 hotfix discussion thread, but they are kind of lost among other posts complaining about different problems.

I agree. I am in it mostly for the visuals, and not being able to enjoy the clouds and the way they affect the lighting, which is one of this simulator’s most gorgeous features in my opinion, is a huge blow. It also means I cannot play the Halloween challenge since there is no way to modify the weather, and even then I would be missing on the spooky cloud formations. Even if the issue is fixed eventually, the challenge will be removed in next week’s patch…

Unfortunately the amount of voices can only be as big as the amount of Kepler and Maxwell 1.0 users. While we are probably almost nothing compared to the entire userbase, based on the responses I’ve seen in the last two days I think it could be enough for Asobo to step up and do something. As always, the most direct way to communicate with the developers is Zendesk, and once they catch up with the reports we might get an update on what is going to happen.

Personally I’m not going to contact live support since they would just tell me that my GTX 750 is a lower number than the minimum GTX 770 even if it is a newer architecture, so I would suggest people using the GTX 780 Ti, GTX 960M or similar to contact support again once our Zendesk reports are marked as “Solved” I presume.

I don’t have a dog in this fight but this doesn’t seem legit. You bought a game with the understanding that you met the minimum requirements at purchase. They should offer you a full refund if this is the case.

2 Likes

Unfortunately it appears someone else with the same issue was denied a refund.

1 Like

Same issue, discussed under the thread “flickering clouds”. With a GTX Titan I was getting 30 -40 fps GA flying. Everything was running smoothly. Till the patch.

As a small update, my Zendesk report is now marked “Solved” which means they have seen my description of the issue and all the specific GPUs that are affected. Once more of you get this, it might be a good time to contact support again to see whether they’ve changed their mind on the matter.

5 Likes

@ChaoticSplendid I updated my ticket as well and awaiting their further feedback. I´m not gonna give up, I do think we´re the right ones here.
@bazonk3rs I´m not interested in refund, I want clear words from them if they´ve done this on purpose or just somebody forgot about something and now they´re covering it with “low HW bullsh*t”.

Buying a new card supposed to inevitable at some point anyway. I´m not gonna argue that, I just thought I´ll read something in an update like “we´re moving to new technology so some old cards will get deprecated, please, upgrade your rig”.

This would sound fair to me and I believe none of us will complain.

2 Likes

My Zendesk ticket regarding the cloud flicker is still open. Just an FYI.

2 Likes

LOL, made me laugh. :slightly_smiling_face:

My application is already accepted from zendesk and i hope that they do something with this bug

Yes I too have the exact problem, and I am running with a 960M. I have posted my issue earlier in this forum and I have also created a Zendesk report along with short video showing the problem.

I have tried many different Graphics settings/changes and nothing makes a difference.
My current updated GeForce driver is 27.21.14.5709. I also tried rolling back to the previous version but that did not help.

This problem only started with the latest MSFS Version #5 (1.10.7.0).

2 Likes