Pilatus Porter: Swiss Army Knife of the Skies

Released today from Milviz: PC-6 for MSFS2020

14 Likes

Yeah, and there’s already a lenghty thread about it.
Please check before you post

You mean this topic? MilViz PC-6 Pilatus Porter Released

If you look closely, I also created that topic @Archer374 :joy: I was part of the beta testing team and wanted to show off some screenshots of the aircraft in a seperate thread!

4 Likes

This is tagged as a screenshot thread.

1 Like

Well sorry about that. It’s just with every new plane there are several threads running parallel. Annoys me a little and made me overreact

3 Likes

Cant even get it to startup. Yes, following procedure in manual, but just keeps windmilling.

Follow the instructions in the manual or this video for the start up procedure:

Works every time for me :wink:

1 Like

Yep, that worked thanks.

1 Like

Nice photos! i have a blast with the Milviz Pilatus in streams and solo flight, however there is a curious problem : on cold start, sometimes it is working good OK, no problem, but MOST of the time, nothing, no battery, black screen for the garmin (i tried without and with the NXI, and now the integrated GTN750), the battery seems dead, and no way to start, even with ctrl + E. I do not understand why ! looks like a bug to me. And yes i bought the aircraft from Milviz and the Corsair too (truly awesome). have you encountered this problem ? Good day

Ctrl E doesn’t work with this aircraft.

Are you using the checklist for your start up?

I am not using the checklist, i tried all possibilties, even the checklist, and yes the WASM helper programme is running. The problem is worse now, the aircraft does not start whatever you do, in flight and on the runway (the engine died and battery does not work anymore, interesting if i keep shift+M punched, the screens are alive and the engine, if i release no more battery and engine) or cold start. I reinstalled the WASM helper program and the aircraft, no luck. I smell badly a DRM WASM helper problem here ! Conclusion : i do not understand what is happening with this wonderful aircraft. The Milviz Corsair was so good, this is a deception, i have a lot of aircraft functionning in MSFS, free or payware, no problem to start them, only this Pilatus !

i moved this topic to #third-party-addon-discussion:aircraft

honeycomb Bravo users , how do you have it configured for the PC6 ?

I only use axis 1 for throttle and control prop and power in-game. I mapped “Toggle Throttle Reverse Thrust” to the throttle detent on axis 1 (joystick btn 24). To get thrust reverse just pull back the throttle to zero, then momentarily pull back into the detent then back to zero. Now when you advance the Bravo throttle, the sim throttle moves into the reverse region. To cancel, just return the Bravo to zero throttle, pull back in and out of the detent, and throttle action returns to normal.

1 Like

doesnt it kinda defeat the point of the Bravo , if you only use one axis ?

Just hadn’t got around to mapping everything till now. FYI, I have axis 1 as throttle, axis 2 as prop, and axis 3 for idle control. To get the prop control into feather, you need to map “Toggle Propeller Reverse Thrust” to the detent on the prop lever/axis 2 (joystick btn 25). To get prop feather just pull back the Bravo prop lever to zero, then momentarily pull back into the detent then back to zero. Now when you advance the Bravo prop lever, the sim prop lever moves into the feather region. To cancel, just return the Bravo prop lever to zero, pull back in and out of the detent, and prop action returns to normal.

1 Like

is this pop in out of detent to get to beta realistic , or limitation of Honeycomb hardware ?

Given that the Bravo uses a button assignment for the “below detent” travel, I would say it’s a limitation of their hardware.

1 Like

Loving the Porter - it’s so ugly that it’s cool! Quick question. I’m currently flying from Santa Barbara to San Diego, but I have noticed several generator related alerts mid flight. Batt Discharge then GEN FAIL and now BATT LOW VOLTAGE. I have checked the GEN switch is on (it is) and tried the GEN RESET switch, but that does nothing.

Voltage is down to 23v and AMPS is zero (which seems odd) everything else is in the green.

Any ideas?

I’ve had a buzz about and not encountered this. A potential bug? All I could think it could be is the generator does not kick in below certain RPMs. Have you adjusted the prop or condition levers at all after takeoff? Another potential cause is some kind of failure seeing as it is possible to kill the engine, perhaps something has caused a generator failure.