Plane froze in mid-air

So I had this situation today. As I was making my final approach into KFMY I get the dreaded photogrammetry too slow box. I click ignore out of the box. After that my plane just froze in mid-air at 820ft to touchdown. Sound worked. It wasn’t paused, slew wasn’t on or anything. No CTD. It just froze in mid-air. All my views worked I could zoom in and out in the cockpit and exterior views. It’s just froze in time. Nothing I could do to get the plane moving again. I Alt-F4 out of the sim disappointed in not being able to complete my flight after a nearly perfect flight. Has this happened to anyone else?

1 Like

that really sounds like you put it into Active Pause, maybe by mistake and didn’t notice it.
Check your key bindings " pause key is default for active as well as using the drop down menu at screen top, you may have another key or button assigned to Active Pause ( different from pause, "esc key)

It’s not active pause. I’ve had this happen a couple of times in the past in exactly the same way - on short final, the dreaded error box popped up informing me that my 1 Gbit fibre connection is too slow for PG, then a complete freeze.

The symptoms look exactly like if you had active pause enabled, except everything in the world around you also freezes. With active pause, the world keeps moving around you (AI planes, ground traffic, etc). When this happens, everything locks up. You still hear sound, and it looks like it’s all running, but it just compeltely freezes. The only fix is to force-quit MSFS and restart.

That said, I’ve only had this exact issue happen 2 times that I can remember. And it was while they were having severe server issues a few weeks back. I’ve not seen it before nor since.


Exact same thing happened to me on approach to EGLL, no way out of the frozen state but restarting msfs

1 Like

Due to the lack of photogrametry, he will have automatically switched to Autogen. It will take a few minutes.

I’ve switched PG on and off during a flight to gauge performance. It typically takes about a minute or so for that reload of autogen scenery.

When this disconnect issue happens, it’s not just a switch of scenery. It literally locks up the game. In my case, 10+ minutes and it was still unresponsive and showing as “Not Responding” in Task Manager.


Actually cars were still running on the road. It definitely wasn’t active pause cause I turned on and off again and it did’nt change anything.

Strange. When it happened to me the first time, I was coming in for a landing and there was another plane coming in for a landing at a parallel runway, and it hung in place with me as well. I didn’t pay too close attention the second time other than letting it sit for a while to see if it would recover.

And I know it wasn’t active pause either. I tried toggling it multiple times to no avail. Left the sim sitting for over 10 mins and nothing happened.

1 Like

The need to fix this. Started happening since the Xbox release. Only workaround is to either restart the flight or with dev mode enabled use the menu bar to resume.

I also went in and turned on and off photogrammetry a few times to no avail.

I’m just going to turn photogrammetry off until they get either the sim or their servers fixed. Ain’t worth it cuz you’re gonna get the dreaded too slow thing almost every flight. Ridiculous. Same with the ATC azure voices. It’s unusable.

I’ve seen the slow photogrammetry dialog also in areas without PG, seems slow downloading of bing imagery can also trigger it.

I just hope this isn’t the problem with servers starting up again. Like I said, I experienced it twice, and it was only when we were having the serious server issues a couple of weeks back.

Over the last few days, things have been working fine for me, including Azure Voice which has stopped disconnecting on me every flight. It had been doing that for me on every single flight since SU5. It just mysteriously stopped sometime late last week. Same with mystery CTDs I had been experiencing. It all just stopped.

could as well have been slew mode, entered for whatever reason. There are enough UI bugs in the game so I wouldn’t be surprised if it was one of them.

Enabling slew mode doesn’t show the sim as Not Responding in Task Manager.

The pilot behaved strange as well…

1 Like

Nah I checked that.

I missed this information, yeah that wouldn’t happen. However this wouldn’t be possible either if it had hung up:

All my views worked I could zoom in and out in the cockpit and exterior views.

Yeah, that wasn’t my experience with it. Mine literally froze up while the sound continued playing. I’ll definitely look in more detail if it happens to me again. Like I said, it happened only twice back when the servers were crapping the bed badly a couple of weeks back and hasn’t since. It’s been working better than ever for me over the weekend.

This is one way to trigger it, you need to quickly click ignore before loading is done otherwise the plane is frozen as soon as you do:

It can also happen when the dialog pops up during mouse freelook.

These seem related:

1 Like