Playtime gone missing [Packages out of date]

I just flew from CSSS Singapore Changi to WMKN Sultan Mahmud and had no “Packages are out of date” issues. Azure ATC was working, but log book still is showing just my last two flights.
Achievements are still there tho. I’m from Germany and use the Steam Version.
Will fly now from WMKN to VVCS and see if that works too.

That’s why I’m wondering. My log was still there yesterday and I don’t wanna loose it that’s why I’m wondering if I should just hang in there till there’s official word from Microsoft

Ok, here’s whats happening in my case:

Data is and was fine but I suddenly got stuck in the ‘press any key’ loop after the message about packages out of date during a flight.

Sim started ok today but logbook is at 0, data was still enabled.

Now, every time I disable DATA in the options, apply and save, and then enable DATA, apply and save, I get the ‘packages out of date’ pop-up.

I’ve tried Northern Europe and South East Asia servers and both present the same pop-up.

As far as I can see, all my packages are up to date. I did have 30 liveries pending, but updating them made no difference.

Appears the issue is easy to reproduce, turn off online data and turn it back on. Packages out of date pops up. Same happens when losing internet connectivity.

Clicking Yes brings up the press any key intro, pressing any key resets the profile and logbook. Closing MSFS with the window X button does not.

That’s what I’m planning on doing, but I have this little “devil” in my mind that keeps telling me to see what might happen if I update those packages. :stuck_out_tongue:

1 Like

There are no packages to update

according to my content manager there are. Whether they are just ghost updates or not, I don’t know, but there is definitely an option to download and apply each of them.

I must resist. :slight_smile:

I can not even get to my content manager because ever since this issue came up I can not access marketplace

Hi Everyone,

Can we all condense this into something a bit more concise and accurate in relation to the original post. So far, it looks like this:

  • All log book data has gone missing, along with flying hours and challenge achievements.
  • If DATA connection is lost, either by loss of connection or manually disconnecting and reconnecting a pop-up appears notifying that packages need updating.
  • On checking the packages, everything is up to date and the pop-up seems to be a ‘ghost’ message.
  • There were some livery updates pending but, updating them made no difference to the situation.
  • Some say it’s fixed and others not, can you please state which server you are connected too in your posts and if it’s the logbook and pop-up message issue.

Cheers

Chris

3 Likes

Hi HawkMoth
Liveries?

My Content Manager showed three new updates. I downloaded and installed them without any problems. Now back to normal (until next time …).

Nah, just a couple of US airports and an Alaskan bush trip, as a few other peeps have reported.

Hello everybody. I had answered “NO” (steam - Italy).
Here is the result: shop disabled - profile intact (hours, flights, etc.) - no files to update (but I didn’t have everything installed) - all my purchases present.
I’m afraid the giant has started to breathe and they don’t know how to tame it.

1 Like

And STILL no reply from “customer friendly / transparent and to listening “ Asobo !!

This is real bad … some of them read these forums also right ???

If there not hard at work this weekend trying to fix things for their users then probably not, the let it trickle down to them thru zendesk / forums snitches er I mean moderators lol ;p

I just did a couple of short flights and it was better but not great, didnt even think to see if my log books were back, but I did manage to get these:


I just noticed, Ive already made several passes on this person, so we’ve been in the air for at least 10 min, and his gear and flaps are still down…

Hi CAPT5LOW

In my case was a bit different. I try to summarize my experience of the problem:

when I got “Warning: Your packages are out of date”, i clicked NO (as i was in middle of flight)

  • log book data / flying hours / challenge achievements were not affected

  • all online services got disconnected, just after pressing the NO button (servers, ATC, weather ,marketplace) during the ongoing flight

  • online services were still unavailable after sim restart

  • on the menu, option->general->data → online functionality box was disabled (as noticed by Riverrover).

  • I’ve enabled the option, apply the change. Closed sim with ALt+F4

  • after restart, all online services were working again.

  • performed some test flight and all went smooth.

  • The pop-up still did not appeared again.

  • now, I have 3 airport packages in content manager to update (i’m almost sure they were not there 2 days ago)

  • i’ve updated them now.

  • Sim still working fine. No warning pop-up still raised and all online services still okay.

Cheers

I know exactly what will happen with this thread.

We’ll keep asking about this until Tuesday.

The CMs will maybe tell us “the team is looking into it”.

We’ll never get any reply.

The error message will stop popping up after World Update IV on Tuesday.

The moderators will lock this thread because it’s “not an issue” anymore.

The people who lost their logbook data will never get it back.

If we vote up a Q&A topic to ask about this, the question will be ignored by Jorg and the others.

11 Likes

More news on my “trying to know what can cause the issue and what kind of issue it cause”:

If I do this (change data to NO apply, latter YES and apply) while in flight and not in the menu, the Pop-up will appear as spected with this bug. I choosed “NO”, it seems to have applied something.
After that, I press esc to open the menu while still in flight and went back to “Data” and… the data are still “OFF” despite de fact that I saved it as “ON”.
Why? Because the pop-up tells you that if you choose “NO” it won’t allow you to go online.

Ok, then I changed the data to “ON”, applyed the settings and after that the pop-up shows again, that time I clicked “YES”.
This trigger the cutscene with the “press any key” loop.

I restarted the sim and I had the SAME ISSUE AS DALMAKO, when it started ask me about configs and accepting the license terms. In the sim, some of my settings went back to default by itself (all in assistance and some in the general category (misc, accessibility, traffic and sound as far as I can see) and ALL MY LOGBOOK WENT BLANK AGAIN

I hope that this “invetigations and checks” can help to the devs to trace what can cause this bug.

Greets.

EDIT: This is what happened to Dalmako

EDIT2 with More info: The “world map” now is centerd in north america instead on my last departure and the aircraft selected is the “Daher TBM 930” instead of my previous used plane (Shock Ultra). Literally the same as Dalmako, I was talking with him on Discord when the bug happened to both of us at the same time while we where flying online.

2 Likes

Yep thats what I did and it worked :+1:

Thanks mate,
Maybe it’s clicking the YES then that causes the logbook issue, and clicking NO creates the data issue. Possibly the NO disconnects you and preserves all the data, but means you have to manually re-select ONLINE when you restart the sim.