Poor Performance with RTX 3080 and 3900X CPU " Limited by MainThread"

Hi there.

I am experiencing very very poor performance for a top end PC with this simulator.
I run an EVGA RTX 3080 with a Ryzen 9 3900X CPU, 32GB of Ram and the game is on an SSD.
At 1440p, regardless of graphics settings, this game performs shockingly poor.
I have made a video showing and explaining my situatuion.

Upgrade to 4k monitor those cards are made specifically to run 4k and MSFS doesn’t have lower Api Directx 12 at the moment. By the way I would never go back to 1440p once I bought 4k monitor I mean never especially with the hardware you have. My advice BIN 1440p

I dunno about that, I mean its not saying " Limited by 1440p monitor" haha. How will switching monitor change the way a CPU is being utilizted. The more I look into this, I dont think the 3080 is even a factor with this issue.

3 Likes

whatever good luck

I’m afraid to say that your CPU is limiting your framerate, MSFS isn’t well optimised for multi-core processors yet and only uses 3-4 cores, so you’ll find faster speed cores are more beneficial than having more cores at the moment.

That’s unfortunate, would you recommend the recently announced new AMD CPUs?

I guess i’ll just wait and see what optimizations come with the future patches.

Not sure about the new AMD processors, what is the clock speed of the cores? Intel typically reigns supreme with single core performance, ideally you need to be aiming at 5GHz. Even with that I’m not sure you’d get much more than 50-60fps with your settings. When Asobo move MSFS to DX12 that may help a bit too.

I’m not far off 5GHz, I boost clock mine to 4.5GHz. I surely would have thought it was adequate to get 60FPS on super low end settings.

Not actually too sure on the new AMD 5000 specs

What really confuses me is people with lower core performance are getting better FPS on the same settings

The new 5950X runs at up to 4.9GHz, so yeah not much improvement over what you have, maybe 10% tops.

You’re running on Ultra settings though, so far from super low end settings.

You could probably easily go up to 4K resolution and still hit 40fps.

I run 4K res with only High settings, but I have to knock the render scaling down to 70% to get 40fps - I have a i9900 CPU and a 2080 Super. I think your performance is right for the settings you have, there may be settings you can change to lower the hit on the CPU.

Yes but I dropped down to low end settings and still dont get above 50fps, when others with lower spec components are acheiving 60 fps, on higher settings. Just look at digital foundry and their video on FS2020 in 4k

That’s not an issue limited to just 3080s or 3900Xs. I have the same problem with my i5-10600K and 2070 Super.

The issue seems to be that not only is the “MainThread” limited to a single core, it’s limited to a single thread on a single core. In my case that’s the 2nd thread (hyperthreaded threads don’t have as much oomph as primary threads) on my weakest core. In fact to help with this SINGLE problem, I just re-enabled my CPU OC which I had disabled due to instabilities. But there’s been a firmware update and many driver updates since then, so hopefully it sticks.

But that’s a workaround, not a fix, and even if it works I can’t imagine it buying me much. My next steps will be disabling hyperthreading on that one core, and then on all cores if it just moves to another T2 to see if that might help, too.

MS/Asobo needs to get that process spread amongst several cores, and preferably the first thread on those cores to really fix the problem. And they need to do it yesterday.

Please upvote this bug report, and hopefully they’ll read what I’ve learned, but I’d bet they already know it.

KevyKevTPA
PP, ASEL, IA

6 Likes

yeah, I see what you mean about the low end settings, probably need to see what other AMD owners are getting. The CPU is definitely the limiting factor, not sure why though, sorry.

I’ve heard about disabling HT before and I even tried using CPU Lasso when I was having issues in DCS World - it didn’t help. I think it was worth it with WIndows 7, but Windows 10 is much better at managing threads. DX11 is poorly optimised for multi core CPUs, DCS World also uses this and has the same issues.

1 Like

For comparison, I’m running a 3700x and a gigabyte 3080 and consistently get above 45fps at 4K.

The key to not getting main thread limited is reducing your AI traffic. Don’t have traffic above 25 or at all.

If I turn off multiplayer and AI traffic, I’m at 60fps 4K all day.

6 Likes

Hearing this really concerns me, and partly why I made this post. Seeing people with similar specs getting better performance even in 4k.
I have AI traffic off and tried turning MP off but that made no difference. Perhaps 4k makes zero difference on the 3080 in terms of fps. Wish I had a 4k monitor handy to test.

Yes, 1440p on the 3080 probably isn’t even reaching 45% on the GPU, which would completely mean you are thread limited in that situation.

Also depends on the refresh rate. Are you at 60Hz?

120hz refresh rate

Is v-sync, g-sync, or any other limiter on?

Pretty smooth. I have the same machine down here except the GPU. It’s just a 1050ti for the moment. You should see this! I have a 49“ widescreen monitor with 5120x1440px and i reduced the flightsim to something 3000x1080 or so and it’s still horrible compared to your video. :joy: