Quest 2 - how to setup

Hi all, i recieved my Quest 2 today and i have been reading through loads of different posts but i seem to be stuck

im seeing some conflicting posts so im not sure what the correct way to setup the quest 2 is now.

i have updated the Quest 2 and installed the pc software, ive turned on allow unknown installs and set it to the beta channel, i should be on v28 now.

i have purchased virtual desktop for the quest and i have the pc streamer running, ive installer steam vr as i saw in a post that this was needed despite having the game pass version of the sim.

i have double checked the openxr registry points to where it should do… all seems to match what i have read so far.

if i start the quest and run the virtual desktop it connects to the pc fine, i then start MSFS which starts but the audio is a bit glitchy and it stutters a bit but it loads up, i set a random flight and start on the runway and the sim begins to load,

the issue i get is when i switch to VR using the key bindings im getting different issues, one time it may come up and say the headset cant be found, another time it has said openxr isnt available or words to that effect but most of the time it just causes the headset to flash to exiting home starting MSFS and just repeats this constantly until the sim crashes, other times i get the steamvr home flickering between different head positions but again still does not go into VR. i have had ot where it has been flickering on the main monitor in a split screen state, this is the closest i have got to vr but the headset was saying exiting home and starting MSFS repeatedly, most of the time it crashes the sim.

I have tried with all the pop out windows removed as i have seen someone else had issues with this and a second monitor, this seems to save the sim from crashing but doesn’t help solve the VR

What am i doing wrong… is there a latest install guide that i have missed that clears all this up, im trying to go down the wireless route but i have tried with link and got the same results. ive been trying for hours to get this to work and it shouldn’t be this difficult surely.

any help would be greatly appreciated, happy to try anything to get this working else ill have to return it :frowning:


windows 10 home 20H2
3080 Nvidia card (latest drivers)
32 gb ram
NVme + SSD Storage
900mb internet (wired) with wifi 6 router

1 Like

follow this Quest 2 + 2080Ti + Link + FS2020 set in ULTRA : Best performance simple setup guide - Virtual Reality (VR) / Hardware & Performance - Microsoft Flight Simulator Forums

you don’t need the desktop thing (I don’t use it).

I have a similar problem, I have followed all the steps that you have, but whenever I toggle VR it says “headset bot found”

Try to wait until you are in the plane in 2d mode before switching to VR in the sim. Then, you have to press the menu button on the left Oculus controller and then select the Switch to Vr button on there as well.

1 Like

Look at this thread, it may help. Oculus Quest 2 with MSFS2020 - #10 by N105LF

You need to have the oculus app running and oculus link turned on

Hi All

thanks for all your replies, i am a total noob when it comes to vr so please be gentle.

Im trying to get this thing to work without the link cable as some posts seem to suggest the wireless method produces better results. i have watched so many videos and read so many articles on the forum but none seem to help, i seem to be finding all the ones that had it work first time and now have this magical setup that is awesome

either way im struggling with getting this working.

today i have managed to get a stage further and actually managed to perform a short flight but when i go back to the sim its all broken again.

the main issue im having is getting into VR, i setup virtual desktop (connects 5ghz) it automatically connects and opens up steam vr, i can see the headset and controllers are connected, i load the sim and get to the point of being at the end of the runway but as soon as i switch to VR we have issues, i do the key press to get the sim to change to VR and this looks like its trying to do this, i get the split screen, on the headset i get the 2d view on the virtual desktop but if i left press the controller and select vr i just get the steam vr compass page (i disabled home because it kept jumping around and flickering making me feel very sick) even the compass screen moves around, occasionally i get the FS2020 starting page but then it stops again and then starts again and keeps repeating, every now and then ill get a flash of vr but then it will jump back to the loading page again and repeating for ages. if i try to turn the VR back to normal mode it seems to freeze the sim on the pc.

I did try with the link method but i got no further than before with this, the aftermarket cable i got for the link is very rigid and uncomforatable so i would prefer to go wireless if possible but at the moment i just want to see it working properly so i can work out where i have to change the settings for the best results.

when using the wireless method all the oculus apps i dont think get used so none of these would help change the settings, i can see some settings in the steam vr app regarding 80, 90 hz etc but im not sure if these are the same settings that everyone is posting as being the “best” settings.

im clearly doing something wrong when trying to go into VR, has anyone else had this issue and if so how did you solve it so trying to get into the vr didnt give you a seizure, luckily im sitting down else when the screen bounces around i could be facing anywhere.

i would love it to just switch on and work without having to open half a dozen apps and tweaking settings before standing on my head and pressing X,Y,Z all at the same time, there must be a way

thanks in advance as always


Thanks! I connected my oculus link and it is now working in VR. I was hoping to be able to connect without the link but it is better than nothing. VR mode works but now I just have double screens rather being immersed in VR. Do you know how I can fix this?

you press CTRL-TAB to enter VR mode

I’ve had the bounce back and forth thing before as well with virtual desktop. I wish I had time right now to go through the process because I always seem to forget.

One thing I’ve noticed is sometimes, there is the small window for steam vr just above the Taskbar on the desktop. You won’t see it for some reason through the headset, but if you look at your monitor you will see it. Minimize that and trying switching to vr with the left controller again. Hope that helps.

Based on your description, I’m not sure this is actually your fault. Sounds like you might have some kind of buggy/glitchy behavior happening… That said, here are things I would check/verify:

(1) The openXR runtime needs to be set to steamVR. One easy way to confirm this is open up steamVR, go to settings, and the developer tab. It’ll say “current openXR runtime: X” where X should be steamVR. If it says that there, your’e good.

(2) SteamVR has render resolution settings in two places. There is a global setting under General, and a per-app override under Video. I can’t remember what label is on it now, it has been changed multiple times, but it’ll be called either render resolution, resolution multiplier, or resolution per eye. On BOTH of those places (the General tab and per-app setting under the Video tab), make sure it is set to “Custom” and a value of 100%. Don’t leave it on Auto – steamVR isn’t always too smart about setting this value on its own and often sets it too high.

(3) In your Virtual Desktop app settings (you get to this inside the Virtual Desktop app in the Quest), make sure your quality setting under the Streaming tab is Low or Medium, at least for now. Once you get things working reliably you can experiment with changing that.

(4) Try running some other PC-VR apps through Virtual Desktop and see if you still have the same issues. This would help you rule out if it’s a problem with your Wi-Fi network, or specific to MSFS.

(5) Make sure you’re connecting to the 5Ghz band of your router, and also make sure the SSID of your 5GHz network is NOT the same as a 2.4GHz network being broadcast by the same router. If it is, the Quest could be switching bands, and VD definitely won’t work well at 2.4GHz.

(6) Make sure you don’t have any background apps running other than MSFS, steamVR, and system essentials. MSFS needs all the resources it can get, and then some, and if other apps are stealing CPU cycles it will make things worse. Also, the current batch of NVidia drivers do not get along with performance monitoring tools like Afterburner, so if you have those, disable them.

Lastly, here’s some other clarifying info. Be careful getting advice on this stuff in this forum, there’s a lot of people as stuck as you trying to help others. For example, just saying “you have to use Link” is neither true nor helpful. VD works fine, when it’s working correctly.

  • You need to have the Oculus PC software installed in order to use VD, but it does not have to be actively running for MSFS if you’re using VD.
  • Settings in the Oculus Debug Tool,Oculus Tray Tool, and even the PC Oculus app have no effect on Virtual Desktop’s wireless streaming, so don’t bother trying to change supersampling values, refresh rate, etc. through them. They only affect wired connections (Link).
  • The render resolution settings in steamVR DO have an effect with Virtual Desktop. Make sure they’re set to 100% as I described above. If they’re higher they will choke even your 3080 severely with MSFS.
  • You can choose any refresh rate you want to use for your Quest, but this is set through the Virtual Desktop app, inside your Quest. Choosing 72Hz or 80Hz instead of 90Hz will lessen the burden on your GPU, but can also increase latency.
  • You need to have Virtual Desktop and steamVR launched/running before you tell MSFS to switch to VR, or you’ll get those messages about headset not found.

Give those things a check and see if it helps. If not, come back here and I’ll try to help you troubleshoot further.


All very good points! I wish it was easier, but at this point it’s pretty finicky to say the least. It’s often just one small detail that everyone is missing.

Given the complexity of the description you have provided for trying to use a wireless connection to run one of the most complex video games currently available (a game that has replaced Crysis in the “can it run” meme) I’m not sure who is being more or less helpful in this particular scenario. Yes, the original poster has asked about this under the impression that wireless is smoother or faster, but simply plugging in a high speed cable and sitting down is far less problematic than all these shenanigans. I would also point out that wireless connectivity to a PC is not yet natively supported by the Oculus and when it comes in the next update it will be an experimental feature.

Do as you will, but plugging in a cable beats messing with your router every single time.

For the original poster, getting the O2 to run with a cable is as follows.

  1. Start the Oculus app
  2. Connect USB cable to PC and plug into O2
  3. Start FS2020
  4. Press CTRl-Tab to enter VR Mode


Of course this is FS2020 so messing with the settings is a given sadly, but there is an excellent post here that will get you up and running in mere minutes.

Quest 2 + 2080Ti + Link + FS2020 set in ULTRA : Best performance simple setup guide - Virtual Reality (VR) / Hardware & Performance - Microsoft Flight Simulator Forums

Well, if you look at what I wrote, much of it would apply whether the wireless connection was being used or not. Regardless, the OP wanted to use Virtual Desktop, and the fact is that it works fine normally.

If you’re using Link, you still need to make sure the correct runtime is set in the registry, you still need to make sure no other background apps are running, you still need to check either SteamVR or Oculus’ render resolution settings (depending on which you’ve set the OpenXR runtime to)… And then you also have to deal with enabling or disabling ASW, setting refresh rate, and if you want all the gains, also setting the FOV crop and the supersampling setting in the debug tool or tray tool, none of which you have to mess with in VD.

I agree that it’s not terribly straightforward for someone new to VR, but getting MSFS running at a mediocre level isn’t really straightforward whether it’s with VD or Link. I use both myself, and I can’t say I have a strong preference for one or the other in terms of what’s better. Both have pros and cons.

Hi EverydayAsh

i have tried with the settings you provided and followed the link you sent over but this is even worse that with virtual desktop

At least with VD i can get VR sort of working, i have tested the cable (i have 2 both over 2 gbps)

one thing i have noticed is when i connect the cable and activate link, i get the grey empty warehouse screen for a second and when i set MSFS to go VR i just get a black screen, i get the audio in the headset and on the monitor i get the two screens but steamVR seems to open is this correct ?
i then get the compass screen and a FS2020 box and waiting… which goes on for ever and never connects.

When ever steamVR starts with VD i get the last played screen which always shows DCS even through i have not played it with VR, i started it whilst everything else was hanging in the back ground and it opened up straight away in VR mode within DCS at the login screen so it is clearly capable of doing it but just doesnt seem to want to do it for me with MSFS

i hav etried again with VD following SwirlyMaple7’s suggestions and i did managed to get a flight in using VD but the screen kept flickering and everything wasnt all that clear, i ddi this before trying the link cable as i didnt want to fully waste another evening without getting a some time in the air.

Im clearly doing something very wrong but i cannot see what.

i have the oculus app open with ODT running admin with the settings set but this has not helped at all, which is a shame as i really hoped using the cable would get me up and running.

i read in one of the posts thats there was a way to link the xbox version of MSFS to steam would this help at all ? not sure how it was done and i think it later said this wasnt needed and to not do it, there is so many conflicting posts its hard to see what should be done and what shouldnt be anymore.

Any further help would be greatly appreciated, i am reading all the posts ive just been at work all day so have not had the ability to give anything a try until i got home.

I really appreciate all of everyones help so far.


Hi SwirlyMaple7

I just replied to one of the other posts but i did give your method a try and i did get a bit of time in the air but the quality wasnt great it was hard to see structures and moving my head seemed to tear the image and cause the screen to flicker up and down and side to side for a few moments before settling down again, i wanted to reply to you so you knew i had read and tried your settings and that i hadnt skipped your post because the link method looked looked easier, turns out it didnt work at all which im very confused about.

My Wireless is 5ghz but i can see it also offers the 2.4ghz and it somes times connects to the wrong one despite being 3 foot in front of me, because its a mesh system i dont think i can seperate out the bands or at least setup an SSID that only has one band but i will take a look and see. i did see earlier that even though i was connected to ther 5ghz band it sill said performance may be degraded despite having a near crystal clear picture (not in VR at that time)

Since then it has been connecting on 5ghz and not showing any warnings about degraded streaming

Any further help would be greatly appreciated


HI All

After alot of messing around i think i now have it working in a stable state.

Im using VD as i have not managed to get link or air link to work at all, i was hoping air link may be the way forward but its just the same as link and doesnt run MSFS in VR at all, im not sure if im supposed to still have SteamVR for this to work or if i need to change something to make link work.

As i have it working with VD this is a great start, i still get the odd jitter but ive flown a couple of times in the flybywire a320 and a cessna and all seems ok,

I noticed that the graphics outside the cockpit are not that great when at EGSS inside the cockpit everything is fairly clear but the buildings and anything further than about 10ft from the aircraft are pretty low quality, i have no chance at reading the taxi way signs.

I tried a cessna from London city and did a quick lap of the Isle of dogs before returning and the graphics looked a little better.

which settings should i be looking to tweak to see if i can get better graphics for anything outside the cockpit, are these settings within MSFS that need to be tweaked or settings within VD or SteamVR.

Any help would be great as i think im really close to getting the setup right but just dont want to go changing to much to mess it all up again. any pointers on how to get Link / Air link properly working would be great as i can use these as a backup / comparison to what VD is offering and see which is better.

Thanks in advance for all your help that you have provided so far, it really has helped a great deal.


this is text from another post, this works for me but it is with cable link; There should be no issue using the cable.

First of all thank you to all for tips and tricks, with these I have been able to find the settings that work well for me so posting here in hope it will be helpful for others. This is with a cabled connection, not Airlink.

System: AMD 3900X, RTX 3070, 32GB Ram.
Oculus Debug Tool: FOV 0.7;0, Adaptive GPU Performance Scale: Off, ASW: Force 45fps, ASW Disabled
FS2020: VR; 80% Detail, all other settings on Ultra, Multiplayer, Live Traffic, AI Traffic all off.

Test area was Santa Barbara Municipal Airport. All planes tested worked very well apart from TBM 930. Planes that worked well were default and pay ware, some from Ceranado, and other steam gauge types but DA62 with glass cockpit also performed well so the TBM must be a bit of a resource hog.

I don’t fly airliners so don’t really care too much if they work well or not. If Asobo optimize more for VR to bring gfx fidelity in line with 2D mode and add in hand recognition (that works well in the Quest2) then we have a big winner from a VR perspective.

One important thing with wireless with either Virtual Desktop or Air Link is that your PC needs to be wired to your gigabit router with ethernet cable (type 5e or better). If you do not do this and rely only on Wifi (or even ethernet power points) you will get very poor results imho. Sorry if this was mentioned before but I did not see this.

Hi EverydayAsh

Ill give these settings a try tonight and see if i can get link working, do i need to do the registry tweak for the openXR in order to use Link or should the same settings for VD & SteamVR work ?

it would be great to get Link working so i can check the differences between the 2 setups and see which works best especially for airliners.

i agree, if they could optimize things a little more and bring hand recognition in that would be fantastic, its going to take some getting used to switching between the flight sticks and feeling for the mouse to flip switches and then find the flight sticks again :slight_smile:

Thanks for all your help