[READ FIRST] About the CTDs category

Visit the Community Dashboard page for more information on this category bug status.


This section is dedicated to CTDs - Crash to Desktop. If your sim abruptly terminates with or without a warning or error message, this is the place to report and troubleshoot.

In order to provide key information to the team, we invite you to read the below instructions and use the template that pops up when you create a new thread.

This will help identify what could be the source of a specific issue but also help the community understand if they experience a similar situation.

Before reporting a bug, follow these steps:

  • Check if the issue has been identified in our Zendesk articles or Known issues
  • Check if a similar thread doesn’t already exist, if so, use the voting system. Please do not create duplicate threads .
  • Report only 1 issue per thread – be specific.
2 Likes

Hi
Since update and with today’s fix my Simulator is crashing. I load the game from Steam, opens well, the app opens, I can move around menus, but he I select fly from any part, it crashes when I select FLY. I need help!!! Do I have to start from scratch? I have read that any on those cases they have the same problem.

Any help would be appreciated

9 Likes

Three times this morning in the space of 15 mins I have CTD, dep airport EGCC gate 12L rw 05R, as soon as the plane appears the app CTD’s. In case it is needed the arrival airport is EGAA, auto rwy ILS 25-Z

This has been happening ever since the SU5 (not just this route)…

Rarely do I get complete a flight.

6 Likes

Hi, since the update 5 my flight simulator is having some troubles, first, when open the flight simulator some times it shows the welcome screen and after check for updates the screen goes black, after some time the flight simulator starts with the home screen, another bug is when Im creating or fliying, sudenly the simulator crash and send me out to the descktop without any alert or mesage, just like that, one moment Im flying, and then Im in my descktop, and that is the reason why i can’t confirm the last bug, yesterday i was flying and the plane did turns very strong to the left all the fly, in some moment I despair and let the plane do what they want, and the plane did a loop and the force that was pushing me to the left, was gone, so it can fly freely until i aprouch tho my destiny and it took me out to my descktop,
I was foirgetting, an other bug is when I do a zoom in the map,it doesn’t always happen but some times the sumulator crash and send me out to the descktop without a mesage or alert.

5 Likes

I am just seeing if my feedback can possibly help me. Since the first release of MSFS I have not issues with it running on my system. Since the mandatory update last week it will not load at all. It will go thru the splash screen and sometimes go to where I can select and plane and airport and puts me at that airport. Other times it will only load bar about halfway and then both will just CTD. I am not a computer genius but it is very upsetting that update was pushed and ever since then nothing but problems. I have deleted and reinstalled the game twice now from steam but results have been the same. I am posting that so that Asoba can see that we have an issue. Hopefully it can be resolved so that I can start flying again. My son uses the software for his flight training and I hope he can use it again. Thanks for the assistance.

1 Like

Ditto!
Exactly the same issue for me. Now tired of reopening and hoping a miracle happens!!

1 Like

If you are using a Logitech Flight Radio Panel, uninstall the driver and see if that fixes your CTDs because it did for me. With the driver installed every single time I try to load a flight, CTD. Uninstall the Logitech driver and it worked again. Re-install the driver, more CTD, uninstall and worked every time. That was enough proof for me. I contacted Logitech support and advised them of my problem. Another problem with the driver is that it stays loaded after the Sim crashes, which keeps the Sim from starting again unless you go to your task manager and end the Logitech process.

1 Like

I have fresh installed windows twice and the sim 5 times trying to minimize and third party interference and yet i still get ctd’s

Error is same 00005 exception error. this is crazy… This all after the update

3 Likes

Constant CTD clicking fly now fix this shyte Asobo!

Same here this is so stupid we shouldn’t have to deal with this or be an IT expert to run a darn game

4 Likes