Release: Working Title G1000 v0.3 - updated to v0.3.5 on 14 Apr!

Ok l have removed everything from the Comm’ folder started the sim and the G36 has panels working fine.
Installed G1000 v0.3 on its own started the FS G36 with everything running and 2 black panels also the Air Con panel not showing the temp as usual. could it be the Nvidia driver running 2080 Super.

Thanks for your amazing work guys! :heart_eyes:

1 Like

Are the airspace lines correct in the mod G1000? they are very light and don’t seem to be removed by DCLTR.

This must be a bug, right? lol. I recall earlier versions and stock G1000 automatically erasing waypoints if you didn’t fly onto the path but flew past the waypoint for you. Screenshot for reference

You aren’t flying an active leg, it should be purple if that leg is active. It only removes legs that you have actually had active and completed.

is this working as intended in the IRL g1000? I also noticed opening up the flightplan page will erase all legs flown past even if you didn’t follow the leg

To be honest no I don’t think it does, but seeing as 99% of the time people use track-up not north up you can’t see past legs anyway. But it shouldn’t remove them from the plan no, that makes no sense.

Cannot install it, the error message always appears that the folder name is too long.

Got the game from the MS Store and the installation path looks like this:


I think that’s the problem because the install path is so long that it reaches its character limit.
So anything i can do about it?

Autopilot fixes!:

I still have the U-turn back issue. Did you make a correction only for a specific aircraft or all of them using G1000?
Tested with Grand Caravan and still have the issue.

Maybe something I missed.

I messed around with the G1000 mod and the G36 mod yesterday. I don’t have the engine page. The install worked fine, and the engine gauges are work to the left of the map are working as they should.

I just don’t have the engine softkey as seen in this picture from above.


Maybe I just have the G36 mod working?

I’m going to try removing all items from the community folder except the G1000 and G36 mods, and see what happens. A flight simmers job of tweaking is never done…LOL. I need to chew on this one a bit more.

Ok I found myself my “mistake?”.

In fact in my test case I used flight plan “load” and not “activate”. Using “activate” is ok (no U-turn).
Now if you use “load” after the last enroute waypoint, the sim automaticaly activates the approach and you have the U-turn.
It would be nice to apply the removal of enroute waypoints when you just “load” the approach after the last enroute waypoint.

1 Like

For a while I thought only I had this issue. You are correct, the path to the location is too long. Most people seem to have had success by moving the unzipped mod into first the main level of the drive (so to F:\ in your case) then dragging into the Community folder. That didn’t work for me and gave the same error. There’s also a registry change you can try, but that also didn’t work for me. There’s also an alternative folder you can move to mod to in your C: drive, but as I already had the mod working, I don’t remember where that folder is off hand. I ended up using Windows Powershell to copy the mod into the Community folder. There’s a link to the page I used as a tutorial for Powershell further up, if you need, in post # 30.

Go to hard drive C, users/user/appdata/local/packages/Microsoft.FlightSimualtorxxxxxxxxxxxxx/localcache/packages/community and laste there.

1 Like

Got this installed tonight. Such an improvement over standard. Amazing job and thank you very much! :smiley:

Enjoying Bonanza & Caravan flights in Washington state with much the improved G1000 now :+1:

Can someone verify, is “heading sync” (click heading knob’s head pushbutton to set heading bug to your current heading) working for you?

My heading bug goes to exactly the opposite direction, towards my back instead of where my nose points at.

OK. I have a build that will fix the G3000 synthetic vision and the issue that has been reported with WPT/NRST map pages on the MFD overflowing the window when in track up.

I’m flagging it as a pre-release as I’d like to let folks who have been having problems confirm that it works for them before I make it “official”. If it takes care of those two problems for everyone I’ll make it official and then we can work on the remaining handful of less urgent bugs.

Please make sure to delete the existing directory before installing this update.


Fantastic, thanks for the hard work. v0.3.0 gave me blank, black screens in both the DA62 and G36 (and that’s with this mod being the only item in the community folder), but v0.3.1 appears to be working!

Testing currently in the DA62.

A really valuable mod which increases realism, useability and overall enjoyment.


is that the same as the g1000+cbub-g3x-v0.3.1?

No, that’s a version of 0.3.0 that was tweaked just to force synthetic vision on. 0.3.1 actually restructures the files so that the G1000 uses its own code in a separate location rather than changing the stock files, which is much safer and would have been the “right” way to do it from the start. :slight_smile:

Incidentally, I’m working with @CarbonProp and the Bush League Legends folks to enhance the G3X. Currently it has a recolored UI, four wind data modes with a button to control them, CAS alerts (which can be cleared both by touch or via the BACK button) in the correct place on the PFD, and a simulated GAP-26 regulated pitot heater with realistic warm-up messages on the screen and a warm-up time that varies with the exterior temperature just for fun.

With more to come. :smiley:


ill wait for the tested realease then as everything works for me