Rift S - flashing white light

Yeah, I had an update load on my Rift S today, Flashes went from being occasional to being extremely annoying.

I did … it didn’t help

Can you monitor the FPS I expect you will find that ASW is enabled in the cockpit whereas there is less demand out of the cockpit so ASW is not required.
Try disabling ASW. To be 100% sure you’ll have to put the performance HUD on and then you can see the FPS being kept below whatever HZ rate you’ve set you headset to run at.

It’s described as a flash but it’s actually a picture change, you move out of the aircraft for a frame or 2. My guess is a timing issue related to ASW, if you disable ASW it goes away assuming your GPU is strong enough to run the SIM.

I haven’t tried this yet but some said it worked.

1 Like

Hi All,

I hope I can be of help. We all know that the FS flashes are linked to Oculus PC runtime v26, which was in Beta recently (causing flashes for those participating) and became the official v26 release two days ago - still with the same flashes in FS.

WORKAROUND: change Khronos-OpenXR runtime from Oculus-OXR to SteamVR-OXR. Tested successfully and it killed the flashes for me!


  • you DON’T NEED need the Steam-Version of Flight Simulator for this to work
  • you NEED Steam-client including working SteamVR (I run on 1.16.8 in Beta mode)
  • IMPORTANT: Oculus Debug Tool / Tray Tool core settings like Super-Sampling, ASW mode/off, FOV are still working - even if running via SteamVR. Additional SteamVR resolution-settings, motion smoothing etc. are complementary - that means they come on top! Bear this in mindin order not to over-tweak your resolution (FPS!) or in case you want to switch ASW off (which I definitely recommend)

For the ones knowing how the above config works: come, see, confirm back and spread the word! For all others, instructions below:

1. How to change Khronos-OpenXR runtime in your Registry from Oculus-OXR to SteamVR-OXR?

  • I’ll skip the classic regedit process, because there s a way more convenient way in SteamVR, as described by @CptLucky8 here:

2. How can I opt-in to SteamVR Beta?

  1. From your computer, open the Steam app.
  2. On the left panel, click the drop-down menu and select Tools.
  3. Right-click SteamVR, and then and select Properties.
  4. Go to the Betas tab.
  5. In the Select the beta you would like to opt into drop-down list, select beta - SteamVR Beta Update.

3. How do I launch FS on Oculus using SteamVR now, after applying the changes?

  1. Activate Link (Quest) / Oculus Home (Rift)
  2. If you are using Oculus Debug or Tray tool, reconfirm all your main settings now
  3. In the Oculus Home, go to apps and launch SteamVR
  4. Launch FS and wait until loaded into Main Menu
  5. Switch to SteamVR (default CTRL+TAB).
  6. Enjoy FS in VR without white flashes!

4. How do I configure Flight Simulator to run smoothly?
Please feel very much invited to my guide and the subsequent forum discussion:

4 Likes

I’m glad you posted this as I wanted yesterday to test the Steam implementation of OpenXR with my oculus CV1 as a test but wasn’t sure about all points you wrote.

But can I expect the same performance using SteamVR OpenXR versus the native OpenXR from Oculus with my oculus headset? I have some doubt…

Any feedback from people who already tested switching? I can’t before tonight (CET).

@CodeLoran69 confirming FS via SteamVR 1.16.8 Beta finally performs EXCELLENT on my Quest 2!

SteamVR was broken in FS two months ago and still really poor only a month ago, but with the latest release SteamVR has overtaken the Oculus runtime. FPS feel about the same, maybe even a bit faster, but what is more important: much more solid - way less micro-stutters compared to Oculus.

It runs so smooth that I have even changed the runtime in Assetto Corsa (my 2nd-biggest VR love) from Oculus to OpenVR (=SteamVR) now! Of course I can only confirm this for my setup, but I hope others will follow…

1 Like

This worked like a charm for my rift S! Thankyou!!

2 Likes

I tried Steve’s solution using SteamVR, and while the flashes are gone, the sim becomes very stuttery for me. I may try and revert to version 24 of the oculus software, and see if that gets me going flash-free again.

I’ve gone with the v24 solution and it appears to be working well.

The only challenge now though, if everyone stops using the V26 Oculus drivers, is knowing when the problem has been fixed and when we can go back. However, it looks pretty easy to reverse the fix and reapply it again, if necessary, after trying out each new release of the Oculus software.

Same here.

Here’s the link to the pdf with the solution: vr perfomance guide.pdf - Google Drive

Thanks to Michelapole818 for coming up with this. MSFS is now smooth like I’ve never seen it before :slight_smile: And not a single flash so far.

1 Like

Awesome, glad I could help and thanks for letting me know. : ) All those posts make my day to be honest. : )

My Rift updated itself last night. I tried to make a flight this morning and now again with the flashing every second. I agree. Totally unusable. I think I might throw my headset down a flight of stairs. Heh.

look here

I’ll keep v26.x. I really dislike to get back on old versions or drivers on my secured machine, and I don’t feel I should be the person fixing their issues each time they fail. Saying that I’m glad for all people who I found the provided solution with v24.x and will keep flying :slight_smile:

Me I stopped flying anyway until this is fixed, so we’ll know when Oculus or MSFS Devs will fix this issue.

Fair enough.

It might be a while before a solution though, especially if it needs both Asobo and Oculus making changes.

I hope it’ll be soon.

My Oculus software is now on v26, even though I am not in the Public Test Channel. The flashing is back (it was fixed when I turned off PTC to got back to v25). Any new solutions?

I had a new feedback from the MSFS support team, I don’t think I break any forum rule here by saying what they said : they apologize for the frustration we have and confirmed the devs team is looking at this specific issue.

So that’s great and we just need to be patient now :slight_smile:

I found rollback is not needed for me. Surprisingly and oddly, nothing happened to my msfs yet with v26 except slight feeling of slow down. Is this issue related with GPU type? Mine is rtx 2060 laptop version.

ps: I have had this flashing and flickering issue when v26 was beta.