Road traffic missing with multi monitor

Are you using Developer Mode or made changes in it?


Brief description of the issue:

The road traffic, for instance in a highway, disappears when adding a new render window

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Use Developer Camera and search for a highway with road traffic. Then go to options and add a new render window (WINDOW 1). Road traffic disappears. Close the WINDOW 1 and the traffic appear again. It looks like that road (an maybe boats) just works without new render windows.

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Welcome to the forum!

I have moved your topic moved into the Beta forum.

If you are enrolled in the Beta, please report regressions or bugs introduced by the Beta in one of the subcategories in #sim-update-10-beta

Thank you!


it seams after the update ma Traffic on the Roads is gone.
Can anyone pls x-xheck this ?


Hi - I have plenty of road/vehicle traffic in the beta released today. I haven’t changed the setting in a long while, so not sure what’s going on?


thanks for checking this.
I dont know where all the Traffic is. I remember i had them before.
But last times i tried all the Options in the DevMode Menus. But now i dont know exactly which one of all the Options in the Devmode menus was checked and which not.
Maybe one of them should not be ticket.

I tried “Reset” in the left DevMode menu, but it does not change anything back to standard.
Maybe anyone knows and can tell me exactly which one must be checked and which one not.
Sorry, that was my mistake not to have a look for that before i changed anything.
I am also not sure if all goes back to standard when i quit devmode?


btw…not to forget, since i have better frames !!
Nice job Dev Team !!

:clap: :clap:

Thats how it looks when i turn on Options->Terrain->Debug Road Vehicles:

It seams they are blocked or something…they are not moving or am i wrong ?

during tests i just tried to activate Smart Docking System ( to see what it is )
But after that i see the Road Traffic is after activating that pooint moving again …
Funny … no ?

Btw, this happens only after a complete deinstall and the reinstall directly the latest Beta


Wow I’ve never seen anything like that. I don’t use dev mode much, but if there’s any way to reset all the settings that might be your best option.

Good luck to you!

as i wrote above, i tried "[DevMode] → Reset settings, but it does not relly reset all dev mode settings.
Thats the reason i ask if anyone have the default settings for me.

Oh gosh I’m so sorry. I’m still waking up LOL. I wish I knew how to help more.

1 Like

:slight_smile: no prob man …

maybe anyone can tell me at least which of these options in the Pic are checked by default ?
Thanks a lot !!


1 Like

Those four settings are normally selected in default.


Ok, thanks a lot !!

But there is still the Issue, that my Roadtraffic is not showing ( starting ) after i start MSFS.
Just after i select “Smart Docking System” from the Dev Menu, then the Roadtraffic starts.
The Traffic on the Airport itself runs normal from the beginning.
That happens only on the PC where i have deinstalled MSFS completely and then installed via the xbox app because it is no longer possible to install directly via the MS Store.

What can cause this ?

Ps: I did a small video on my Laptop ( connected via Anydesk to the Main PC in the Cockpit )

You mentioned you didn’t adjust the Road Vehicles setting in a long time, can you check and confirm what the setting slider is set at?

yes for sure…see pics

For test purposes, I would turn it up to 100% and try.
If there still is no traffic, try starting the sim in safe mode, that will eliminate any addons, as there may be an addon conflict.

To start in safe mode,force quit the sim with alt+F4 or end the sim from Task Manager. You will then get the prompt to boot normally or in safe mode on restart.

1 Like


thanks for that tip.
I already tried today to change the Roadtraffic to different values, but it did not work.
I also already tried just to rename the Community Folder, which also brings no result.
But will tomorrow try your tip and hope it will not destroy the sim installation :wink:



finally i had the Time to start the Sim in Safe Mode.
But still, the Traffic is there (i activate “Debug Road Vehicles”) see here:

But theey are not moving and also the Model itself is not displayed correctly.

But i had also a LOT of errors in the Console, also like this:

I dont know if this could have something to do with that, but it sounds so.
But i really dont know what else i can do?

It seams the only Difference is still, that i have on one PC first installed the Sim a long Time ago as it was possible to install it directly via the Store but on the PC where it is not working i must install it via the xbox App.

i installed on another PC the latest Version , there was no previous versions installed.
Here it is the same, the Road Traffic did not start, he stands still.
Here are no Addons installed, so no Problem with any addon.

Can pls. anyone help ?

I did a seach for LivingWorld_Config in Packages ( over Community ) and also in the Microsoft.Flightsimulator… directory, but there is nothing found.

But as of the SDK it should if i understand it right?

Living World Configuration is described by a single *.xml file (compiled into *.spb while packaging), located in a folder called "LivingWorld_Config ". It is possible to have multiple such files in the same folder, in which case they will be read in alphabetical order, each new one overriding part (or all) of the previous ones.


Have you tried to delete all your server side game data? I think this is the nuclear option, you’ll lose all your flight hours.

1 Like