Screen hangs on Content Manager screen if community content is active

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
MS Store version

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
After update, with activated community content, the Content Manager screen hangs. The game still works, I can go back to the other menus. The game will hang completely when tyring to exit the game.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Start the game with content in the community folder.
Enter Content Manager. (Content loads at first.)
Exit Content Manager.
Enter Content Manager again.

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:
1.21.18.0

I have something like 1200 mods (thank goodness for mod managers), and this is a CONSTANT problem for me. Same pattern: content manager will not load; sim works fine (as far as I can tell); and hangs on “return to main menu” from an active flight.

But not every mod will trigger this hang. I can mix and match to get down to a set that works fine with the sim, with some effort. Here are some general notes I’ve accumulated:

  • Mods that were compiled pre-SU5 (i.e. the date of their last update was before that) are a common cause, especially for scenery add-ons. I have everything pre-August 2021 segregated, and deactivating these used to solve the issue in most cases. But not anymore – see below.

  • Older liveries can cause issues in general; I’m not sure if this is one of them.

  • This is just a hunch, but it seems that some of the “suspect” mods (dated pre-SU7) will work fine on their own, but seem to not work in conjunction with other, newer mods.

Before the last update, this was a manageable issue. But after the last update, things got significantly worse. To give a quick example – I organize my US mods by region, so I have sub-folders labeled “Northeast”, “South”, “Midwest”, etc. As of, say, Thanksgiving, I was able to set up presets for each region that worked, and that worked together, so I could just select the “good” Northeast and Midwest if I planned to go from Boston to Chicago and wanted those assets loaded. Now, I can barely get one region to work. I can add one or two mods from a second region, tops. And setups that work one night might not work the next night, if something’s been updated. It’s like there’s an effective cap on the number of mods the sim will accept before throwing the Content Manager hang issue. (I’ve also been getting CTDs again, which had been completely absent since SU5, but that’s a separate issue… maybe.)

I’m no expert, so I don’t have any real insight into what could be causing this. But something has definitely changed, and for the worse, with the last update.

I wish I could find some sort of characteristic that the “bad” mods have that’s a flag for this issue, but there’s nothing obvious, and I can’t really dig into the underlying details of a compiled project, even if I had that sort of time.

(Completely speculating, but the nature of the issues I’ve been having seem to point towards some kind of memory or disc access issue within the sim.)

2 Likes

Can confirm this problems still persists. I’ve had to start just renaming my community folder whenever I get a notification that an update is available in the content manager.

This will be a major issue for those that load hundreds of addons (like myself). I have found I can isolate the addons the Content Manager cannot properly read (I have isolated it so far to just scenery addons present in the Community folder). You can have one single folder with an addon the Content Manager cannot read and it’s hung. When I discovered the issue I found 10 folders (containing hundreds of addons) that locked up the Content Manager but had 12 folders remaining (again with hundreds of addons) that didn’t hang the Content Manager. The problem is trying to weed out the addons that the Content Manager is hanging on from all the others in the same folder. You can test one addon at a time but if you have hundreds loaded this becomes an impossible task to weed out those hanging the Content Manager. The obvious solution is to get a little help from Asobo to identify what is hanging the Content Manager (they know what it’s reading) but don’t look to Asobo for any help on this. They pretty much blame it on the addons. Per response from Asobo, “… but Asobo Studio and Microsoft do not oversee the creation of add-ons and plug-ins. Our responsibility is to ensure the stability of the sim in its vanilla state, which is why the QA team can only investigate vanilla installations. As a matter of fact, there is nothing more frustrating for our QA team than wasting time and energy trying to reproduce an issue to finally find out that the culprit was an outdated mod or faulty plug-in.” Okay, they make a good point (although I’d like them to define a “vanilla installation”) but this issue prevents end-users from being able to use hundreds of great addons because it’s an impossible task to weed out those causing the issue from the hundreds plus there’s obviously something here creators in the community need to know about. It would benefit everyone to resolve this. Gotta hope they aren’t getting “burned out” and have stopped listening to the Community. Not all addons cause the problem so you would think that this could be easily figured out by testing an addon that hangs the Content Manager and testing one that doesn’t. I’m not the expert but that seems to be easily looked into. So, unless someone with talent in coding can sort this out plan on living with this since it was introduced in the updates (as mentioned in other comments it certainly wasn’t there before). BTW, your addons will probably work just fine (you just won’t be able to access the Content Manager while using them). If you need to get into the Content Manager you’ll now have to use a utility like MSFS Addons Linker to quickly and temporarily disable ALL your addons while you access the Content Manager. It’s a shame we have to resort to workarounds like this but like the Colonel said, “C**P Happens” ! Regards.

I have the same issue. I see the screenshot posted in the original post when I open the Content Manager. I also experience the hang, mentioned in the second post, which prevents returning to the main menu after finishing a flight. The only way to exit the sim is alt-f4.

Yep same for me too, it’s really getting annoying now. Have to empty community folder every time I want to update something in the content manager.

Same here. Any coder here who’s able to program a filechecker? Would be great! :hugs:

Never had this issue until this week. Now it’s constant. :frowning:

Turn ethernet off and then back to on to see if this helps

For me it’s definitely a particular item or items in my community folder. If I enable all my add-on planes and my “base” mods, it happens. If I just enable a few planes and the scenery I’m flying around, Content Manager doesn’t hang.

I haven’t had a problem until now, especially after the SU10 update. To add insult to injury, the bug of not purchasing anything in the marketplace but keeping the money has returned for me. The latter I have to wait & see if it solves itself before I go to Zendesk. But I feel the former might be a burden I’ll carry as I don’t know which addon caused this besides deleting all & loading the game one by one.

Today I had the same problem.
Reason for this problem was a community aircraft livery with a corrupt layout.json, that contained aircraft.cfg contents instead of a xml-coded file list

Since yesterday I have the problem again and this time no new addon is involved.
I could reproduce the bug like this:

  • Start msfs, go to profile/content manager: Content manager is fine and shows all addons
  • go to marketplace
  • select an item, that you have already bought and installed from the marketplace
  • click on “go to content manager” button on this items detail window
  • content manager opens and this time hangs loading nothing
  • no you can’t finish msfs by menu and need to shut it down using the task manager
  • when you start msfs new content manager still hangs except you delete all scenery indexes out of AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache before starting msfs…

Further investigation seem to show, that the problem occurs, when I have at least one community livery for the new Microsoft-Inibuilds a310 installed/activated. [changed]:
Now it has shown, that it is the same bug as posted here:
content manager not loading when more than 128 items are in community folder
so it has nothing to do with the a310.

As this report may be an issue (or by design) of limited addons, please use this topic for reporting: