Significant CPU usage spikes in low stress areas - caused by 'Rdr Thread'?

Have you disabled/removed all your mods and add-ons?


Are you using Developer Mode or made changes in it?

Only for FPS counters

Are you using DX11 or DX12?


Are you using DLSS?


Brief description of the issue:

I have a good system (i7 12700K @ 5.1Ghz/RTX 4090) and because I run at 30fps + vsync my system is under very low stress (see attached photo) and is generally very smooth and stutter free BUT I’ve noticed that SU12 has brought some significant CPU usage spikes. These are in seemingly random areas and more surprisingly can occur many km away from cities or airports. It is repeatable in a given area and not caused by head movement or camera panning. It is not due to network activity (I’ve watched the network utilisation and it does not correspond to the spikes - also I’ve tried with cache on and off). It occurs no matter what aircraft is being used. It is repeatable in a given position it rules out and 3rd party app using CPU. The spikes are so severe that they causes a visual stutter - this is very frustrating given the high spec and overall low use on my system. The screen shot is taken when flying a Cub from KUKI and heading southeastwards towards KSTS. It is taken about 2 mins into the flight. (Edit to add: all settings at ULTRA but zero AI or Live air traffic).

Provide Screenshot(s)/video(s) of the issue encountered:

Excuse the photograph but any screen grab tends to introduce a stutter and so I used my camera instead. Note that the FPS indicator has scrolled past where the CPU spikes occurred but do cause a noticeable visual stutter which has not been captured.

Detailed steps to reproduce the issue encountered:

The example I’ve used it a flight from KUKI to KSTS.

PC specs and peripheral set up:

i7 12700K - RTX 4090 - Windows 11 dedicated to MSFS (clean system nothing but MSFS).

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, many more stutters due to CPU spikes since SU12 beta, quite independent from the scenery I’m in (on the ground, in the air etc.)

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Here’s another example to show that the issue is not only in a single location.

  • This is a flight taking off from EGNC heading westwards at 6000’.
  • There are no major airports or cities for miles.
  • I’m heading towards the sea.
  • I’ve switched off AI online/offline.
  • I’ve switched off live weather.
  • There is no camera movement or panning.
  • There is no head movement.
  • Low speed aircraft at about 120kts (although the aircraft type does not make any difference).
  • There is no network activity to correspond to these spikes so it is not terrain tiles being fetched.
  • Completely empty Community folder

But look at the CPU spikes - what is the sim processing?!

It’s frustrating that with the very low average CPU use I’m still getting visual stutters even in these locations.

1 Like

Why are you rendering at a higher resolution? Are you definitely not using DLSS? Dev tools also shows that your GPU limited, can you provide a full screenshot of the stats? What aircraft?

Isn’t it related to NVIDIA 531.18 drivers?

I’ve encountered some abnormal CPU usage and spikes during gaming, eventhough the problem officially happens after exiting a game.

See Nvidia GeForce 531.18 driver bug causes higher CPU usage; company acknowledges issue


After watching the FPS window more carefully it looks as if these spikes are being caused by the ‘Rdr Thread’ - unfortunately they disappear off the FPS display so quickly I cannot capture it but here is the windows task manager showing them. It is frustrating given my PC is hardly being stress to have to see spikes/stutters like this in even benign areas. Remember these are not random but are repeated at the same geographical location consistently. If it is the render thread I wonder if there is a problem with a model that is being loaded - not nothing obvious is appearing in the debug console window.

Have you try and test by disabling the Rolling Cache?

Rolling cache is known to cause stutters, especially when it’s been full and start the rolling logic.

Excuse the HDR setting in the screenshot but I’m experiencing CPU usage spike in a similar manner. Nothing else seems to be taking over, its like the simulator just stops for a second. Otherwise the game is really smooth. I have even done a fresh install of windows and everything else and still have the issue and no setting changes make it better.
My PC should be good enough not to get massive stutter spikes like this. No other game experiences them. 5900x 4090 64gb ram.

1 Like

So in an attempt to eliminate a corrupted install causing these spikes and seeing that no further updates were coming post Beta 12 I decided to do a full re-install. What I did:

Deleted ‘One Store’ folder.
Deleted user config file.
Deleted all items from Community folder.
Complete download of all assets (scenery/planes/bush trips/etc).
Did not download any word updates or extras, i.e. totally vanilla install.
Started MSFS and selected Ultra settings (RTX 4090/i7 12700K should handle that surely!).
And yes, spikes still there in same locations as before…

So I repeated all the above steps on a second PC (it was a long day!) and yes, spikes still there.

I’m now convinces this is something in the software and not due to my settings or system.

Remember: My settings have no live weather, no live traffic, no PG, 30fps and vsync. My system is hardly breaking a sweat!

I think CPU usage seems to be markedly higher full stop with SU12.

My usual test is to park the Fenix A320 at stand 519 at iniBuilds LHR and let it settle down. I use either FSLTL prioritising the JustFlight models or FsTraffic itself so no live traffic. Prior to SU12, with the clear weather preset (actually, it makes no difference if Live Weather is on or not) the FPS with a cold and dark aircraft would be well in to the 40’s, ordinarily about 45.

Since SU12 it’s 30-33. Something has unquestionably changed for the worse and I’ve also, for the first time ever experienced stutters and actual pauses when flying. This is EXACTLY what I experienced during the beta and I left because of it. When I did a clean install of SU11 the performance was much much better.

DX12, 4K Ultra with DLSS Quality

RTX 3090
32GB 3200mhz DDR4
Fast NvMe SSD

Edited to add - on this system DX12 has always been better on account of the VRAM on the 3090. It would appear that with SU12 DX11 is now better which isn’t right at all!

1 Like

Is your issue only occuring in cruise?

Imm seeing really random behaviour in the cruise for what it’s worth. My fps is all over the shop, constantly varying from the mid 20’s to 50’s. My GPU is sat at 59% usage despite being 4K Ultra and the Fenix displays rendered on it too.

What exactly is the CPU doing that is stopping it from being pegged at 60fps?! Once upon a time, with a weaker machine, that is what I used to see.

What I’m describing in my OP and follow up posts is a very specific issue I’m seeing and not meant to be indicating a general decrease in performance with SU12 (there are a few of those threads elsewhere!). On the contrary I’m actually seeing a (slight) average lowering of CPU usage (and so if I had vsync off I guess that would be an increase in FPS) BUT that appears to have come at the price of the significant spikes.

I’ve been careful to determine that these are not randomly occurring in time (I’ll never see them when stationary - parked at a gate for example) but are repeatable at the same geographic location. However, what is ‘random’ is there seems to be no reason why they occur where they do, i.e. in the middle of country-side miles away from major airports or cities. If you read my posts you’ll see I’ve eliminated the possible ‘non-deterministic’ causes of this I have control of, i.e. AI, live weather, cache on and off, network connection, etc. but I’m still no closer to understanding what is the cause. Hey, maybe its just the design of the software!

I got exactly the same huge « purple spike » as displayed in this screenshot. Occurs randomly maybe once per minute on a 13900k. Did you find any fix ?

1 Like

Mine ended up being an HP printer that was connected via network. I removed it and the problem went away. Game is so much better now!
I think it was also hurting performance in other games too but it was much more pronounced in msfs.

This was really hard to find. I wasn’t seeing anything in process lasso out than a tick up in explorer.