Sim crashes when zooming in at the worldmap

Just found this thread as I’ve been banging my head on the desk and also been suffering the same issues noted. CTD on the world map, CTD around 80% load after “fly now” and on the rare occasion I get the cockpit, CTD anything from 10 to 20 minutes in.

Re-install achieved nothing, nor did running in a vanilla state. Disabling Bing data does seemingly cure as does the limited internet speed fix posted in the above thread so does seem to me that’s the root cause.

I’ve added to the helpdesk report volume, hopefully, it gets sorted very soon without the need to throttle internet speeds.

I had a crash in the map a few minutes ago with weather disabled.

I’m convinced that GPU drivers (in my case NVidia) have some contribution to this, interacting somehow with the rendering of the network map data.

How did I reach this conclusion?

I’ve been tracking this issue for a while in case it impacted me (and Location Manager) but wasn’t being affected by it, no matter how much I zoomed in and out.
I’ve been doing the NVidia driver swap for a while, as ever since the 40* series released they have been consistently inconsistent, causing CTD’s not just in MSFS (proven) but also other games like Starfield (proven).

I’m running an older RTX 2060 6GB OC (don’t laff, great workhorse GPU;-), and have always had great performance on MSFS with a combo of high/ultra settings (TLOD 120) + DLSS Quality and some NVidia console tweaks IF I can manage to settle on a NVidia GPU driver release that is stable.

For a long time I was on quite an old version that was stable (forget the version #) but pre-su13 I started keeping up to date again. Most releases seemed to have issues, but occasionally one release would seem pretty stable so that became my current goto GPU driver version.

Drivers 545.92 seemed fairly solid for me out of the most recent releases.

I recently updated to 546.01 and strangely enough the map zooming CTD’s started. Not all the time, but I’ve had about 4 so far which I wasn’t getting under 545.92
I also experienced map zoom CTD even with the optimised map filter mod.
ref: Sim crashes when zooming in at the worldmap - #331 by Sonicviz

I’ve just switched back to 545.92 and no amount of map zooming will trigger a CTD (so far) and I also have the optimised map filter mod enabled as well. Additionally, map zooming seems qualitatively smoother, with less hitches.

Upshot: Correlation isn’t causation but given how twitchy these NVidia driver releases have been I suspect GPU drivers also have a part to play in this issue as well, given the map is rendered outside the regular UI framwork (which I know from my experience developing Location Manager as an integration into the World Map).
I know from my experience so far there are some strange non-linear bugs that can occur with the UI, and GPU does contribute (confirmed from some user testing results as well).

I’ll keep monitoring and testing to see if I can trigger it with 545.92 drivers though.

my 2 yen


Since WU15, I’m getting CTD on first start up of the sim usually when zooming in on the map (and no error message). Once it’s crashed and reloaded, it’s trouble free.

I’m normally very lucky with (lack of) CTD, only recently become a problem.

Really bad again tonight. Presumably MS / Asobo are getting telemetry reports of all these crashes?

Who knows. All we know it’s logged along with currently exactly 625 other topics. It’s silence like always.

I get the same. Make sure you vote at top of this thread. Best workaround I found so far, is to remove weather and switch to IFR map when selecting your airport route. no more crashes for now.

1 Like

Just a quick note as the thread has grown substantially since I last looked.

My 100mbps workaround is most appropriate for those folk (including me) who are vulnerable to CTDs at all the terrain tile loading stages (map, flight loading, etc). However if anyone is only seeing issues at the map screen then changing the map format may be a more applicable (and easy to use) workaround.

P.s. I’ve now been using my workaround for over 3 weeks and not seen a CTD in that time except for when I forgot to reapply it after a few days away from the sim. (I turn it on and off as needed so as not to slow down my connection when not using MSFS).

Reminder the 100mbps workaround is only useful for those folk who are on high speed fibre connections via a LAN cable to the router. It will not solve any other general CTDs even if they appear to be similar.

1 Like

Agreed that the NIC speed change has resolved my CTDs so far. I was getting them during the flight loading process. I do have a high speed fiber connection.

One clarification from my experience: use the 100Mbit HALF DUPLEX. It slows down the connection further but still seems to work fine for loading things during flight and actually seems to give a quicker loading time overall after pressing FLY. The 100Mbit Full Duplex setting still resulted in some CTDs during the flight loading process (75-80% of the way through). It really seems like MSFS doesn’t like high speed connections after SU13.

I also just rolled back to 545.92 and the CTD’s on the map are gone. I also have a 1gig internet connection. Completely back to normal.

1 Like

Searching in the Zendesk site for the Minimum, Recommended, and Ideal PC requirements for Microsoft Flight Simulator you’ll be surprised to see that the “Ideal” internet speed is 50 Mbps (data upgraded on Nov 02 2023) .Weird enough…along with the “Ideal” HDD size of 150 GB

The reason why I don’t think that this is directly related to SU13 is that I never saw these CTDs during the very long (2 months?) SU13 beta and there was no update to the application for beta users when the release of SU13 went public. In other words unless something was dormant in the SU13 during that beta, SU13 can’t be the direct cause as the exact same executable was being used during and then after the release.

p.s. glad my workaround has good results for you. I’ll try the half duplex myself.

It may not be a change to the client post-SU13 but rather on the server side that they implemented at the same time. I don’t know, but can absolutely pinpoint it to starting after SU13 rolled out. I’m happy(ish) to have a working sim again, but worried about their thinner client plans for 2024.

I’m going to have to try this. Still getting CTD far too often on loading the flight. Very very frustrating.

Could someone be so kind as to link to the post that explains exactly step by step how to do this on the network card (Windows 11 if it matters)? Thanks!

Oh I agree fully. This very thread was first created days after the official release but my observations of no CTDs during the beta is persuasive evidence that it may just be a co-incidence that server configs (or whatever the cause!) were changed days after release. My exact words in an early post on this thread is that I’d now had more CTDs in 3 days than the total number I’d had in 3 years before whatever change was made. So I think I’d have noticed any CTDs during the beta.

Who knows? Will we ever find out? I doubt it :slight_smile:

This is what you need to change…(same on Windows 10 and 11 BTW).

Sim crashes when zooming in at the worldmap - Bug Reports / Crashes (CTDs) - Microsoft Flight Simulator Forums

1 Like

Scroll about 40% of the way down, where it talks about setting your speed to 1 Gbps. In our case, though, you want to select 100Mbit Half Duplex.

1 Like

Remember my previous warning that changing this setting will disconnect your network card for a second or so. Make sure you’re not mid-way through a big (non-resumable) download!


I’m curious if anyone else running the latest beta of SU14 ( The release notes showed “Several crashes have been fixed across the title”, so I’m running it now and, as I write this, I am flying my 16th random aircraft at my 16th randomly selected airport without a crash. I’m also running my internet at full speed (1 Gbit) and zooming in and out of the map as I would normally. I’m also using the satellite image with the cloud layer.

Obviously, I am not going so far as to say it’s fixed with this release, but I can say that something hasn’t definitely changed for me. I understand that not everyone is a big fan of testing betas but I’d be curious to know if anyone else who is running it, is also seeing increased stability.

I am having the same issue , I9 13900K (Stock) 32GB Ram , RTX 4090