Sim crashes when zooming in at the worldmap

Sometimes then, sometimes at other stages. It’s completely inconsistent. It also never happened once before SU13.

Well I’m genuinely disappointed. I posted the workaround over a month ago and I believe you’re the first person who it hasn’t helped as far as I know! Of course they may just not have fed that back into this thread. You say there are others it didn’t help - did they post elsewhere?

Hopefully Asobo are closing in on a appropriate fix by now and the workaround can be removed as no longer needed.

Lets hope they find the common denominator to fix it for everybody.

As with @AboezD you’d be the first i hear of that the NIC speed didn’t help, if the causes are the same.

To be clear, when you say you changed your network speed, did you try the 100Mbps Full Duplex as originally suggested, or 100Mbps HALF Duplex as I suggested subsequently?

In my experience (and other have reported favorably as well), that’s been the only consistent workaround.

Have had a total of 3 identical CTDs (same Offset) in current SU13 (in about 100+ Dev sessions)
West Coast USA

Tried both for extended periods of time. Doesn’t work. Still get the same frequent CTD’s when zooming on the World Map.

As I wrote earlier, unfortunately the network speed trick didn’t work for me either.
Only and only disabling Bing Data eliminated both the World Map CTD and the CTD during the fly.
Exactly the same thing happened to my friend who I fly with. Bing Data off = no more CTD.


You’d previously said:

This doesn’t seem the same experience that most folk who the workaround has helped (or to be accurate they didn’t include such behaviour in their report). Perhaps you have a different source of CTDs? Or perhaps my workaround isn’t as universal as it appeared to be? Who knows? Hopefully Asobo :slight_smile:


Thanks, I’ll try this.

edit - no luck :frowning_face:

1 Like

Turning off cloud layer in the filter setting of world map has eliminated the CTD for me.

1 Like

This is currently happening to me. Super annoying!!!

Any news from beta users?

The SU14 public release is coming and haven’t heard about any fix yet.

Reducing my speed to 100Mbps full duplex or half duplex didn’t help me at all–then again, my consistent CTD happens after about 60% progress bar after pressing “Fly”. I only get CTD in map view if I zoom too fast. Though waiting about 30 seconds before zooming also seems to help. For me the only “work-around” that keeps me from crashing at all, is to turn off Bing Data. If I try re-enabling Bing Data after “spawning” at an airport, then I get CTD immediately.

EDIT I think I found a solution for the CTD after pressing “FLY”.

  1. delete rolling cache
  2. disable Bing Data
  3. Apply and Save
  4. Spawn on airport (Press “Fly”)
  5. Once loaded go back to “options>data”
  6. Enable Rolling Cache again (it only worked for me if I enabled rolling cache first) {Apply and Save}
  7. Enable Bing Data but make sure Photogrammetry is DISABLED {apply and save} (did not work if I enabled both of them together)
  8. Enable Photogrammetry {apply and save}

So far this has fixed my CTD even after restarting the sim (I still have to be careful of zoom speed in map–even with cloud filter turned off). Up until now, I was consistently getting CTD over 30 times in row, so this at least seems to have “fixed” it.

1 Like

Wow, your CTDs experience is so severe that perhaps it’s no surprise that my workaround did not help you. I admit it is weird that it works at all! For what I can see posted in this thread most people were experiencing a couple of random CTDs per session not every time they ran the sim. That was certainly my experience.

Glad you’ve found a workaround that ‘fixes’ it for you though as posted just above by @Darewell there has been no mention of any official fix so far in the current beta (although I’ve just updated to beta and so that may bring improvements :crossed_fingers: ). I’m genuinely fearful that we’ll see the issue in the release of SU14. Hope I’m wrong.

You can add +1 satisfied customer.
Since SU13 I started to get CTD’s in the world map when panning and zooming.
It’s something introduced in SU13. Previously it didn’t happen.
This workaround works for me. Not one CTD since.
Since it started I immediatly suspected it was something to do with loading objects or textures in the world map.
The strange thing is going offline doesn’t work. I still had CTDs offline.
Didn’t try to turn off bing maps. Just switch to offline.
Oh and switching the filter to IFR map also worked. But no need for that now.
Just curious. It started to happen around the same time I actived REBAR and updated graphics drivers.
How many of you are on Nvidia and have REBAR active?
As I understand it REBAR deals with large amounts of texture data being pushed directly to the GPU.
Maybe it’s connected to the CTDs…

FWIW I have Nvidia GPU but not REBAR, and I never had a crash zooming in the world map even on a 1Gbps full duplex connection.

Funnily enough, just about when you wrote this, I had the same idea: that it might be related to ReBAR. I have had it activated for a long time, and I was seeing something strange last night related to the crash reports I see (don’t know why I hadn’t noticed it before).

The amount of memory it shows for textures that have to be unloaded after a cash is enormous. Too large to be a real number and so I think something in SU13 might have screwed up theemory referencing of textures. I’m going to try tonight to test the ReBAR setting and see if it makes a difference.

1 Like

I also have a profile using the Nvidia advanced profile thingamajig to enable ReBAR… so that could well be a factor here! Let me know your findings and I will have a tinker over the weekend too (can’t tonight).

Just a quick report back. I only had a few minutes to test and while I didn’t CTD on loading the flight after disabling ReBAR, it also took a really really long time to load. So long that I had to quit MSFS before it finished loading (which was way after it would normally have CTDd).

I’m fairly certain there’s a texture memory management issue that is made worse with ReBAR allowing a greater allocation of memory.

And, the reason reducing the network speed (especially to half duplex) workaround might work, is that it limits the amount of textures that the sim needs to process in a short amount of time. Possibly the condition arises when, above a certain amount of textures in a certain amount of time, an allocation of or calling to a memory pointer that is out of bounds gets triggered. This could be made much more likely with those that have very high speed connections.

I will try again tonight and see if the slow loading was a one time issue or if it persists, and I will also try after deleting all my caches.


I can confirm I have Resizable Bar enabled too with my 4090, with a 2Gbps fiber and a 2,5 Gbps ethernet port.

It has been 1 month without CTD since I stopped using ingame Bing data, hoping for a fix with SU14, they advised us to join the SU14 beta to get a fix before the public release, still no news :slight_smile:

1 Like