Simulator does not start anymore, update impossible, reinstallation impossible

I confirm that the clean installation fixes the problem

This is where I’m stuck too. On Windows 11 Insider Beta. Windows Store doesn’t show an update.

The answer can be found here Where are people downloading the hotfix from? - #11 by SlinkyMate thanks to @SlinkyMate

Thaïs launcher is a joke ?

2 mb/s, seriously ? ■■■.

124 hours for download mfs for me.

Yes, a CLEAN install of Windows 10 Pro, does fix the problem. After a month of doing resets, repairs and all other work arounds, I wiped the drive and did a clean install. Fixed.

If you use Process Lasso, then disable it before starting MSFS 2020. Apparently it crashes the sim after a few seconds. None of the less, I am unable to download anything from the Microsoft servers. Zendesk investigation is pending.

It’s terrible, I reinstalled windows just to try it out, I went back to my original configuration, I had done an image made with Acronis before, and I don’t intend to reinstall everything just to be able to install MSFS2020, I will put that aside for a few months. I’m fed up

I’m at that point,should I wipe windows and hope MSFS su5 works? Should I try buying from steam instead of MS store? I really miss VR. Being in lockdown for over a month so far,and no way out in sight,with MSFS VR I could escape to the skies-not any more.

Don’t bother with steam either. I’ve just finished a fresh windows install, drivers etc, and still won’t start from steam. Have the initial 700mb game downloaded from steam but it won’t start. :man_shrugging:

1 Like

Hello everyone, I am having the same problem after update 5, I have tried all the solutions even the solution of reinstalling Windows 10 with MediaCreationTool21H.
I am at the stage where MFS2020 was uninstalled due to its reset and unable to reinstall it from Microsoft Store.
I still note that Microsoft Store is working since the other updates are going well

Édition Windows 10 Éducation
Version : 21H1|
Installé le ‎31/‎07/‎2021
Build du système d’exploitation 19043.1151
Expérience Windows Feature Experience Pack 120.2212.3530.0

At the price or is sold the software I hope to expect better.
And now what do we do?

Hello, wait for a windows 10 update that would fix the problem, or format and completely reinstall windows 10, but beware a fresh installation does not solve the problem for everyone, some have done it and still cannot install the simulator.

For more than a week, we owner of PC have been badly led by Microsoft

1 Like

I have a similar issue with MS store and can’t re-install.

After the last update it ran OK for a while then after a CTD the sim started throwing me to the store to install XBox game sevices which were already installed. I went through everything i could find here and many hundreds of other web pages to no avail. Eventually uninstalled msfs, all the XBox apps and components and ms store. Installed all the store stuff and the XBox apps, game services etc. But msfs now refuses to install.

I have done a clean Windows installation fully updated and have spent four days inside windows registry and powershell and am no further forward.

I am logged in perfectly well everywhere, all is updated ok but the store installation just sits there “pending” and going nowhere. All other downloads from the store work OK but not msfs.

I may need to resort to raising it with Zendesk and Microsoft but from reading all the threads they have responded to out there it looks like they don’t have a clue either as there suggestions rarely lead to a cure.

I am starting to think it is an issue on the Microsoft side though with either Store itself or my profile.

Bugs, updates and hotfixes are annoying but par for the course with software these days and I can accept that as long as things are moving forwards but what chance do we have when Microsoft can’t get their own installer to install their own software on their own operating system without this performance.

I can’t spend any more time on this thing. I do have a couple of unused Steam vouchers so I may give it a try with their installer before binning the whole thing. Anyone gone down that route and care to share their experiences?

Any and all suggestions would be welcome

G.

Hello, it’s the same disaster for me. I appealed to Microsoft support, I’m still waiting for their response.
The problem undoubtedly lies with Microsoft and not with the users.
Do I have to use a pirated version to be able to use this software?

PC users sacrificed, for the sake of another platform ?? :frowning:

1 Like

I do have the same problem in the German version: After starting, again and again this sentence appears on the screen: “Ein neues erforderliches Update ist verfügbar. Bitte führen Sie vor dem Starten von Microsoft Flight Simulator zunächst ein Update mithilfe des Microsoft stores durch”. I already have the Version 1.18.13. In the store there ist no update available. I tried to shut down the virus protection and the firewall, the community folder is empty, I changed Joystick an throttle … nothing helps. I can`t start anymore. It makes me crazy… From where do we get help???

Still no further forwards. I have tried everything including a complete reinstall of Windows.

Clicking on Install in MS Store does absolutely nothing.

It ran OK for the last 12 months but after SU5 it CTD’d, told me to re-install and that was it!

At the moment I feel I have paid £110 for a very expensive icon!

Whow! I am happy! The Flight Simulator 2020 is working again! —I went to “Apps and Features” (a list of all my installed programs on my computer), klicked on “Gaming services” - then “Extensions” (“Erweiterte Einstellungen” in red letters) and klicked on “Reset” (“Repair” did not help). Then I started my Computer completly new and tried the Flight Simulator: It workes like in good ol times!! - So perhaps this may help others too.

I had tried a few days ago, I just tried again and nothing helps, I still cannot install the simulator.

When i try to install, the download is paused and doesn’t move

i have exactly this problem https://xbox-forums.com/threads/gaming-services-error-12007-0x2ee7.451204/, but no solution worked.

I’ve had no other choice,no help from Asobo or Microsoft-tried all known fixes bar wiping windows and buying from steam. A pirate pilot with VR is the only friendly skies left for me.

Don’t waste your money. I am on the same dilemma as you, but the other way around. I am on Steam and was thinking about buying from MS Store. No. This problem exists both in MS Store and Steam.

I had similar issue not being able to download. Ms store version. I uninstalled trying to get more fps but it didn’t matter. I should have just updated. Well to get to install I had to plug my computer directly into my modem, no router, go into network advanced network settings, change adapter, right click on ethernet, properties,configure, advanced then set speed and duplex to 100 mps half duplex. After that I was able to download and install again. I have no idea why this worked for me but i read some hints through the forums. I also noticed that when going through my modem to update packages inside the sim it would slow the download down until it stopped and started over. I had to use the above settings for those to be installed also. This whole install process stinks and needs addressed. I am also wondering if the modem issue effects the losding and performance inside the sim when flying since you are streaming data? I hope this can help someone because I know how frustrated I am with the whole thing.