Simulator does not start anymore, update impossible, reinstallation impossible

Hello

On the 27th I installed the SU5 update without problem and the simulator started, yesterday I tried to launch the simulator so that it suggests to me to update the SU5 patch, since it was not not available in the windows store.

Every time i try to run the simulator I am referred to the microsoft store on the gaming services page, I have researched and found posts with potential solutions,

So I tried to uninstall and reinstall with the Poweshell, erase the registry keys, reset the gaming services ect … nothing helps, I cannot launch, in the services only one out of two Gaming services is started the second one does not want to start (with error 12007 :: 0x2ee7), a google search and nothing about this error related to gaming services.

I used the MediaCreationTool21H1 to repair windows, installed all the updates including the latest update KB5004296 supposed to solve problems with the games.

As a last resort i uninstalled MSFS2020 and now tried to reinstall it but the download is pending and won’t start.

I tried to deactivate the firewall, windows defender, log out and reconnect on the store ect … and still nothing.

It seems to me that it is since the last update of the Gaming Services version 2.54.22004.0 made on July 29

MSFS2020 installed in the default directory, just the content installed on another hard drive

I have never had this kind of problem since the Beta test phase of the simulator, I don’t even know if formatting my pc and reinstalling everything will fix the problem and I sincerely wish I didn’t have to.

IF anyone has an idea I would be grateful for their help, thank you in advance.

Config :
Asus ROG Strix X570-E Gaming
AMD Ryzen 9 5950X
Gskill 64 GB DDR4-3600MHz
Gigatybes GTX1080 8GB
Sabrent Rocket Nvme PCIe 4.0 - 500 MB for WIndows 10 & 2 TB for MSFS2020

Hi, I solved like this. You must go to microsoft store, go to my collection, search Microsoft fligh simulator, click start. it will open a window, there you can download the fix…
regards

Thank you for your answer, unfortunately I tried this solution before completely uninstalling the game, and I did not have the option to update.

Now the reinstallation is pending and the download will not start

1 Like

Did you try this article?
Download & Installation issues: Windows Store troubleshooting – Microsoft Flight Simulator Support (zendesk.com)

1 Like

Yes i tried all the suggestions before repairing windows, i will try again.

1 Like

Did you try the MSFS–> app settings–> repair function?

1 Like

Yes I also tried that ! :slightly_smiling_face:

I have the same problem. On the 27th I installed the SU5 update, it worked without any errors. Yesterday evening I started the APP and it forwarded me to the Windows Store for a patch.

I was only able to load the patch after a few attempts, but the app no ​​longer started. I have worked through a lot of instructions from the forum and the internet, including the link above twice - without success. When deleting registry entries for the gaming services (was recommended somewhere) I broke them. I was able to solve that by uninstalling the Gaming Services and XBox and reinstalling both apps.

Finally I have completely deleted the MSFS and reinstalled it, without success. The installation file is loaded in the store (almost 700MB). When I press “launch”, it opens very briefly (at the bottom of the bar) and closes again. Afterwards nothing happens, when I try to relaunch MSFS.

Like Sahak92 I also have the installation on the default hard drive and the packages on a second SSD. I finally checked the windows event logs and found the following: Whenever I click on the MSFS app, I get an event 51 error about accessing hard disk 2. This is strange, because I only have hard disk 0 (the main hard disk) and hard disk 1 (the SSD for the packages).

I don’t know what else I can do. I’m already pretty desperate.


This is where I am too. When I click on “OK” the store opens and no update or download exists…Never experienced so many issues with any other game, sim, or app.

2 Likes

I never heard of a Event 51 error here in the MSFS forums. You may want to do an internet search on this error.

These topics contain various solutions:

FS Pushes me MS Store for update - Nothing there. FS Shuts Down - Bugs & Issues / Install, Performance & Graphics - Microsoft Flight Simulator Forums

Unable to download SU5 hotfix from Store - says I’m “good to go” - Bugs & Issues / Install, Performance & Graphics - Microsoft Flight Simulator Forums

1 Like

@aracines thank you for your help, Tonight I am going to do a restore image of my current installation, format, reinstall windows 10 and I will try to install the simulator again, I will keep you posted.

1 Like

I’ve just done a windows installation (i did not format the drive.)…just performed a “windows upgrade” as it suggested in this thread to fix the 0x00000001 error… and did not work.

In my case, i not have the sim installed, and i can’t even get to download from the store the installer.

I also tried repairing windows with MediaCreationTool21H1, keeping my files and programs and it didn’t work.

I tell myself that maybe a fresh and complete reinstallation will solve the problem, even if I will go back to my current system image, because I don’t have time to reinstall all my programs and reconfigure everything.

I do it tonight and I will post the result here

It was pretty much a fact that this is the only solution of this nightmare.

But honestly, … what would happen after $$)))=)=·$ update 6? re install windows again? ahahah. The sim update day is like “Groundhog day”

I thing buying this is the most i regreat in my life after a 340 plane bought from peter hager

It is clear that if this should happen again, it will become painful, I hope it is an exceptional case.

I am pretty sure that for me the problem is with the latest Windows Gaming services update, before everything was fine. I was able to update SU5 and do 2-3 hours of flight time (and enjoy the few CTDs that I had never had before this update :rofl:), but not patch the SU5.

I had some issues the other day.

Check add remove programs to make sure it’s gone. Also check on the Xbox app to make sure it’s gone - mine was stuck with some error

1 Like

I just checked and everything is good on that side. Thank you

try this

Hello everybody same problem here i tried all the solutions mentioned above and can’t lunch the sim yet

|Edition|Windows 10 Pro|
|Version|21H1|
|Installed on|‎01-‎Aug-‎21|
|OS build|19043.1151|
|Experience|Windows Feature Experience Pack 120.2212.3530.0|