Simulator suddenly constantly crashing on Xbox Series X

What the title says. Let me just say, I have no clue what really happened. But all of a sudden, for the past 2 weeks, I have not been able to complete of my flights because the sim always stutters then CTDs a couple of minutes when at the gate before departure. It is frustrating and I am scratching my head over this, because the sim was running flawlessly for me before the latest SU7 HF. It even happens at Asobo handcrafted airports :disappointed:.

All I want to do is fly. Asobo, is that really hard for you fix and make the sim more stable? Do I really need to buy a gaming PC just because the game is suddenly unplayable on my Xbox Series X? All my other games run perfectly, no problems.

I can’t be only the one experiencing these issues.

I loathe to suggest all the usual suspects, but here goes.

Did you delete and/or turn off the Rolling Cache?

Have you purchased any 3rd party add-ons recently or within the timeframe you’ve noted the CTDs?

Have you updated any 3rd party add-on in this same timeframe?

Have tried uninstalling add-ons and retesting?

Have you tried setting online functionality to offline and tested?

1 Like

I’ve tried everything. Rolling cache on, rolling cache off. Uninstalled 3P addons, still happens. Tried re-installing the sim. Tried changing to a lower resolution. Photogrammetry off/on. Live weather on/off. The sim will just stutter. If the stuttering gets too much, it gives up and CTDs. Unfortunately that’s how it is now. Sim really is broken on console at the moment. Even BF2042 runs better than this. I just don’t understand how it was running perfectly a couple weeks ago.

3 Likes

Yes, this is why I’d asked the questions. Something had to have changed here. It doesn’t make sense otherwise.

Definitely. I just can’t bring my head around it. Could it really be server issues in the run up to WU7?

I’m hoping that WU7 at least addresses some regular instability, but maybe I’m being too optimistic. We’ll see.

This is happening to me every time i try to return to main menu from a flight. In on series S.

I had 5 Ctds on Xbox series s can’t wait until they fix it

…my series x keeps crashing when i try to land after 2 hours flights… very frustrating…

3 Likes

Mine started crashing when returning to home then loading in to a airplane for a new flight. Series X I noticed it right after the Australia update. Though around the same time I got the PC-21 from the marketplace.

If any of you have stripped your installation down to the absolute bare minimum — no extra content whatsoever and that includes uninstalling any/all World Updates, and you’re still getting CTDs, try this:

Quit FS2020:
Xbox Home—>highlight FS2020–>press Menu—>select “Quit”

Then Clear Reserved Space:
Xbox Home—>highlight FS2020–>Manage game and add-ons—>Saved data—>select Reserved Space—>press A and choose “Clear Reserved Space”

Restart sim and test.

Let me know if this solves anyone’s issues, please.

1 Like

Didn’t solve mine, I’ve stripped it down several times and mine still does it.

I used to do this all the time ever since MSFS launched on Xbox. But this time the method doesn’t work because nothing has been corrupted. The game is fundamentally broken on the XSX and it desperately needs a fix.

1 Like

I’m hoping that this OS fix that there’s hints to should offer some help. That could be months away unfortunately if that’s the case :worried:

You’re right that there’s something wrong with our systems, I’ve suspected as much for months already. In the official test environments, things run fine they reckon but things go pear shaped once out in the wild. They also run their emulations and Xbox’s on a closed network away from anything we have, so all very technical indeed. There are definitely discrepancies between us and them.

That’s odd. I get no stutters on my console X Series. But I get a few crashes. My best bet re-format the console and install everything again.
When I crash I just setup a new flight plan and then it works ok.

After yesterday’s update, the game ALWAYS crashes now after loading a flight.

Version: 1.25.7.9

Xbox Series X

GAME STILL BROKEN UNPLAYABLE

4 Likes

Same here! Stutters and crashes all the time!

1 Like

Hello,

Same here. Before 1.25.7, the sim was really working fine on my Xbox Series X. Now the game stutters like crazy, the nav display doesn’t work properly on the standard A320 Neo, and I never managed to complete a single flight, since I have been experiencing CTDs every single time since the update.

4 Likes

The game works better for me than ever before after I changed just one little thing.

I have to say that nothing worked before. The Vfr card kept getting stuck. I couldn’t complete a flight without the sim crashing. Every few minutes the game was shaking. In the menu the courser kept freezing. Basically all the experiences you have had.

All you have to do is go within the Flight Simulator to Options select General and then Data. Now you will find the item Cache at the bottom. Please clear it once and ignore the warning. Go back and save it.

Then close the sim and restart it.

I really hope that it will work for you too. I am very happy to be able to enjoy the game again. Just made another flight with all third party mods without anything getting stuck or crashing.

Have fun and enjoy your next flight!

PS

I hope I have expressed myself clearly. I come from Germany and am therefore not 100% fluent in English.

Greetings from Frankfurt!

Its good advice, except, for quite a few users, the cache options are now missing :wink: