Slow download of updates and game files - Data Limit Override Needed

yes… this is a new possible feature “postpone an update”. But I assume, because possible side effects with multplayer-code, this might be not allways possible. Then users have only the choice to stop the update and can not play.

At least that would then be a choice.

If the updater would prompt,

"You have 50 GB selected as your Data Limit.
You are currently at 45 GB.
This update will consume 25 GB.
Do you want to continue?

If you select, YES , your Data Limit will be ignored and you may incur additional charges from your service provider."

then the user can decide if they want to blow through their data or not. Currently the update is just going to go ahead. If the data limit is exceeded the update will fail. If it automatically ignores the preset limit the user may not even realize they have smashed their limit until the monthly service provider invoice shows up.

1 Like

sounds good… like an extended “choice”.

PS.: I realy wonder how many users have in 2021 a data-limit… I assume I need per month 1 TB ( PC with all the updates, game updates, games itself, the all the video stuff, handy, … )

With some MMO the loader provides you a chance to change your (Options) in-game graphics and other settings before you launch.

With the download bug they have going on that locks your download speed to whatever you had set last has resulted in it taking THREE and FOUR days for some people to re-install with no way to ‘clear’ their previous settings stored in the cloud first. They have to just endure it until they can get back in and change it.
This is a known bug on Zendesk.

Anyway it has me thinking that is probably WHY other MMO’s in the past have also added in the ‘Options’ in the launcher.

No idea if they will fix the download bug but having the ability to make sure your download speeds are max first would sure help.

Cheers.

How long does it take to download the new update? So far its taken about 23Hrs and it has only downloaded 4.65GIB out of 22.22GIB. My internet download speed is 85.90 Mbps and my DATA is set to unlimited

On My 4th day of re-downloading, searched high and low in the install folder and I can’t find the setting file with the data cap or speed limit. Can set the graphics up for the game I can’t yet play though. Awesome.
Tried pulling ethernet out but get an error off xbox and a loop denying access to settings.
Cleared store, deleted cloud data, which refreshes anyways as selecting ‘local’ downloads something and keeps the 20Mbits/s cap. I’ve tried all the netsh commands =disable makes speed start at 0 and climb to 20 then cap, =normal makes it start at 40 then crawl down to 20 cap and bounce up to 30 and down to 20 and up to 25 and back to 20. So stupid. Somewhere there’s a “20000” limit that I can increase to stop the bungeeing.

I’ll probably install it, crash once, and uninstall as my patience is gone. Worst installer I’ve encountered since home brew cassette’s.

I can’t believe it has been nearly a year since I first downloaded this sim, and downloads are still a miserable experience. MS won’t actually assist with the problem as they’ve pawned it off to communities. Why can’t I download an airplane I purchased that is a mere 579MB? It starts downloading, stops, starts again, stops, starts again then completely stops. Why doesn’t it remember where it stopped downloading and start again? I have about 10 items I’ve purchased and am unable to download them. Why can’t MS fix this awful system?

Good luck. It took me literally 7 days of trying to finally get the latest update. I had to uninstall, turn off anti-virus, firewall, flush cache and do a dozen other command prompt items and it still took more than 18 hours to download 171.22GB. I have about a dozen items purchased in the marketplace that won’t download. MS won’t help. They only point me here or to another forum and expect me to read dozens of user generated entries and figure out which one applies to me.

Got it downloaded. Changed DL settings. Saved.

Decided the entire Windows install could do with being nuked so wiped the lot and started over.

Game re-DL’ed in two hours, all 160 whatever gigs + setting up the cache.

Awesome.

PS. Now it crashes if I try and click general settings and my new stick has a mind of its own. Honestly… :joy:

I thought the ‘crash on general settings’ issue was related to the sim’s ability to write to your hard drive (permissions). There were two solutions, first, reboot and go straight in, no problems. Otherwise, start the sim as Administrator to see if it’s a permission thing.

Oh god I thought I was the only one. Can’t believe it’s been a year and no fixes for this. I’m making an install on my new PC and I just can’t remove the speed cap because I need to update before I can edit the settings.

I can’t delete the save file either because xbox will download the cloud save right after I open the game.

Anyone got a workaround or know a way of deleting the game pass cloud save?

Had to finish the whole download to access the settings and change the dowbload limit. Super frustrating.

Since the fresh reinstall of Windows and MSFS20 clicking general settings crashes everytime. Can’t access general settings to try changing rolling cache path or graphics settings.

Got a flight stick and both it and xbox pad have a mind of their own as if there is always some force being applied pulling the stick back and left.

Single worst gaming experience of all time.

It’s ok, once your in… it will be the best flight simulation experience of all time.

Unfortunately no lmao

The game starts, i can fly with whatever settings its downloaded from the internet - settings created 6 months ago on an older CPU and a 1080p monitor.

Now running 1440p monitor, faster CPU, doubled up my RAM, moved everything to gen 4 nvme drive.

None of it matters as the game CTD on clicking general settings :joy:

Tried adding the US English language packs, EVERY possible fix on the CTD Troubleshooting steps, have run up 450gb of downloads, have clean windows installs and so on.

Can we edit the settings file outside of the game?

sometimes windows applications like to start once, then close completely once. Then, when run a second time, behave differently. As if the application didn’t close completely and some LOG or INI file got corrupted. I was seeing this behavior in FS20 recently (in 2021) as I couldn’t get the sim running after an update completed. But low and behold, I just needed to unplug and restart everything… and it works fine now. I did have to remove some community addons that were causing issues too (littlenavmap) but have since been resolved by the developer.
I hope you get your sim up and running smoothly.

It’s happening again. Looping on big file 156 of 178 at 25MB/s until I turned on my VPN and Proxy to slow the speed to 14MB/s.

It was working fine up until the PC-FS-BASE-BIGFILES-0.1.144.fspatch (file number 156 of this new 1.16.2.0 patch)

I simply wish we could adjust the Simulators Bandwidth Data settings PRIOR to updating. I don’t understand why they force and lock users into updating without allowing the user to first PREPARE the system.
They know about, and have responded with patches aimed specifically at this download looping issue. (their official solution includes exhaustive system and network configurations, removing TCPv6, etc.)
I expect it could even happen while in-game and we wouldn’t notice that the same Scenery and Textures were repeatedly loop downloading because the Microsoft Servers were choking and continuously resetting the connection and the Sim doesn’t STOP after trying 100000 times). Hopefully, the installer packages are hosted on different servers than the scenery and content data.

FS20 is the BEST VR Flight Simulation experience period… but the installer has been the worst. I’ve been doing this since FS1 in 1983.

EDIT: now that I got into the Sim, I found that I had changed the Bandwidth to 20MB/s and that is why the installer reset continuously when it hit 23-24-25MB/s as it spooled up on the big files. Small files will complete quickly, before the bandwidth rises above 25. So people with it set to 40MB or higher, may not experience the issue as frequently as those who are set to 20MB or lower. Which supports my entire argument above… not being able to adjust the Bandwidth setting before or during a pending patch being released.

1 Like

For those having issues - if you purchased via steam, the settings are stored via steam cloud - you can temporarily disable steam cloud and move the files to get the default settings
until your download finishes… see Download loop due to internal data cap

If you’re Windows Store - I think the only solution is to log in with a different Microsoft/XBOX account that doesn’t have the settings saved. I think you can force it to ask for new creds by deleting the saved Xbox credentials inside credential manager.

Well, the true Solution is for the Bandwidth throttling software code in the Updater Routine to actually adhere to the Configuration set previously by the User while also allowing re-configuration (including resetting to defaults).

  • A simple workaround is the User can throttle their own bandwidth to match any custom settings previously set. (using additional software outside of FS20)

This only affects a small number of people who go into their Data Settings and LOWER the bandwidth limitation settings.

KSIElevenBravo wrote this guide a while ago. It should be related to the described problem: