Everyone having scenery resolution streaming issues - PLEASE READ

I see many on these forums complaining about lower quality ground textures after the last patch, and are wondering if it could be a data issue streaming from their cloud. If you’re connected to their servers in-game, have all of the data options on (streaming, photogrammetry, etc.), and are still having issues – please take a look below and give this a try.

Open Win10 Settings → Search for Xbox Networking → Click ‘Fix It’


Got a small improvement in latency value, thanks.

Thanks! I was noticing slower streaming of assets compared to the previous build and this seems to have resolved that. :slight_smile: Also recommend restarting after the ‘fix it’ button completes as that helped even further.

1 Like

mine is open and connected and running 1gb speed internet plus running on Ethernet not wifi and still very bad quality looks like fsx and orbx together now


Took me a while to fix the Teredo service as the FIX IT did not work.

With an elevated CMD prompt type the following to see the state of Teredo
netsh interface teredo show state

If it says disabled then type the commanad
netsh interface teredo set state type=enterpriseclient

See if it then works with the XBOX Networking test.


HI @KSIElevenBravo
Thanks for that - great tip!

Thanks bro ! its better :smiley:

This one worked for me, thank you.


Thank you very much for this post which was very helpful!

As the other guy pointed out, and which worked for me without having to run ‘Fix It’ every time I restarted my computer, you can also do the following:

Run Command Prompt ‘CMD’ as Administrator, then type: “netsh interface teredo set state type=enterpriseclient” without the quotes.

I type CMD into the cortana search in Win10, then right click the Command Prompt an Run As Administrator.

To me same as previously, nothing changed…

Unfortunately none of the solutions have resolved the Server Connectivity Blocked for me…


Okay an update. After a reboot of my PC seems it is blocked again. I found a way to permanently fix the issue and tested it after a reboot.

You will need to access gpedit.msc and those with home versions of Win10 (most of us) will need to enable the disable gpedit.msc

One suggested method and you are welcome to google other methods is below:

Enabling GPEDIT microsoft console on Win 10 home edition

Run the gpedit.msc command and then follow these intructions:

Instructions to modify Teredo through group policy

Also from what I have read you must hae the win 10 firewall on in order for Teredo to properly work.

See Microsot’s other requirements here

MS Teredo Troubleshooting

1 Like

None of the above works for me… Windows firewall on or off, still get server connectivity blocked.

1 Like

It’s kind of sad that so much tweaking is necessary in 2020 just to get a proper server connection. No other multiplayer game has ever been like this, they just connect to a server and work. What is the point of NAT, and why is this only an issue on Xbox related things? I’ve had this problem playing Xbox games but never anything on PC.


I dont have any issues regarding this , at least not yet but Ive checked out of curiosity my ESET FW rules and I found this .

Believe me or not I did not add those exceptions. And I dont have interactive mode selected.
So it seems that Microsoft is again pushing limits and breaks any privacy whatsoever by doing this.

TLDR users with different firewall may dont have exceptions and have issues, try creating rule like is on screenshot

No issues here with connectivity, just reduced LOD and that sucks…


I’ve tried the following: creating a local cache at the highest definition for a particular area (Alameda) and I can’t see any difference when streaming or when using the local cache. Either there is a LOD bug which is also affecting downloading assets to the local cache, or there is no bandwidth limitation at all and the LOD is just reduced between v1.7.14 and v1.8.3.


gpedit.msc did not work. I followed all the instructions but… nothing. All I get is “MMC could not create the snap-in”

It is sad but all these suggested fixes don’t work for me.
This connection problems occur since the second patch. One might questioning the quality department for releasing such patches.

1 Like