Solved my CTDs after months of being down

For PC - MS Store Version

I haven’t been able to fly in MSFS since the summer - probably since SU5 without a CTD either from the main menu or a few minutes into flight. I finally have it solved (knock wood).
System: i7 11700k @4800mhz, 64GB T-Force DDR4 3800, RTX 3070 factory clocked.
ASUS ROG Z590-A motherboard.

Overclocking had nothing to do with my CTD’s. Rolling Cache had nothing to do with my CTD’s. Page files had nothing to do with them. NVIDIA Game Ready vs Studio had nothing to do with CTD’s either.

I went into my applications and started uninstalling everything I could find that wouldn’t effect the operation of my PC.
Removing one of these apps did it. I don’t know which one (yet) - but I’ve been flying with all my add-ons (including FBW A320) for 2 straight days on VATSIM.
Here’s what I removed. Removing one of these was the silver bullet for me:

  • ASUS Armory Crate
  • Realtek High Definition Audio Driver (from 2019) (my audio still works)
  • ASUS ROG Live Service
  • ASUS Aura (LED light utility)
  • Corsair iCue (LED light utility)
  • ASUS Fan Control Service
  • ASUS Framework Service
  • Patriot VIPER DRAM RGB (don’t know where that came from)
  • Patriot VIPER M2 RGB software (don’t know)

I suspect either the Realtek audio driver (which might have been redundant or conflicting) or all the junk controlling the fan, motherboard, memory LED’s were making MSFS unstable.

I’m going to enjoy MSFS for a few days before I start adding these back one at a time to see the real root cause - but I’d suggest if you have extra time - start uninstalling non-critical novelty apps or possibly clean out your audio drivers.

Bob

congrats and enjoy the crash free days!

I have to say that i do not believe that you managed to fix the issue, because i had that happen more then once. For me it feels like that they have access to the game code, or to say it different: that they can chance code without having to release a visible bigger update.
At the moment i do not have the Loading bar bug anymore, it doesn’t crash to desktop but now it started to mute the ATC Tower for some reason - which i NEVER had before!

I have 499 addons installed and it does not crash since a week, and there are alot of community addons installed!

amd 5950x
6900xt
64gb ddr4 3600mh
hp reverb G2

The one that set of bells in my mind was uninstalling the outdated and redundant Realtek Audio Drivers. Years ago I was having CTD trouble with either FSX or early P3D and it was the culprit.
The other reason I don’t dismiss software being the problem is - if you look at the list - we’re talking about software that controls hardware. This isn’t stuff like SimToolKit or Vpilot. This software drives hardware that MSFS uses.

Regarding not believing my problem is solved. I don’t know what to tell you other than I’m flying for the 2nd straight day immediately after uninstalling that list of software. I wasn’t able to keep the sim running more 10 minutes since early summer.
Whatever I uninstalled fixed it. It’s nothing supernatural.

1 Like

I know what you mean and i know how it feels, i got crazy with the CTDs, sometimes after 5min without being able to take off, i tried everything, driver updates, VC++, volume on the G2, tried everything and then from one to the other day it worked!

At first i bought a new Soundcard, because it always crashed when the ATC talked, i didn’t know that the reverb G2 had the volume bug!

Let us know if these crashes stay away or come back or maybe you can nail the app which is the bad one :+1:

1 Like

I have an ASUS X570-Plus MB where the same progs can be installed.
All this stuff is completely useless on a gamer PC.
In general, ASUS “utilities” are known to be often bugged.
The most often, installing drivers for a device is enough.
Only drivers, coming from manufacturer’s site.
Problems cames with “utilities” provided to manage this device, wich often interfere with other things and are nothing else than eye candy for functions already existing in Windows.
For audio, Windows includes drivers for a non too sophisticated audio system and for headsets.
The CPU and case fans controls are available in BIOS
And anyway GPU fans cannot be managed with Asus Fan Control nor BIOS and they are generally the noisiers. For this, you should use what comes with your graphic card.
Patriot utilities were installed with ASUS programs (or another one who knows ?) and are also useless.
Armory Crate and LED utilities are only necessary if you want your PC looks like a flashing Christmas tree.
So dont hesitate to NOT install all of this b…t !
You’ll have a gain in memory, boot time, and the most important in stability.
And no headache with updating them and wondering wich one is the culprit when you get issues.
In this matter, less is best !

Voilà, voilà, my 2 cents…

a few years ago I had a similar thing but wasn’t with this sim. Uninstalling Armoury Crate app fixed it for must have been an issue with version number as have since re-installed and not seeing any issue anymore. I get crashes occasionally but not really more than I would expect anyway.

Whilst we can’t say for certain Realtek Audio drivers were the problem to be honest it’s unlikely given the majority of PCs will have these drivers installed so any major problem would be pretty obvious very quickly.
Although you uninstalled the driver, Windows will normally automatically re-install a Realtek driver on reboot if it detects Realtek hardware. (Check in device manager).
This was often a problem for people trying to update their Realtek driver as Realtek’s installer would get stuck in a loop trying to uninstall the old driver.
It is true however that you may end up with a later version than the one you had before although Windows Update should automatically update it periodically.

I have both of these installed and I’ve never had issues with the sim. Of course, that’s been my experience and I can’t say for certain if that’s what was causing the troubles you had.

I’d look at the rest of that list. I wouldn’t be surprised at all if one (or all) of those Asus programs were the culprit.

Interestingly enough I have the ROG z-590 Mobo too and just uninstalled all those after CTD in about 3-4 min of opening FS2020 and my CTDs are gone. Now to retune my settings and see where I end up. Just default global High I get maybe 45fps but also have the RTX 2060 card. :frowning:

You could be onto something! I have several of those softwares but I’ve experienced CTDs occasionaly. Most of all, what’s bugging me is the stuttering every few minutes. Please keep us updated when you reinstall them one by one, I’d definitely be glad to get rid of the incriminated one as well, if you find it!

I haven’t had the courage to add any of those programs back as of yet.
I’m having too much fun flying stutter-free and crash-free.
The removal of all those apps hasn’t affected anything else on my system other than my fans aren’t McLaren Papaya color and it might be bringing Lando and Daniel bad luck in the race on Sundays.
I’ll keep you posted when I do.

Thanks for sharing,
I removed the Realtek High definition Audio Driver and as you said the audio still works fine.
This solved my loading problem.

1 Like

My msfs2020 crashed the whole computer everytime on loading it a minute after being in the aircraft , my Pc runs everything else fine ( watercooled )

Given up