Streamdeck input lag

I use a Streamdeck XL for some functions, and recently noticed some input lag, and duplicate inputs being sent to the sim, almost like key bounce.

The first time I noticed this was when pressing the key that brings up the ATC window. It would appear then disappear. Of if I opened it via the keyboard, it would disappear then reappear if using the Streamdeck to close it.

I have since identified what I think is a bug with how the ATC window is being displayed, which is a separate issue, but it is made worse by this kind of input lag.

I also notice it when trying to do simple things like press the button that enables the parking brakes. For me this is CTRL+NUM DECIMAL.

This works perfectly when I use my keyboard to do this, but when I use the Streamdeck the input will often either be ignored, or will happen a second or so later.


The upshot of this is it has made the Streamdeck all but useless now.

Earlier this weekend I had an instance where it would disconnect sometimes when pressing any of its buttons, which would then cause the sim to crash sometimes due to the USB disconnect bug, but a firmware update seems to have fixed that particular issue.


The System\HotKey Action from StreamDeck sends the Key-Stroke to the Window/Application which has currently the Input-Focus. So if this it not the Sim, this could explain why the Input is sometimes “ignored”.

SInce you’re only using 50% of the StreamDecks capability, an viable Alternative could be the vJoy-Plugin (with the vJoy Driver installed on your System): GitHub - ashupp/Streamdeck-vJoy: Map elgato stream deck buttons to vJoy buttons
With that the StreamDeck Buttons behave like normal Joystick-Buttons which you could map in the Sim Settings to actions like setting the Parking Brake and such (like you would with any other Joystick).

The point is it never used to be like this. I haven’t played for a while, so I don’t know for sure when all of this happened.

It’s not a focus problem, but its not an issue specifically with MSFS either, as I have tested it in Notepad, and the input lag is there also, but never used to be.

I’ll have a look on the Elgato forums in case this is a known issue.

Hmm … maybe it is a Hardware Issue with the Deck? Maybe the Hardware itself does not or only slowly recognizes the KeyPress!?

You could use vJoy (and the Plugin) to test that - if it is a Hardware Issue, it will behave as bad as it is now (because the Hardware does not recognize the KeyPress correctly).
If it is a Software Issue the vJoy Action should behave differently, maybe even better (e.g. Elgato changed something in the way they sending Key-Strokes or MSFS how they react on Keystrokes which is now not performing as you were used to before).

I use my XL in a completely different way (no Keystrokes), but I have the same SW Version and FW Version as you and have no Input Lag.

1 Like

Yes, I’ll give that a go, thanks. I also have SPAD, but never really configured it with that, so I could try that also.

Sure, but SPAD (to my Knowledge) is not a Plugin - it is using the StreamDeck Hardware exclusively. So it’s either StreamDeck Software (and Plugins) or SPAD.
But I could be wrong!

There also other Alternatives g :wink:

Okay, that’s weird. If MSFS isn’t open, text input to Notepad is at a normal rate. No delay. If the sim is running in the background, then it has the delays, and occasional repeating characters. :thinking:

It’s effectively emulating a glorified keyboard, so I have no clue why it’s doing that.

I use AAO and recently had lag with my SDXL. I’ve traced it to a driver for my Kraken headphones, Realtek audio and Voicemeeter. I let Synapse it load on startup and then exit the programs it runs and have no problem now. I would encourage you to see if there might have been some change, no matter how small that is causing your issues.

1 Like

The only thing I’ve added is a set of USB speakers, Logitech G560’s.

I’ll try disconnecting them tomorrow, and see if that has any effect.

Next day thoughts. This morning I was thinking about this, and half remembered that I had changed rhe port that my 17 port powered USB hub was plugged in to. Before work I quickly checked, and I think it was plugged into a USB2 port.

I don’t remember the reason why I changed it, but I’ve moved the plug into one of the red USB 3.2 ports.

It’s possible that the problem only occurs when the sim is running because all my other gear is communicating with the sim in only that scenario.

I’ll update when I get home from work.

UPDATE: With the hub plugged in to one of the red USB 3.2 ports, I have seen no discernible improvement with the way the Streamdeck works. It’s really weird. Without the sim loaded it works perfectly. With it loaded there is usually a 1 to 2 second delay before a character appears, testing with Notepad. Sometimes a single press will cause the key to repeat endlessly.

So it’s not MSFS related, as I did a quick test with Salt and Sanctuary, a game from the Epic store. When that game is loaded I also get the character delay, and repeating characters. Perhaps a recent Streamdeck update broke it, though I have now tried versions 5.2.1 down to 5.0, and all three versions had the same issue. Ticket opened with Elgato.

Interestingly, if I disable the Streamdeck software, and instead use SPAD to send the keypresses, then it has the exact same problem. Perhaps hardware failure in some way…

Last test of the evening. I unplugged the SDXL from the 17 port USB hub, where I have been using it for the last year or two, and plugged it directly into the computer. No input lag detected!

Tried it with both MSFS, and Salt and Sanctuary, and in both cases input lag has gone. I also tried MSFS ATC functions, and a few other things, and it all works fine.

No other USB devices have an issue with that powered hub, and the SDXL has been plugged in to the same port for nearly 2 years I think. But at least I’m on to something now. Tomorrow I will likely disconnect all USB devices from it, and try the SDXL as the only device connected to it, perhaps try connecting the hub to a different port on the computer.

How did it go H? Similar setup here, but SDXL and a second SD too, with no issues to report. All works well. Very well infact

Still a WIP. With a USB extension lead, I can plug it n to the back of my computer order my standing desk. It works perfectly if plugged in directly like that. If I plug it in to my 16 powered USB 3 hub, then the delay occurs, but only if any game is loaded, not just MSFS. I have an open ticket with Elgato, and have sent them logs.

The thing I don’t get is I bought that hub, and the SDXL at the same time, and they have been working fine until now, with no delay whatsoever. One difference I my Windows 11 upgrade in October of last year, but that didn’t seem to affect it either. Other than that my system has been static.

Meanwhile, on the ATC front, I’ve just found another regression.