[SU7] End-Of-Flight logbook popup suppression: Still creating bogus zero minute logbook entries

The sim is only an approximation of real life, the log cannot be edited yet, you keep your log IRL. Is there any sim out there with a 100% accurate log? Give Asobo a break, they have other bigger issues to fix. I’m sure that many pilots have made errors in their own log IRL or forgot to include a compromised flight. I’m pretty sure that drugs flight pilots don’t keep a log, so much for a " a logbook is holier than the bible"

Yes the sim is an approximation of real life and trust me I ma giving Asobo a ton of breaks with all kinds of other ■■■■ that isn’t even close in this SIM at this point.
The Logbook should not be one of those things where they need the best of their programmers to get even half decently working. What they have now is far from that.

Funny how folks who claim not to care about one item or another always feel they have to come to ASOBOs defense.
And with that I am done arguing with you about something that doesn’t matter to you.

1 Like

That is very nice to know, thank you.

1 Like

I would like not to have a new Logbook Entry when shutting Battery and Avionics of our Aircraft down.
It should stay on the same Entry when we continuing our Flight please.

And this is why everyone is currently using MSFS, all the other sims are dead. Or are they?

What are some of you guys blabbering on about? This is the “Miscellaneous” section of the “Bugs & Issues” forum:

If this is the first bug report forum for you or the purpose is a bit foggy to you - it’s meant to collect feedback about issues (regardless of their gravity), to verify and confirm bugs and buglettes and - if need be - to investigate them in order to create a meaningful bug report. It’s not meant for meta discussions and musings about the decline of whatever.

SU7 tries to improve an old issue and this thread is to clinically point out how exactly that improvement failed to meet more than half of the expectations: The popup interrupted reenacting shutdown procedures and discouraged training them this way. The current simple kludge meant to address this is merely clicking the dialog away automatically (which is also still noticeable) and hence it leaves the other part of the issue with this (surplus zero time logging cluttering up the logbook) untouched.

A better implementation could be using the [ESC] key as a trigger for the same logbook dialog, that way the user can decide when he wants to see this and either go to the [Main menu] or [Continue] for another flight to be logged. Zero hours entries (maybe because the user changed his mind about another flight) should be automatically purged.

2 Likes

Aha, I get the logic now - once the aircraft is “shut down” the sim makes a new logbook entry. It then expects another “flight” but if this doesn’t happen it makes a zero hours entry on exiting. In a way this makes sense because you don’t need to go back to the beginning to start another flight if nothing else is changed.

I can live with that - but it would make much more sense for zero hours “flights” to be ignored in the sim logbook, just as they are in real life. Or give us the ability to delete them.

2 Likes

As an airliner simmer, I see all the behaviour above:
What is less acceptable is that msfs2020 appears not to correctly recognise any flight which doesn’t use the rudimentary flight planner built in.
If you start at a stand Cold and Dark, plan the route in Simbrief etc, then follow the checklist, start and taxi to the runway, the sim doesn’t recognise this as a bona fide takeoff. It then rubs salt into the wound by adding another empty entry into your logbook which represents the time after shutdown and closing the sim.
Bizarrely if you select the empty line whose departure and destination are both noted as the destination of the flight in question and select Fly Again, you are taken to the original departure point…
I imagine these problems are cumulative if you then fly onward with other legs.
Most of my flights are between 45 and 90 minute duration. I have 732 entries and only 168 hours total, so things are pretty messed up, given I seem to lose hours after each update…

I’d certainly like the option to remove all the empty lines!

2 Likes

This would be almost good IF it worked like that. Ideally it would then track the first airport and the final airport as the end points and log each TO and LDG.
But if you do not exit back to the main menu it almost always logs only 1 TO and 1 LDG.
I am not even asking the Logbook to track full stop LDGs…which is one requirement to maintain current for example at night.

Was just about to post a related topic: “Disabled end of flight logbook still annoying” when I came across this. In addition to “bogus zero minute logbook entries”, the following happens (at least in VR):

  • it awkardly lurches to centered cockpit view
  • it closes panel windows, including in-progress checklists
  • it closes aircraft doors in the middle of passenger disembarking

In short, it is an awkward, immersion-breaking experience. Auto-clicking the button isn’t the same as disabling it. The pre-SU7 ticket should be re-opened until these things no longer happen.

Thanks for listening.

I have the same.
I’m not on VR so the logbook screen doesn’t pop up for me (not even briefly), but I always get the “double logbook entry” the second of which is empty (0.00.00 time recorded).

Note how the flights with the Kodiak and Hawk T1 were crashes and didn’t generate a double logbook entry. Same with the flights before 26/11/2021 because I hadn’t checked the option to disable the end of flight logbook then.

the logbook works better now…But there’s a thing…Pressing escape always works but landing with the objective window that say shut down the engine doesn’t log…if i land and turn off the engine the window show my flight time but it is not recorded in the logbook…it is recorded 00.00 because the software understand that i continue and start a new flight despite i am with engine off and stopped at the parking…when the window with the log appears,if i press return to main menu from the window option the flight is logged correctly but if i press continue and next escape to main menu the flight is logged 00.00

After excitedly reading that the logbook was fixed in the latest patch I gave it a go again and made a 1:30h flight with a landing on Lukla airport. This time, the end screen got triggered properly and it displayed my flight. I clicked continue to explore a bit of the bespoke area.
However, after viewing my logbook back on the main menu, there is no flight logged other than one from Lukla to Lukla of 0:00h. I somehow get a feeling that pressing continue ruined the log, though this is something that was never a problem to me before.

Is anyone else encountering this?

I had the exact same problem. Done a flight, got the end screen displaying my flight properly. Pressed continue, and only found a 0:00 “flight” marked in the log with a destination and arrival both the same of the airport I landed on. It’s driving me nuts that so many hours go lost.

I thought he said turn off the engine and the master. I know in the caravan, I can shut down the engine and it doesn’t popup the log window, but when I turn off the avionics master switches, it always logs the time and TO/Landing.
Regards

Exactly…Pressing continue it logs 00.00…it’s a minor problem…before it was fixed it never logged…only with the objective system

Just found out if you click back to main menu will log your time in the main logbook, do NOT click on continue! New bug?
Will do more testing.

I just had a flight where I shut down completely and received the “completion” menu (which includes continue). This “log” showed a 27 minute flight, 3 takeoffs and landings (Nanwalek ending at PASO). However when I returned to the main menu, profile and logbook, it showed 00:00 total time, no landings or takeoffs and the from/to was listed as “PASO [Vicinity]”.

HOW TO CHECK; To test if you have this issue, try to complete a flight and shutdown the aircraft so you get the completion menu (that allows you to continue). Click continue, then exit back to main menu, and check in your profile logbook whether the flight matches what was shows during completion.

I believe the issue that was closed is not yet fully resolved.

1 Like

I also noticed several other flight entries over the past day (since patch) that have the same issue (they showed correct times after shutdown but zeroed out under profile/logbook).