TCA Throttle Quadrant Engine Mode Selector

Oh can’t wait to try. I just downloaded the beta this afternoon but haven’t done a flight yet!

I’m on the steam beta for SU10, but for me the issue is still alive and kicking.

Same problem here, am on the sim update 10 beta (steam version) and it still doesnt work without the workaround. Even in that capacity it barely works consistently with the FBW, even more troublesome with the Fenix. any sort of action which interrupts the switch causes it to start flickering between modes

1 Like

I hope they fix this before Sim update 10 cause this is annoying… Also issues with speed brake issues since sim update 7.

1 Like

Same problem here with Steam versione UP10

I had the same issue, it’s gone now (did 3-4 flights) by magic (unknown) reason. SU9, Fenix A320.

nope, still not working on SU9. button starts flickering especially on the fenix

Bug is still here in SU10

For me the only issue with the TCA engine mode selector is the flickering the right mouse click and the drone camera are causing.
My mappings of the selector are very simple - SET ENGINE IGN/START MODE - Button 8 (on press) and SET ENGINE CRANK MODE - Button 7 (on press). I do not set NORM MODE to release or anything else (just leave it empty) and when I use the hardware TCA button the virtual selector moves in sync, no flickering at all

I get flickering only when using the right mouse click to pan the cockpit camera and when going outside with the drone camera (upon return in the cockpit I hear the particular click and see the selector going back to IGN/START). I really would like to see this fixed, especially for the drone camera.


Are any users in this thread continuing to experience this issue on their TCA Throttle Quadrant? Our team is having trouble reproducing on the latest builds. Thanks!

Yes, i still have it in the Fenix, but not in the FBW, strangely enough.

Hello; Same issue here on last build. I’ve only tested on Fenix.

For Normal mode i use release on Buttons 7 and 8.

Same here in SU11 with the Fenix.
Did not try the fbw yet.

But in addition when starting the engine while the switch is visible in the 3D cockpit, the engine starts up.
When zooming to the ECAM display while the switch gets out of sight, it switches back to NORM. :frowning:
Engine start is only possible when the switch stays visible.


Did any of you guys contact Thrustmaster? Or are you just announcing your discovery to the community?

Thrustmaster can not help. Useless.
They just build switches that reflect on Buttons of an universal joystick device.
How these buttons behave in MSFS is the responibility of the sim (or the aircarft addon). In fact, this is buggy, so Asobo or Fenix (I did not check the FBW yet) have to take care of this.

1 Like

Have you tried using the middle mouse button to pan around instead of the right button. I’m told this has worked for others.

I still get the flickering of IGN button while panning the view with right mouse button - in Fenix A320. Can’t say for FBW, I fly only the Fenix.

1 Like

Same for me as well Fenix the crank switch still a issue

Same here, just got this yesterday. I managed to fix it in the FBW by removing the bindings I didn’t have such as flaps, trim wheel etc and just kept in the throttle quadrant ones itself and following 320 Sim Pilots YT video. As for the Fenix, this didn’t work fully, with the ‘right click view panning’ moving the ignition switch. I did see a temp workaround on here somewhere about assigning the middle mouse button to panning, I shall try that today at some point.

Edit - found it: