Throttle/Flaps/Mixture/Speedbrake/etc axis at 50% when exiting menu WU IV (1.15.7.0)

,

I’m also seeing this issue when using Honeycomb Bravo throttle bound to MSFS directly. Tested in Citation Longitude: the spoiler, throttle 1 and throttle 2 axes on the commercial twin-engine config (1st axis, 3rd axis, and fourth axis respectively). After hitting ‘ESC’ to see the menu and then returning to flight, my spoilers and both throttles moved themselves to 50%.

If I use spad.next to control the axes, I don’t get this problem – they do not reset.

Also, all my glass displays went black on the first exit/resume – perhaps because the avionics and power switches are on the Honeycomb Alpha. After switching back to using spad.next, I don’t get a glass display failure when exiting to the menu and resuming (I had to power-cycle the avionics to restore them before testing).

MS Store version (Premium Deluxe, all the fixin’s. Nothing in community folder. Navigraph Simlink and fs2ff connected to ForeFlight, as well as spad.next for input management, over SimConnect.)

1 Like

MS Store version (Premium Deluxe). Nothing in community folder.

Controls are Thrustmaster T16000M FCS Flight Pack - Joystick, Throttle and Rudder Pedals.

When I press escape, throttle goes to 50% and mixture 0%. This also happens if I don’t press the escape key but have it bound to another button on my joystick.

Have to start engine and hope I’ve got enough height to glide until the engine restarts. Of course the new way to fly is to start and not press escape (just use active pause).

Would love some help to reproduce the following for those willing and able:

For those who have both a throttle and flight stick and see this error, disconnect the flight stick and see if this issues happen with just the throttle connected.

Thanks!

Unplugged joystick Virpil Warbrd, (kept MFG Crosswind2 rudder plugged in) booted sim;

Can confirm that the 50% does not trigger then.

Reconnecting the USB plug during sim, will trigger a warning by MSFS about a profile not found for the new device, however it loads just fine.
The 50% bug then reappears.

2 Likes

The issue is gone, if flightstick AND rudder pedals are disconnected (hotplug).
The issue is back, if one of both is reconnected (hotplug).
Thanks.

1 Like

I am also experiencing this issue. MS Store version. Will test unplugging in the morning and report back.

Happens with all axises on my TCA Quadrant/Add-On - flaps, throttle, toe brake, spoilers

Would try AxisAndOhs which I own as a workaround but that seems to be crashing the sim on startup now. :-1:

1 Like

Unplugging the Honeycomb Alpha yoke seems to stop the reset of the spoiler, throttle, and flaps axes on the Honeycomb Bravo. However it immediately shuts off my avionics, and leaves me unable to fly. :wink:

1 Like

same for the Thrustmaster FCS flightpack. The Joystick (T.16000M) is connected with it’s own USB plug, the Throttle (Thrustmaster TWCS) is connected with it’s own USB plug, and the Rudder pedals (TFRP) connect into the throttle. With all 3 connected, the 50% throttle bug is constantly there, as soon as I unplug the Joystick, the throttle bug disappears. Plugging the Joystick back in, restores the situation to have the throttle 50% bug again.

There seems to be no difference whether I keep the Rudder pedals connected or not, only when I disconnect the Joystick. Hope this helps!

I have same issue. Honeycomb Alpha + Saitek Pro Flight Quadrant + a vJoy Device to handle my racing sim pedals → rudder.

edit: can confirm that disconnecting the yoke (Honeycomb Alpha) removes the bug.

edit2: I take it back! I just experienced the bug with no yoke. No idea what caused the bug to be reintroduced.

Same issue here, Warthog HOTAS, only noticed because I saw both the Cap10 and the Spitfire actually zero out my mixture slider, killing the engine. as soon as I touched the slider the mixture went back to the position it was supposed to be.

Edit: Due diligence, I removed all my mods, forgot to do this before posting. Confirmed does this with the Caravan as well.
Have HOTAS set Axis X as Prop Axis, Axis Y as Throttle, and Slider Z as Mixture. When I hi t ESC and back to the game, both X and Y go to 50% and Z goes to 0%.

Saitek X-55 Hotas.
Game is from Microsoft store.

I ran with an empty community folder and tried some mods as well.

If I am flying and I go to the menu and come back, my plane looses all RPM engine shuts down. Jet, Turbo Prop, and regular prop planes.

I unplugged my joystick as suggested and I didn’t loose my engine. If I restart my engine then plug flight stick back in same thing happens I loose power/fuel/rpm.

After some further testing it seems to be related to the setting: Mixture Axis (0 to 100%) When I delete my key binding for that rotary control, I don’t have the issue anymore when I go into the menu then back out. If I then go back and bind that key again, then my plane’s fuel mixture/flow goes to 0% again.

Hot fix coming for these issues? :face_with_monocle:

3 Likes

Same problem. Steam version. Honeycomb Alpha/Bravo and Thrustmaster rudder. I’ve tried reassigning the axes but that doesn’t fix it.

I’m not usually a fan of “me too” messages, but in this case… well… “Me, too!”

Honeycomb Bravo, when pausing and unpausing, the throttle goes to 50% on both engines (A32NX) and the Flaps go to Condition 1. A slight jiggle of the physical hardware corrects the error, though the overspeed warning error with F1 at 250kias (or more, depending on altitude) is jarring and scared the snot out of me the first time it happened.

2 Likes

FWIW, this does not seem to be a universal issue. Have not had it occur with Logitech yoke, throttle and rudder setup. Maybe related to hardware…

All axis seem to be affected, it’s just most noticeable with slider ones, rotaries too probably.
Looks all axis states are put into neutral position upon exit from pause.
Also can be seen on elevator/aileron axis - try to keep a constant climb with the joystick, go into pause and back while maintaining constant stick pressure and see what happens. Thrustmaster Warthog here.

Confirm I DON’T have this issue with Honeycomb Alpha and Bravo connected via FSUIPC (maybe that makes a difference?)

@Jummivana Can confirm this issue does go away when unplugging joystick.

Just tried to test this, couldn’t see any obvious indication this was happening here but it’s difficult to test I guess - maintaining a constant pressure in exactly the same spot is difficult - a small adjustment just as the pause menu is fading away could make it difficult to see the evidence, though I do agree all axes could be affected.

Here’s a video to illustrate, the yoke movement is not just a visual - notice how both yoke and throttle go into neutral position after pause (I was keeping turning left the time). You need to move the relevant control axis for it to “wake up” afterwards.

yup, same issue here, voted!

upon hitting resume: throttle/mixture/prop pitch 50%, even flaps went down a notch(but yeah, have that on an axis as well.

I’m just guessing a hotfix will be up soon, keep on voting guys!