Thrustmaster TCA Throttle Quadrant USB device not recognised error

Yes I have.

I just started to have the same issue with my throttle quadrant a few days ago. I have also tried every suggestion listed in this forum. I might just sacrifice mine for the forum and open it up. I want to see if there is a cable from the USB board to the main Board. If there is I can check it out and see if maybe there is just a loose connection or something. I bought mine refurbished from Amazon back in October of 2021. So I really don’t think I have a warranty. But not sure. If I can’t fix it I might just buy another one. I will report back here if I can find a fix after taking it apart. Thanks for starting this topic.

1 Like

It’s unfortunate that this is such a common issue, and there doesn’t appear to be any permanent fix yet. Hopefully you can find something taking it apart, I’d also like to know!

The replacement from the cable from main PCB to USB PCB was only precautionary. They cant find the any defect. Perhaps is it a mistake between the device and only AMD systems?

I have an Intel & Nvidia system, so I would assume the issue is specific to the throttle itself.

Today mine is working perfectly. Doing a flight with the FBW A320. I’m not going to take it apart until it messes up again. I’m sure it will soon. But I will keep the forum updated.

My device works for five day´s without problems and now is it not recognised again. It was separated without use. I have connected to a separated PC but the TCA is down.

Hi All, on the back of this, I am unable to download any updates, drivers, firmware from the Thrustmaster website. When you click on the button, nothing happens. I have just added the Airbus add-on (flap lever, spoiler, etc) however, MSFS 2020 does not see it, and for some reason, I am unable to find the setup software, I can not even download any of the PDF files.

Here is a link to the proper download location for it,
You should be able to download this from here.

https://support.thrustmaster.com/en/product/tca-captain-pack-airbus-edition-en/

Nice one, thanks for that.

1 Like

Hey @dflight8685 Kannst du mir auch weiterhelfen? Ich habe ein ähnliches Problem. LG

Hast ne PN…

Hi there, I’ve been having theses problems for a couple of years…It is impossible to get usefull…I got a Thrustmaster email where they suggest to take it to a loca electronic repair local…I’m wondering if may be a vot/amp issue.

Any thoughts?

Have you tried downloading the proper drivers using the link above?