Tip for Nvidia Users- Check your 3D settings

Thanks for sharing, I prefer letting the app control the AA, running these settings you’d have to disable AA in game. That said if it works for you then who am i to tell you different, happy flying :wink:

I just bumped the Terrain LOD to 4 (in the GraphicsVR section of the usercfg.opt) and it seems to really increase clarity with no significant impact on performance (I do have a 3090 however). Have you tried fiddling with this?

yeah, I set the LOD (terrain) to 3.500000, object stays on 2.000000. not one of the lucky ones to get hold of one of those monsters yet lol (3090). I noticed very little impact on performance, probably 5-10% at the most.

Other settings i edited included post processing, I disable color grading and film grain. Also in the Microsoft Flight Simulator 2020\Official\Steam\bf-pgg\PGG folder I edited the config.toml file…

enables switching lods for debugging

lod_override = true (changed from false I think)
lod_override_with_lod = 2

Do you have the steam or store version?

I have the store version. I will bump the objects to 2 too. This thread makes my day!

1 Like

Now install reshade ontop and you’ll be blown away. I’ll glady send you my config file and you can toggle effects on and off. Let me know :wink:

How do you do this? I assume you have a G2 too?

EDIT: found it Installing ReShade on MS Store version of the MSFS2020 via "ReshadeForUWP" program by MilkyDeveloper

Thats the one, give it a try and see what you think. I have a config file which works great for fs2020. You will require additional shaders but I’ll send you the link.

1 Like

Does reshade works in VR mode then ? I was under the assumption that it only works in 2D.

I always have my nVidia settings left at Default for MSFS since VR first appeared, except for capping FPS to 60 for the Menu otherwise my GPU is screaming (literally…) at full blast for no reason whatsoever!

Sorry for not responding earlier :wink: unfortunately I don’t own VR so I’m really not sure, I should have mentioned all settings were tested on 2D only.

No problem. Thank’s for your answer.

Same settings I had except I did not have performance set at max. I changed it just for giggles, but since SU5 practically has my GPU pegged at 100% as it it, I don’t expect to see any difference.

Then again, in the spirit of it’s as much voodoo as it is science, can’t hurt, no?

Kev

2 Likes

To all:
Here is the topic about the NVidia CPL Anisotropic bug, and several side-by-side showing that FS2020 settings are doing what they are expected to:
PSA: NVidia Anisotropic Bug: in-game setting disabled (was: Some tests on Texture Resolution and Quality) - Community / General Discussion - Microsoft Flight Simulator Forums

@KevyKevTPA
Here are my latest Index setting for SU5 HF1 (for HF2, just change TLOD and OLOD back to 100%):
My 2070 SUPER VR settings and suggestions (Index - SteamVR) 🟢 - #547 by CptLucky8

And some more comments:

PS: I’m not done yet adjusting for the Index, thus I’ve not tried the G2 with SU5 HF2 yet.

6 Likes

Oh I can’t wait for this! :slight_smile:
Thanks for this super detailed post as always!

2 Likes

Oh, so waiting for your (CptLucky) updated recommendations for the G2!!!

2 Likes

@GuillaumeKun @FubarSWE2020
If you compare my previous G2 and Index recommendations, you might see they are quite close already.

I suspect both the latest FS2020 settings I’ve posted a week ago with the Index, and the OXR settings I’ve posted for the G2 months ago, would most likely be good starting point to experiment with.

1 Like

Nvidia control panel at default, no issues.

@Ess0ess

What I’ve found is that even if set at default, this doesn’t mean it is at default! (at least for the anisotropic settings). This really requires clicking the “RESTORE” button to reset everything and to be sure it is.

NB: I’ve had the same kind of bug a few months back, when I was using 457.30 but did try a newest one just to see whether it would be better. This was one of the newest driver with the “limit background window fps” and I’ve set it to 30 for FS2020 so that during loading, it wouldn’t take 100% GPU if I selected any other window. When I reverted the driver back to 457.30 in just installing over (NVidia recommended way), I realized the background window fps limiter was still set even if this older driver wasn’t offering this feature yet!

I think you’re right that all settings doesn’t revert to default unless you do a ”reset”.

Another thing that I find, but it might be placebo…
If messing around with MSFS VR settings in order to test and find a smooth experience I eventually get a lot of stutters and need to dial back some values. This doesn’t really seem to restore the settings (even though under settings they are at the ”right” level) - it still stutters and is jerky. However, if I click ”default” under VR settings, and then set my higher values back and clicks apply/save it runs better.
Anyone else find this? Or am I imagining things…?

Clean install of MSFS and updated Windows and OXR. NVidia is 471.41. G2 + 3090 + i9 (5.3GHz). Nvidia CPL settings as per CptLucky8 of April (I think). Render settings 100/100. Repro off. Visual settings Ultra. Smooth flying and clear detail looking forward through windscreen. Looking out of side windows its jittery: maybe 2 or 3 frames. As discussed above, changing Aniso does not seem to have any effect on image and menu boxes have slightly jagged edges. Cockpit images clean and readable but could be a bit crisper for my liking. On the plus side, have ramped up render scaling in FS to 200. At this level no CTD but frames must be less than 10/sec. However at 150 seemed to be quite smooth over London. And load times are much quicker. So far its looking pretty good that a lot of negatives have been addressed. But still need to tweak and fine tune, presuming of course that there are no bugs. Continuing to experiment and will give these suggestions above a go. WIP.

Edit + 2hours - CPL set to default then relvant functions to Application to Decide. At first not a discernable change so I reset FS settings to default. Cleaned it up nicely and getting smooth and clear. (Cub at 1000ft) Render scaling 100/100. raised most settings to Ultra and sliders to 200. Left aniso and Tss at default. Still good. tried raising ansio and tss but seemed to degrade image. Also increasing render scaling >100 degraded clarity somewhat. Image not as good as 2d 4k but I think i’ve reached the limits of the G2 as far as clarity is concerned.

2 Likes