TnT Quest 2 Settings - Sharp and SMOOOOTH!

Yes, indeed, the flashes are gone with v.27. Performance fine too. (Rift CV1).

Hi, i stayed about more than one month without using my Quest 2 and MSFS after my first tests which where close to a nightmare, sometimes good, sometimes bad, never stable, etc… so i gave up…

Today i started again to test.

I have the V27 on my Quest.

I installed the last Nvidia 461.72 driver.

MSFS is at the last level.

And i saw this post, so followed the settings.

And i started a flight.

It was ■■■■ !!! very stuttering… but… i started to fly anyway… CPU was at 85% (Ryzen 2600X), GPU at 100% (RTX 3070)
and… after about more than 5 minutes flight, i noticed that thing seemed far better…
GPU was down to 60%, CPU also…
And everything was extremely smooth, whao, what a surprise !!!
I was in the TBM 930, so i tried some acrobatic flight… not easy but everything stayed smooth…
After crashing in the ocean, i changed for Pitts, here i did all acrobatic figures i wanted, close to the ground, no stuttering, eveything smooth, details quite good in the cockpit and outside !!!

Things have improved a lot !!!

To be tried again, but promising !

Thanks

1 Like

@BravoMike472413 great to hear that! And yes, I can confirm that MSFS usually starts much slower in the first one to few minutes as it’s apparently still processing a lot of data at the beginning. Good luck that it stays stable for you.

Oculus V27 feels like quite a game changer to me. Much smoother, even with slightly higher settings.

Yes, was a good surprise, but after i stopped and tried again 30 mins later, i didn’t got the smoothness, stuttering was again there…
so… not sure if i did all the needed steps…
thats the drama with this system… so many steps, one time its beautiful ! the other its not !!!
will try again.
or test again VD…

It was recommended earlier that you should go into desktop and reduce all setting in MSFS to lowest, low or off. Then save all that, switch back to VR. Now the SIM should settle quicker.

Just wanted to bump this thread, @TonyTazer1504 your OP has unlocked so much smoothness for me, but I’ve found a few more tweaks recently that might be interesting.

The latest oculus beta doesn’t react to the hz setting, 72, 80 or 90, it ignores your choice and will sit at 72hz. check with your FPS counter, I could be wrong but it’s what I’m seeing.

BUT the V27 beta being so much smoother has meant that I can drop the supersampling within OTT. I’m now running 72hz (no choice) and 3936x1984 in oculus, and TAA 100 in the sim.

OTT settings are now Super Sampling 0, ASW off, GPU scaling off, and FOV 0.8 x 0.8. I’ve also reduced OVR server priority to Normal as I’ve been reading this can actually do more harm than good (see my post on server priority here) and as V27 is so stable i don’t think it’s needed any more.

I can even bump to 120 in the analog gauged planes. I found that dropping the extra step of supersampling has (i think) improved smoothness with no loss of quality.

Food for thought, my VR flights are the smoothest they’ve ever been now.

I don’t use the tray tool anymore with the 0.27 beta. It just works fine for me. And no more fiddling around with all those parameters:-)

2 Likes

It’s so close for me, but taking 20% off the FOV still gives me a little boost in FPS from just-about-30 to solid 36fps. I think it just helps my 3070 cope at the moment. Hopefully not long now til things get even better and I can ditch OTT completely!

1 Like

Cropping - Is your resolution 4128 x 2096 in the Oculus App (there are three 1.0 resolutions for me)?

This is a question for you and the OP - there’s a note in OTT that setting the FOV is only for the 2D mirror display. Does it actually work within the headset as well (Quest 2)? If not, do you recommend using OTT and ODT simultaneously, as I’ve tried that and didn’t see a performance hit.

Let me go take a look now @AJsowavyy8906 and I’ll come back with the exact numbers.

But yes OTT fov setting definitely affects the field of view in the quest 2. Try setting it to 0.6x0.6 and it’ll be very obvious. 0.8x0.8 is the sweet spot for me, I can’t see the edges so it just crops out the pixels I didn’t see anyway. Everyone’s eyes are different and depends if you have the glasses spacer in the headset, etc.

I’m taking the path of “least amount of tweaks as possible” and that has seemed to help me get things smoother. I reset all my nvidia settings, PC power settings etc etc and just changed the few that @TonyTazer1504 mentions in his post. I just find it stops you chasing your tail after updates.

Also, without wanting to get into a heated debate about things I have no idea about, I believe that asobo are intending to get this sim running on PC’s that don’t have a billion tweaked settings in NVIDIA control panel, with process priority changes and funky settings etc etc so as we get each update I revert my driver and PC power settings back to factory and tweak again from there. So far, every update to the sim, oculus app and NVIDIA drivers has resulted in less “under the hood” faffing from me.

So a positive direction I think!

I’m new this year to PC gaming (but use PC’s for my sound engineering work) and I started out tweaking everything to “PHOAARR MOOORE POWEEERR!!” Mode when I first built the pc. But I’ve realised I wasn’t helping and I shouldn’t try to fix things unless they are broken haha.

I’ve rambled… hope that helps.

3 Likes

image

2 Likes

@CroppingPoem113 many thanks, great insights!
It’s true Oculus v27 Beta locks the refresh rate at 72hz no matter what, however Oculus v26 also works fine now again (revert by opting out from Beta again). I learned that in a FB group and was able to revert back: NO FLASHES, very smooth performance AND again the ability to change the refresh rate.

It’s amazing how smooth and stable FS runs recently! My current sweet spot is the following (didn’t change any graphic details):

  • went from 60% to 80% game render scale (can even do 100% on bush trips etc.)

OTT:

  • went from 1.6 to 1.7 super-sampling
  • ASW off
  • GPU scaling off
  • 80hz refresh rate again with Oculus v26
  • FOV of 0.8, 0.9 (needed to go a bit higher not to notice the display borders)
  • Server priority “above normal”, but will follow your advice and revert to “normal”

I have to say I’m very happy with the performance and really love what the Oculus super-sampling does to the image, but I find your approach with 100%-120% in game and SS switched off interesting and will give it a try.

Wow 150Mbits/sec wow mine is at 20Mbits/sec in the quest app no wonder the graphics look blurry
My setup is. Ryzen 5600 32 gb 3200 ram and a 3080 card
But I don’t have gigabyte power lines for the VD side I still get around 650mbs to 700mbs using WiFi and I’ll check the other suggestions too as a wired connection in my mind is just not worth it at the moment

Thank you for all your help, can you report back on this please?

Hi guys, for the ones that still follow, there has been so much going on with Oculus, Asobo, Nvidia and Windows updates, turning some well-established configs upside down, at least for me.

After again many hours of tweaking and testing I have finally reached again the shores of smoothness and could enjoy some wonderful Spitfire flights in the Mach Loop.

Some of you experienced tuners may again be surprised what I configured, as it’s partially quite contrary to common recommendations, but well, it works just awesome again, smooth and sharp, so please dare checking this out:

  • Nvidia driver 461.92
  • Oculus v26 (Beta OFF), 80hz, resolution 3940x1984 (approx.)
  • Windows: HAGS ON, Game Mode ON (yes!!!)
  • OTT: SS at 1.9, FOV at 0.8, 0,8, ASW OFF, “Adaptive GPU scaling” ON (yes!!!)
  • Game: 60% render scale, same settings as in my original guide above.

OTT super-sampling at 1.9 casts an unbelievable sharp yet butter-smooth image due to game renderscale of only 60% - you have to see this!

2 Likes

@TonyTazer1504 I’m glad it works for you but what’s the point of setting a resolution, then SS it, then reduce it at 60%?

1984*1.9-40%=2261.

So if you select a resolution around ???x2261 in the Oculus app, you won’t have to play with SS and can leave the in game resolution at 100% and you’ll get the same quality and performances.

No?

Hi @Flobud, I was originally thinking exactly the same, that it wouldn’t matter how you get to the final “multiplied” resolution, because the load for CPU and GPU is roughly the same. I couldn’t be more wrong. It’s a bit like to assume that if you want to travel 10.000km it doesn’t matter how much of it you do walking, driving and flying, because the actual distance is the same. Yes it is, but the efforts and times needed are very different. So let’s diferentiate:

  • Oculus PC client headset resolution (e.g. 3920x1984)
    Here you set the “physical” resolution the headset then requests from applications like Flight Simulator - before it gets super-sampled afterwards by ODT / OTT. Flight Simulator knows then this headset expects e.g. 3920x1984 “actual” pixels delivered from me. (We know it’s not the native LCD panel resolution of the headset, but FS doesn’t care for that.).

  • In Game Render Scale (e.g. 60%)
    Hereby you tell Flight Sim the resolution the actual game engine should render the image at, including all load-heavy procedures like lighting, textures, 3d models positioning and all the effects (SSAO, glare etc.). Out of the three resolution levers described here, this is the one having by far the biggest impact on FPS. If you set 60% it means in our case that the game engine actually renders in 60% of 3920x1984 = 2352x1164px. IMPORTANT: as per first bullet above, Flight Sim still needs to afterwards deliver the image scaled at the requested headset resolution: 3920x1984. So here, the first super-sampling layer is applied by Flight Simulator (not Oculus). It’s not as simple as just scaling the picture up, because e.g. textures are processed still at the higher requested resolution while the geometry and effects aren’t. This is also why going higher in the Oculus PC app resolution requires way more resources from the sim than the ODT / OTT super-sampling applied at the very end - and not connected to Flight Sim render engine!
    What’s MOST IMPORTANT is that scaling the 60% image up is way less work-heavy than rendering it at 100% resolution. This is how you gain a lot of additional FPS on the compromise of some introduced blur, which leads us to the last point.

  • Super-Sampling in ODT / OTT: (e.g. 1.9)
    This is the final step applied after the first two above. The image received by the headset from FS at requested resolution (3920x1984) is then 2D-upscaled by the factor of super-sampling. In our case it’s 1.9 = 7448 x 3767px !!! This resolution sounds insane and if we would ask FS to render the game at this resolution, it would probably run with 2 FPS. However, super-sampling is a very lean and fast process. And on top, the algorythms nowadays are very smart. While they scale the image up, they preserve and in some cases even expand the patterns in the images, like curves/outlines, texture details etc. The resulting image is extreme sharp and detailed yet computed very efficiently. Of course these tricks come at a price. For example you naturally lose some details which would have been rendered at 100% in game. The landscape in far distance is not as full of nice, little details compared to 100%. But very important: it’s not blurry.

In the end it’s a pretty complex matter, but I hope I could bring the idea over. Going 60% first and taking the biggest burden away from GPU/CPU allows for a very strong and visually still great 2D super-sampled picture aferwards - way faster and smoother than 3D-rendered at 100%.

2 Likes

Hi Tony

Something has changed and became indeed better the last weeks. Don’t know if it has to do with Nvidia driver update or simupdate 3? Will try your latest suggestion but I noticed that I am able to crank up my original settings.

My original settings where:

  • Oculus Link with Steamvr runtime.
  • Oculus app at 3920 x 1984 at 80 Hz
  • OTT SS 1.3 ASW 18 hz
  • Steamvr res. per eye at 100%
  • MSFS render scale at 100%

I now have my OTT SS at 1.6 and still smooth…

1 Like

Very good description. I made few weeks ago a chart with various combo of RenderScale and Supersampling (Pixel Density in Oculus Debug Tool) to see the impact on crispness and mainly the impact of fps. As FPS was too fluctuant I chose to lock them to 45 (Oculus CV1 90Hz /2) ASW off (no retroprojection). So I was watching the GPU usage instead.
We can see what you said : You can’t have the same performance and image quality if you only use the Render Scale factor. At a given render resolution, reaching it just by Render Scale is way more costly on GPU usage than using a combo of RenderScale and Supersampling to reach the same end result. I already posted this somewhere. It’s a rough draft but could be useful to understand the mathematics behind all that.

2 Likes

Trying this now @TonyTazer1504 but I’ve already had to quit the sim and re-enrol to the Oculus Beta - the dratted flashes came back when i rolled back to V26, they were worse than ever before for me!

Everything else looked REALLY hopeful though, wow that 1.9 OTT SS setting really works wonders eh?

I’m just updating back to the V27 beta, fingers crossed everything is ironed out and i can enjoy even better performance!

Thank you thank you thank you again for the work you’ve done on this. It’s so wonderful.

1 Like