Toe Brakes not working seems like a common thing

I have been using Xplane for lots of years now after having moved from FSX. My Slaw Device RX Viper V2 rudder pedals have worked flawlessly.
Now I have MSFS and went to set up my Viper pedals and of course there are issues right out of the gate.
The yaw works (Z-Azis) in both the default Cessna aircraft and in my JustFlight Piper Arrow addon aircraft and the virtual pedals animation in the cockpit moves as expected, but no matter what I try in assigning the toe brakes to the Y+ and X+ axes the virtual brakes in the cockpit do not animate and the brakes will not stop the aircraft when rolling.
It seems like this is a common issue with many rudder pedals.
Am I missing something in the setup?
An email has been sent to but there is no telling when or if I will receive any reply.
Any help to be had here?
Edit: I have done the calibration using the Slaw Device rudder.exe calibration software any number of times but that has had no affect. Both right and left brake boxes showing the joystick axis Y+ and X+ assignments light up when selecting the validate button and pressing the toe brakes.

When you are in Controls Options, in the box on the left marked "Search by Input " do you get any indication when you press the toe brakes?

Do the toe brakes jump to 50% right away as soon as you touch them? (or already at 50%) when you are looking at the sensitivity settings?

If so, it’s a calibration issue (and is common).

Yep…that is the way I determined which axis to use for which brake. And it appears the Y+ is right brake while X+ is left brake. Not very intuitive to me.
The Y and Y- as well as the X and X- dont work. But I dont understand those axes as they relate to toe brakes.
The toe brakes are assigned as above and the boxes turn white with the validation as I depress the brakes. But nothing happens in the 2 aircraft I have tried.

Under Sensitivity with the Axis X and Axis Y graphs, as I depress the toe brakes, the dot moves from bottom left of graph to top right of graph along the diagonal line.
Edit: All appears to be in order, but the movement of the toe brakes doesnt translate to the aircraft.

Maybe some funky firmware problem on the Viper controller. Maybe there is a firmware update. These pedals are about 4 years old.

Have you tried the sim in Safe Mode to see if this still occurs?

I will see if I can find how to go into safe mode and give that a try.

With the sim running, stop it using Task Manager.
The next time you start it will prompt you.

Nope…running in safe mode and still the same behavior.
Its probably a controller board / firmware issue relative to MSFS.
No issues in Xplane.
Maybe I will hear something back from Poland later tomorrow.

Edit: I will shift my focus to my Fulcrum One yoke which is also not working.

And I was having such a good day…

1 Like

More toe brake problems
Per the suggestion of the rudder manuf. (just received a reponse)
I have disconnected all other peripherals except mouse and keyboard.
I also removed the toe brake mappins to the keyboard.
Went into the rudder config and noticed

  1. The validation box (not sure what its supposed to be called) changes from grey to white when the toe brakes are depressed. But the validation (turns white) only every other 3 or 4 depressions and then noticed that I had to put a lot of pressure on those brakes to get the box to change to white.
  2. So I thought maybe a sensitivity issue. But as I tried to adjust the brake sensitivities the flight sim locked up on me. Time for task a manager shut down …again.

Edit: It’s not the sim that is locked. That exercise of adjusting the brake sensitivities locked up my entire computer. Second time in two days that MSFS has done that. Cant even open up task mananger and have to hit the reset switch. Windows 10, Intel Lake CPU, and GTX 1080Ti, 12 GB on GPU and 32 GB system ram is not cutting it perhaps.
I may have bigger issues with this high end computer not being high end enough to run MSFS.

I’ve never had any ctd or pc lock ups, but did have the toe brakes start at 50% in msfs and full movement in windows calibration with my old Mad Katz Combat Rudder Pedals ( precursor to Saitek & now Logitech ) but they did seen to function normally in sim. Now using MFG V3 with no issues at all however.

Does the Slaw device have it’s own drivers or special software?

The slaw device rudders has its own config utility rudder.exe for calibration.
I think I may need to start all over with a computer build.
While trying to configure the Fulcrum yoke, my entire system just stopped working…froze. Not even ctrl-alt-del works from the keyboard.
I have to get down to some basics and probably simplify my entire system. I am using a 34" curved monitor (plus two 27") with on board monitor switching between computers.
Time to start pairing it down to the basics and eliminate some variables.
Thats an exercise for another weekend.

Edit: BTW it doesnt do a CTD…MSFS is still on the screen as are my web browser on another monitor…everything including mouse and keyboard just stop…

@Palladio8627 Sounds a bit like you have a 3rd party antivirus running that might block your controller. I had exactly what you describe years ago in P3D. It recognized in the sim that I actually moved the axes, I could bind them to the sim and to FSUIPC but when I tried to use them to control the plane nothing happened. I was told to get rid of Kaspersky and that did it for me back then.

I use Thrustmaster T.Flight pedals and do not have any toe braking issues.
MSFS v.11
No anti-malware running except Windows Defender.

Perhaps I need to dive into my Norton AV.

Norton AV and the sim do not go well together.
I would shut down Norton altogether and then try.

I will give that a try

I verified that Norton is not the issue.
If these things worked with MSFS 2020 last summer and not now but work in Xplane still the only things I can imagine affecting it are the MSFS updates when I started this sim up after not using it for more than half a year, or the pedal controllers are just faulty enough to not coordinate with MSFS but still work like a champ in Xplane.
In that case I may be forced to buy some new pedals because I hear from Slaw that there are many of his customers using these pedals with MSFS with no problems, but I have no way of knowing how to get info from any MSFS simmer who is successfully using the Vipers…or are having the same issue.

1 Like

Slaw is convinced there is nothing wrong with my pedals and the problem is all on the Sim side.
He suggested there might be something else assigned in my MSFS configurations that is conflicting with the brakes, but I can’t find anything.

just some info on how mine looks (never had any problems and my generic pedals where preset by the game)

so on every X axis i have “Left Brake Axis”
on every Y axis i have “Right Brake Axis”
and on every Z axis i have “Rudder Axis”

they are all ‘Reversed’ with the checkbox

i dont know if that will help anything but … it gives you a baseline of what its supposed to look like?
good luck