Top Mach Studios: Lockheed Martin F-22 Raptor

Over 10 kts (I believe) the canopy automatically closes and locks.

In speculation and jest - I believe this is to prevent fighter pilots from looking too cool while taxiing on the ramp. It could also be a visual confirmation that a pilot isn’t “speeding” and below 10 kts while taxiing.

1 Like

And, jokes aside, because the canopy mechanism, IRL, almost certainly won’t support much wind / dynamic pressure before suffering damage or failure. I believe we set the cutoff for canopy open position at 15 knots indicated or throttle lever above 40 or 50%. We don’t know in real life if there is such a limit / automatic closing function, but we felt like this was better than simply having customers flying around with the canopy stuck open if they had any issue closing it themselves - a failsafe of sorts.

1 Like

Haha yes that makes sense, can’t have the pilots feeling too cool :grinning:

In my case my issue is after I’m stopped, parking brake is on, engines off. I’m clicking the button I used to close the canopy but I can’t get it to open.

Is your battery still on? It needs to have power.

Also, if using VR … try closing your non-dominant eye and then try to click the switch.

Thanks yes the aircraft was still powered up (I tried turning on the APU as well). No VR.

Doesn’t seem like your issue has a quick resolution. Could you please find us on Discord and post more details about your issue - the MSFS forums are generally not supposed to be used for 3rd party add-on support inquiries. Search “Top Mach Studios, LLC” and join. Thank you!

Sure, will do, thanks!

very good plane , MFD is not that indeep, I’m having huge stutters on turns, can you plz fix it ? Thank you


I’m experiencing a lot of stuttering also. Turning off the MFD’s helped some.

Edit: uninstall it, went thru all the sim folders and deleted all mentions of the F-22 and reinstalled. Tried the no FBW, lots of stuttering taxing. Loaded up the FBW version and flew for awhile and no stuttering with MFD’s on. I’ve tried just uninstalling it and deleting the files in the packages folder before with no luck. But when I went through and manually deleted all the files associated with it the FBW worked yet the no FBW still had stutters. I got it from Just Flight if that matters.

1 Like

Screenshot (1525)

Thanks, will try that. Haven’t so far been able to cure the stuttering with MFDs on.

With the release of SU12…and WASM finally running (successfully) on xbox. When can we expect the Raptor?

When the marketplace team makes it available. That’s all we know at the moment. Hopefully that will be shortly after SU12. Our testing has found no significant problems in the Xbox environment so it should be ready for action.


Available now for Xbox!


Thanks for posting about the Xbox release here! Does indeed look like the Marketplace team has enabled our F-22A for Xbox. Console gamers, enjoy!


After more than a year of waiting, it’s finally available on Xbox. It’s so fun to fly this thing. Many thanks to the devs of Top Mach Studios. Excellent work by you, thumbs up for this noble product. I LOVE it so much, thank you :heart:


…and the Raptor is absolutly awesome on the xbox. Thank you Developers and Microsoft Flightsimulator team…


For Xbox Users, the Manual and Quick Start Guide can be found here


Really loving the plane, detail is fantastic. Not sure if just an Xbox issue but Ive had a few crashes on Series X. One turning the battery on and two when attempting to fly the plane in showcase mode. For some reason in showcase flying it from the ground, the plane is acting very oddly and literally stopping in the sky and violently nosing up and down losing all air speed.

Looking forward to getting this aircraft in the future now that it’s on Xbox!