UI broken and reset user settings - Gaming Services update

Buy to own…

I also encountered that bug.

The options have all reset and are not saving anymore. Not even the control settings have been retained. Nothing. I am certainly not rebinding all my key assignments every time I want to fly.

I can not even change the language of the sim to EN-US anymore, because that requires a restart of the sim and then the options are all reset again. Infuriating, because the German translation is hideous.

Guess no more FS2020 for me until this is fixed. :expressionless:

I don’t have Edge, or Cortana, or any pre-installed Windows apps such as the trail versions of Office 365. All were removed with PowerShell scripts specifically designed to permanently remove unwanted Win 10 features. There are multiple web sites that provide guidance on how to do that.

My flight sim PC is dedicated solely to that purpose - I have MSFS, P3D and XP, each on it’s own dedicated SSD drive. Other than software that directly supports flight simulation - ranging from utilities like LNM to planners like PFPX, and development tools, there is no other software installed on the computer. The Win 10 Pro OS is stripped down to only the essential services required to support the 3 sim’s I run. Doing this would probably not be optimal for someone who wants to use their FS computer for other tasks.

I have a separate PC for “everything else”.

1 Like

I didn’t start FS2020 yet today, but just in case it helps finding out the problem:

  • This morning I got a notification Gaming Services was updated (notification center)
  • Using IOBit Unlocker it shows I only have 2.50.5004.0 in WindowApps
  • When I open the Windows Store App, it shows last update was on Feb 11th to v2.50.5004.0
  • In the Windows Store App I have now nearly all my Windows Store Apps have a new download ?!? for example: Xbox Identity Provider, XBox game bar, Windows Alarms & Clock, Microsoft Tips, Windows Camera, Movies & TV, etc… Mixed Reality Portal, HP Reverb G2 VR Headset Setup… Windows Calculator, etc… There are 33 of them.

This is specifically what I was wondering about! what services did you keep in the end for this :slight_smile:

2 Likes

FIXED so time to restore default startup configuration for: Ms Store, CscService, DSP, WSearch, wuauserv

How to

1 Run the command prompt as administrator (CMD)

Copy the command below, paste into CMD

REG DELETE “HKLM\SOFTWARE\Policies\Microsoft\WindowsStore” /v AutoDownload /f

press Enter

2 Copy the command below, paste into CMD

sc config CscService start= demand

press Enter

3 Copy the command below, paste into CMD

sc config DPS start= auto

press Enter

4 Copy the command below, paste into CMD

sc config WSearch start= auto

press Enter

5 Copy the command below, paste into CMD

sc config wuauserv start= demand

press Enter

obraz

Close the command window and restart the computer.

Run MS Store app and turn on automatic app updates.
How to.

Fly safe!

28 Likes

Removed (among others): All remote management, Remote Desktop, printer services, fax, WiFi and Bluetooth, (I use a single Ethernet card), media services, image acquisition, touchscreen, remote registry, file sharing, geolocation, biometrics, program compatibility assistant, parental control, diagnostics, indexing.

1 Like

5 Download Microsoft.GamingServices_2.50.5005.0 shows access denied

Yep, same issue as everyone else. Gamingservices updated a few minutes ago and now everything is screwed up. Come on Asobo/Microsoft… really???

new download link :wink:
tlu.dl.delivery.mp.microsoft.com/filestreamingservice/files/aa7a17b0-64ad-4e13-afbc-ee88a7221c3c?P1=1613883233&P2=404&P3=2&P4=ZAMqS5oBbdmmzudZ0zwMl%2FiKm%2B0QXctLS8iAoMctowIHZyCkufNS0UHj8DeRmGpA9LBkGz65P5Q6W%2BFK1g9pNw%3D%3D

1 Like

Escalated to test - thank you for the detailed posts.

4 Likes

Let’s review. SOMEONE SCREWED UP – AGAIN –

What a hack job. Seriously?

I keep asking, where is the QA?

5 Likes

I would believe the offices of Microsoft/Asobo right now are something like this memorable clip. The office fire drill

2 Likes

It doesn’t seem like these developers are to blame. It looks like a Microsoft specific app update is to blame for this. I doubt Asobo could’ve even known this would happen when the Gaming Services app got updated.

4 Likes

Not sure if this is the same issue but a .cfg file is set to Read Only. If you remove the Read Only setting it saves configuration settings as required and loads them as they were left at the previous load of MSFS.

The file is UserCfg.opt

Same issue here since yesterday. Prompting me to setup all initial config during each load.

It happened to me today. Some of my profile progress got reset!!! I can’t believe it man! My “landing at 500 different airports”, “Complete 10 weekly challenges”, “Land at 25 Star Airports” and “Use smart camera to watch 100 landmarks” got completely lost!!! I’m already halfway in the “landing at 500 different airports” and “Complete 10 weekly challenges” and I’ve already finished the other two. Those are very time consuming challenges and I dunno why it got reset!!!
Asobo you better fix this ASAP!!!

This worked for me. Thank you for this!!

Same issue here in Spain since this morning after updater Gaming Services. The only way for me to avoid this problem is to keep the simulator running.
I wil send the electricity invoice to M/S :joy:

I don’t think we are a minority. I think lots of people don’t bother coming or posting here. Right after WU111 I now have this problem. I nearly didn’t post because I’m apathetic. This bug needs looking into by Microsoft asap. I don’t have the time to keep setting everything each time I run fs2020. It’s ridiculous. Zendesk are aware. Let’s cross our fingers for a hot fix. I’ve decided to not mess with anything until then.

1 Like