UI broken and reset user settings - Gaming Services update

Hi,

since this morning the UI reset to default values every start of MSFS.

Welcome screen and setup screen for the UI.

After initial launch UI is leaking and cause freeze while try to update content in the content manager.
Also leaking and freezes while try to navigate through the ui.

Last action was the big uk update yesterday. Today I wanted to complete the couple of downloads
that was also related to the UK update.
Airports, Landing challenges etc.
But stuck and freeze.

Flight dynamics I could also confirm as very buggy.

Manual settings in the user.cfg also are not saved.

No UI mod installed. Tested with clean community folder.

@RoyalTot @Jummivana

Update:
After actual update of Gaming Services App at the Microsoft Store App the problem should be solved.:white_check_mark:

Reset instructions for those who use @TenPatrol fix:

Default Settings every time I start the sim
This repeats itself every time I try to load the game
After the patch, sim doesnt save settings
Each MSFS launch starts from settings sequence
Stream Deck new game configuration every game start
FIXED : I'm losing my settings after every launch (Post Feb World Update)
FIXED : I'm losing my settings after every launch (Post Feb World Update)
Set the options, every time I start the sim
Set the options, every time I start the sim
Can not save Settings, with every launch demand to “Set my experience”
Can not save Settings, with every launch demand to “Set my experience”
Control binding reset every time load into the sim
Each MSFS launch starts from settings sequence
Cant re-install mfs error Error 0x80073d12, 0x80070005
Cant set language preferences anymore (sim doesn´t keep settings)
This Triggered Me
Gaming Services listed twice under services
Something is seriously wrong
FIXED : I'm losing my settings after every launch (Post Feb World Update)
Accessibility Setting and Graphics Setting each time i launch FS ... what is happening?
My FS keeps asking me for Experience Settings as of today ... what the hell has changed now?
Settings wont save and achievement progress reset
Accessibility Setting and Graphics Setting each time i launch FS ... what is happening?
My FS keeps asking me for Experience Settings as of today ... what the hell has changed now?
No save settings new update
Fresh setup Every Time I Start the sim
Reasign controllers everytime
Reasign controllers everytime
Marketplace took my money and did not download Vegas
After the patch, sim doesnt save settings
Initial options (Accessibility, Graphics, etc.) requested every time MSFS is started
Unguarded configuration
Starting FS: Please insert disc, then I restart FS, asks for settings as in first install?
First time UI configuration menu everytime
Why do I have to redo all of my initial settings every time?
Why do I have to redo all of my initial settings every time?
Ongoing failure to store / save settings

+1, I thought it was me but it is asking for settings every time you launch the simulator. Las night it did not happen.

9 Likes

Same here. I have a new profile and 0 hours of flight (I have more than 600)

2 Likes

I made a backup of C:\Users\pcnep\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SimObjects

as I don’t want to loose my flight hours in every aircraft.

1 Like

I have been trying to correct the same issue at my end for the last 90 minutes.

I have tried a complete uninstall and reinstall and that doesn’t fix it.

The sim seems to want me to re-do all settings every time I run it!

I have already filed a zendesk ticket.

6 Likes

I can confirm this behaviour. Everything worked as expected yesterday evening. From today MSFS asks me for initial configuration EVERYTIME I start the sim.

Moreover it’s impossible to skip this (no workaround) so I must configure the sim on every start! It really draws me crazy. :slight_smile:

I suspect that today’s Gaming Services update broke this (nothing else changed on my machine since yesterday). Will try reinstall Gaming Services completely and will let know if it helped.

3 Likes

Uninstalled both MSFS and Gaming Services, then reinstalled - it didn’t fix this issue.
So ASOBO / MS should fix this as soon as possible (hotfix or Gaming Services update).
Until then MSFS is unable to keep the previously set configuration and this is really frustrating.

5 Likes

I just checked and haven’t got the issue. What I noticed is, that I’m running a different Gaming Services app version compared to @tamalien, and he does have this UI problem.

Looks like the gaming services app is the culprit. Not 100% sure though yet.

1 Like

I think you are onto something here. Gaming services updated today to 2.50.18001.0 and since then this problem has manifest itself. Chatting to others who are on different gaming services versions, they aren’t experiencing the issue.

1 Like

Yep till now I tried also everything. But no reinstall.
Suggesting it’s a minor fix.
But some kind of curious bug.
Grounded :no_entry_sign::flight_departure:
Gaming Service was today the last system update. Right.

1 Like

+1. This morning I updated Gaming Services from Microsoft Store and nothing else changed.

2 Likes

Same here: tried 3 times this morning, and every start up is like the first one: set your experience, and so on…

Try to re-install the Gaming Services app:
(steps taken from Xbox Support)

  1. Open Windows PowerShell as admin
  2. type the following command and press Enter:
    get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers
  3. In the same window, type the following command and press Enter:
    start ms-windows-store://pdp/?productid=9MWPM2CQNLHN
  4. Install the app on that page, and select Yes when you receive the User Account Control (UAC) prompt.
  5. Restart your device, and try to run the simulator again.

Not sure if this fixes it, but worth a try as it comes from the xbox support website.

2 Likes

I’ve just tried but no luck, it is happening again. Thanks anyway.

2 Likes

Having same issue as posted by several users in my duplicate thread here

https://forums.flightsimulator.com/t/default-settings-every-time-i-start-the-sim/368897/13

Is the Steam version affected as well? I afraid of starting my sim and destroying my configuration.
I remember having in the past (set your experience) similar symptoms when the sim was unable to connect to the servers, but then there was also the “press any key” message (despite being removed, but somehow returning when no connection to the servers).

Same issue here :confused: It worked fine for me last day, but after I updated Game Services this issue happened

I have the Store version. It affect not only the ui settings. Content manager stall. Also navigate though the UI result in stalling.

You can backup your config files.

Look for the config files in these locations:

  • C:\Users\[USERNAME]\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

  • [STEAM-DIR]\steamapps\compatdata\1250410\pfx\

  • [STEAM-DIR]\steamapps\userdata\[STEAM USER ID]\1250410\

  • [STEAM-DIR]\steamapps\common\MicrosoftFlightSimulator\

3 Likes

This problem before the weekend is a drama :frowning:

1 Like