UI broken and reset user settings - Gaming Services update

Another one to the list.

Another one with problem, using Game pass ultimate. Sim worked normally on Friday, but not on Saturday anymore. This is a major issue and it is really exhausting to adjust all settings at every game launch.

1 Like

Im having the exact same issue since the update, everytime I launch the sim I have to redo my settings like Id launch it for the first time. Really annoying.

Another victim here!

Yeah at first I thought it was one of the add ons I have but I cleared it all out and tried it again with no success. It worked like a charm before the patch.

+1 my achievements are also gone…

I think the problem is not directly with the SIM but more likely with the XBOX accounts or something like that.
On Friday I installed all the latest SIM updates and everything worked perfectly.
Then on Saturday I decided to try out different settings for real-time AI traffic.
I restarted the SIM more than ten times without any problems, then suddenly around 22:00 Italian time, it started asking me for the initial configuration.

Something changed after that time on the server side

I am currently on version 2.50.5005.0. It updated automaticaly this morning to this version, but regarding the problems eveybody is encountering I don’t dare to launch the sim unaware of this version is troublefree.

Hey there @Grigna2020. We already know that the root cause is 99% Gaming Services update. Please read above. :wink:

I could confirm that the workaround from @TenPatrol work :ok_hand::+1: Thanks for that.
I will add it into the initial post.
It’s mandatory to work as admin and admin file settings WIN 10. Also powershell with admin settings.

1 Like

I’m not sure if that’s the case, I’m still with this version: GamingServices_2.50.18001.0_x64

Yes, this (2.50.18001.0) is the latest version causing this issue. Once again, read previous posts here. :wink:

How can it work? If we are on the old version of Game Services, MSFS does’nt launch and points to MS Store to update Game Services.

2 Likes

Looking at STORE, seems that Game Services was modified yesterday, but without any notice to me!

How come it updated to version 2.50.5005.0 this morning in Europe? I assume this is an earlier version than 2.50.18001.0.

2.50.5005
2.50.18001

Yes this is the latest version.

Same issue here

Same problem, hoping for a hotfix!

3 Likes

TenPatrol…this is the second time that you gave us a work around regarding a Gameservices failure…you are our hero…thanks man ! it Worked.

same problem here after yesterdays update. It’s very frustrated! Please do something