VCRUNTIME140.dll Error

Too bad. :slight_smile:
Nvidia also has a PhysX setting that offloads some of the Vram load.
There may be a similar setting in there may be something in Afterburner but it’s been a while since I used it.
Maybe take a look and see if you can shift some of the load to the CPU.

The GPU Scheduling of that screen capture that @willisxdc posted, came out with Windows 10 2004. What version of Windows are you on?

Hi, on the latest version: 20H2

HAGs will be avaiable only if your driver is up2date. If you not see it, your driver is possible older than 20.5.1 beta.
(https://www.amd.com/de/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-rx-5700-xt)

BUT: at least for NVIDIA I can never recommend to enable it !

And… what is the issue with usage of 7.99vram related to a card wiht have 8Gig Vram ?

I has a similar problem with the same error code.
I tried everything, including uninstalling and reinstalling the game.

The only remedy that ultimately worked was to “deeply” uninstall and manually reinstall the graphic card driver (RTX 2070 in my case).
To uninstall the drivers I used DDU (Display Driver Uninstaller) available here:

The uninstallation has to be performed booting in safe mode; do not forget to download the last version of the drivers before uninstalling.
Disconnect internet, so that Windows do not try to automatically install its own drivers and then reinstall the drivers you downloaded. It worked for me, I hope it will work for you too.

we allways assume “no installed mods” and this thread is not about these or other mods :slight_smile:

Discussion about Third Party Addons can you find here:

1 Like

Ah ok, understood !

I think i found it!!!
In my case it seems the Logitech GHub caused the problem. I terminatet all GHub Processes in the task manager and now i can fly without the VCRUNTIME140.dll CTD Problem. :dizzy_face: :fearful:

1 Like

Oh no. I can fly longer now but it still CTD. :face_vomiting:

Hi to all,

I experienced the last month issues with VCRUNTIME140.dll
See below the error:

My system (just new in Dec.2020):
Intel Core i9-10900K 3.7GHz/5.3GHz 20MB S1200
Asus ROG Strix Z490-E Gaming
G.Skill Trident Z 64GB (4x 16Gb) 3200Mhz CL14
Samsung SSD 970 EVO Plus 2TB M.2
Arctic Liquid Freezer II 360
Seasonic Focus PX-850 (850W modulair)

and my Graphics card from my old pc:
MSI Geforce RTX 2080TI (1 year old)

I used “Process Lasso” (very nice live log view process start and close steps) and “Event viewer” to find the real issue.
Well it took some time…
Extra info: When I type “MSFS start”, I mean that MSFS has done already the startup processes, but I talk about the moment just before the main menu show up. (screen with all the menus) Because that is the moment that it crash after 10 sec. and return to desktop windows.

Step 1.)
First checked over and over again all updates for Windows, Nvidia drivers, etc…
All was up-to date.

Step 2.)
First my focus was on Visual C++ 2015 -2019 Res X64 and X86. After many times of updating, restart system and startup MSFS, I still got the same problem.

Step 3.)
The next focus was via Process Lasso to monitor after which starting process, the Microsoft Watchdog and reporting kick in.
First thing I noticed that the Nvidia Geforce Experience - Share view option start just before MSFS.
So I switched the Share option off in Geforce Experience. Restart pc and tried again.
No result.
Second I saw that OAWrapper file from Nvidia Geforce Experience startup just before MSFS start. Maybe this could be the reason? So I uninstalled Nvidia Geforce Experience.
Restart system and tried again. No result.

Step 4.) What else started just before??? LogiMicrosoftFlightsimulator.exe
Disabled this in the files section windows and restart everything. Nope no result.

Step 5)
Going back to control panel Windows, maybe this good be the solution to find??
So I checked the Graphic settings option.
Switch off and on and tried both settings. Nope no result.
Changed the MSFS high performance setting in the graphic settings from Control panel windows.
Nope no result.

Step 6.)
What else???
During the whole debug session I was thinking about Nvidia drivers and my Overclock setting for the Graphic card.
I thought… It can’t be… because it worked in December normal until the first week of January this year 2021. So it can’t be…
The drivers are nicely updated. So I didn’t touched it yet.
So first thing what I tried was, going to my MSI Afterburner app.
Switched off the windows startup option for overclock already loaded.
And I turned the graphics card back to default. (reset option in MSI after burner)
Now I restarted the PC and started MSFS.
Well…pffffff…
That was the trigger, the issue, the problem, the frustration and the half day of debugging…
Problem solved!! So it is not the Nvidia drivers or graphic card drivers. However this will trigger in most cases that Overclock settings probably disappear with this uninstall and install. So, if you switch on after the driver installs the OC back on, you will have the same issues occur.

Bottom line:
OC setting for graphic card seems to be an issue for (only) MSFS2020, so please guys check this issue. Maybe you can find a software solution for this. Would be nice.
(Because I don’t have issues with Xplane 11 vulkan and many games like Madden NFL21, PGA tour 21k, Arma3, Tarkov, Witcher3, etc…)

Second: When you think about something which could be the issue and you think …nehhhh…that can’t be… Check that first. :wink:

Hope this will help a couple of guys.

Kind regards,
Geraldar98

Note:
After that MSFS is running (almost 1 hour), I did a test about switching on again my Overclock profile in MSI Afterburner and it seems to work normal. Until now.
If this workaround will crash later on, I will update my post.

and again is the reported issue not an MSFS issue :wink:

Overcloacking is still an issue with your system. Its nothing new about and it is so often mentioned in this forum, MSFS FAQ, etc…

Dear, today I began to experience the 140.dll problem and I had not suffered that recurrent problem when choosing airport and gate, entering the cabin and practically instantaneous error. If you come from a stable configuration, it has to be something that you have done recently and then remember, I had installed the tracer “acars uesvar” a virtual airline, the acars installer, if or if he made me install Visual C ++ 2013, even though I had 2015 and 2019 installed. Logically uninstalled 2013 and problem solved for me.
I hope this post can help those who suffer from the problem.

a greeting

Hi @Matrixx3050!
I find this intriguing. Maybe this can help others who have the same! Thank you for posting this!

I believe that 2013 is included in 2015 or 2019. The failure made me immediately as soon as I got on the plane and it was like 6 times. It worked for me.
I hope the rest will find it useful. Thank you

Ok, a little update on the issue. I have since uninstalled MSI Afterburner and RivaTuner and I have not gotten this dreaded vcruntime140.dll error anymore. I have since then completed many flights, but now and then my game still crash but the faulting application is FlightSimulator.exe… I’m okay with that as it happens but rarely.

2 Likes

possible give a hint about :
which version of MSI Afterburner you had installed

The older ones ( e.g. 4.6.2 ) seems to cause sometimes issues. In my case NOT related to MSFS, but e.g. if you start first MSI-Afterburner and later on Steam, you will see an error message.

Hi MichaMMA

The version of MSI Afterburner I had was version 4.6.2. I have removed it from my machine completely. I hope that it will help you as it helped me

hmm… then it might be strange… I have in relation to MSFS no issues with this ‘older’ version ( except the mentioned start order with steam ). But who knows, possible it created a strange issue in your case and other users can try your hint. Thanks :slight_smile:

Haven’t played since September. Today I decided to check out what is new. Game updated. Then, entered the menu. Crash. No error message. I tried it again. Menu. Crash. Same story. A few more times.

Bugged ■■■■. Regret spending money on this.

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5fda32ba
Faulting module name: VCRUNTIME140.dll, version: 14.28.29231.0, time stamp: 0x5f4c66c9
Exception code: 0xc0000005
Fault offset: 0x00000000000012de
Faulting process ID: 0x1044
Faulting application start time: 0x01d6f8c197176bda
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
Report ID: 1bcb05e1-1a51-4d7e-ae0c-6d5a49176833
Faulting package full name: Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

really a strange error message :wink:

What you already tried from given hints ?
Mods installed ?
What are your System Specs , Driver versions, etc ?