Virtual Desktop *dramatically* smoother than Link cable (Quest 2). Why?

First a tip, then a question.

Tip: if you are using an Oculus Link cable and not satisfied with performance, try Virtual Desktop instead. It made a HUGE difference for me (frame rate, smoothness).

Question: Why is this the case?

It seems being cabled should be the better option. I wonder if understanding the cause will help further improve performance.

PS- I don’t believe I have any USB-port-related problems. The Oculus app sees it as USB 3 and gives me green checkmarks for bandwidth. Other games (like Half-Life Alyx) appear sharper when using Link. My Link issues seem to be isolated to FS2020.

For optimization, I followed the tips here: TnT Quest 2 Settings - Sharp and SMOOOOTH! (thank you @TonyTazer1504 for the excellent guide).

High-level specs for reference: RTX 2070S, 9th-Gen i5 4.6GHz, 32GB RAM, Quest 2, Xbox Gamepass Version

6 Likes

I have another post raving about my better experence with VD instead of the Link cable.
I believe it is a USB issue.
Several times with the Oculus link program it complained about my connection dropping to 2.0 instead of 3.0.
I just don’t think the link cable usb connection is stable and I am using the official Oculus Link cable and the USB 3.0 port directly in the rear of my motherboard.

1 Like

Ah, thanks @GalacticClown15! I just read through that thread (somehow missing it when I searched prior to starting my post).

Interesting about your experience. I’ll dive deeper into my USB stability.

Either way, glad Virtual Desktop is solving things for both of us.

1 Like

There’s some kind of secret-sauce that VD uses to host the VR apps, which appears to be significantly more efficient than Oculus’ native runtime that it uses with Link. Also, bugs specific to Oculus and Link don’t seem to affect Virtual Desktop, like the frame-sync problem that requires V-Sync to be set to ‘fast’ in the Nvidia driver settings. In short, I think the dev has created a stripped-down runtime and framecapture chain which works better than Oculus’ own, but it comes with limitations: it isn’t compatible with all VR apps, and it can’t use ASW at all.

Also, people using Link can get wildly different results, because there are many places to apply settings which can have a huge impact on performance. There’s the settings built into the Oculus app (refresh from 72 to 80 to 90Hz; and render resolution which confusingly varies its multplier value based on your hardware – e.g. a setting of 1.0 for you might not be the same resolution setting as 1.0 for another person!). Then you’ve got the settings that can be changed in the Oculus Debug Tool or Oculus Tray Tool (they both do the same things by the same means–one does not add to the other; they override each other) where render resolution can be further overridden, as well as bitrate, and supersampling (aka pixel density) on top of that which is not the same as render resolution though it’s somewhat related. And to really make things confusing, if you’re running apps in steamVR with Oculus Link (which is necessary for certain VR titles that don’t support the native Oculus runtime), it has an additional supersampling multiplier of its own, which can act on top of any of the settings I just listed above. And on top of that, steamVR has a ‘global’ setting for this that affects everything, as well as a per-app setting which multiplies the global setting!

So, that’s a lot of the reason people can have wildly different experiences. Add to the mix different hardware specs for each user, and you can quickly see that it’s quite hard to even match the same settings between users, much less match performance.

Lastly, MSFS does have a pretty glitchy/buggy VR implementation in general. I’m guessing it’s because it’s running via openXR, which is a newer protocol that Oculus only recently started supporting, and it seems to be nowhere near as stable and refined as their normal runtime.

3 Likes

On a WMR headset like the G2, I can’t say I’ve had any problems related to MSFS in VR, some on the G2 side but not related to MSFS. So I’m guessing these issues you talk about are related to the support for Oculus headsets?

Thank you! I’ve been unable to figure that out on my own. I wasn’t sure if I needed to use the Debug tool, the tray tool, one or both. It’s such a mess to the novice (me) VR user.

This is helpful–thanks for all of the detail.

Thanks @SwirlyMaple7, great description of all layers and caveats, from the sim to the eyes! far from a plug an play VR experience for sure.

I keep your post and will read it each time I’m tempted to upgrade my Oculus Rift CV1 :wink:

I was sceptical at first about Virtual Desktop and I’d just learnt to live with the micro stutters when flying low using the link cable, tried it for the first time today and it’s unbelievably smooth, seriously the smoothest flight I’d had in VR since it was launched and I’m at a loss to explain how as I thought being wired would be the best experience, how wrong I was and for those of you not sure about it, I was simply blown away by it…a must have app in my eyes :slightly_smiling_face:

3 Likes

hi all, i would like to give again a try with VD, but could advise a post where i can find easily again the corrects settings for VD ?
there so many posts, with so many ways to do, that i am totally lost !

Can someone tell me if this would work for a wireless solution?

Cox cable modem & TP-Link M4 Deco mesh router in living room, additional 2 Deco M3W adapters in office & bedroom. VR PC in office tapped into WiFi with USB adapter. Too much latency between Quest 2 & PC after test runs. Ordered dedicated TP-Link AX1500 for VR PC & Quest 2 use but how do I still access the internet? Setup AX1500 as a bridge? Any help would be appreciated!

Bridge is still going to have latency as you are still going over wifi to the original problematic built in Access Point in the M4 router.

Using the M4 router ethernet port you will have to run some wire closer and connect that AX1500 via ethernet and set it as a dedicated access point mode.

https://www.tp-link.com/us/user-guides/archer-ax10&ax1500_v1/chapter-4-set-up-internet-connection#ug-sub-title-4

I didn’t adjust the settings for VD. I did follow the thread I linked in the opening post for my in-game settings (TnT Quest 2 Settings). But that’s it. VD just worked for me.

I also use Deco. The fix is probably to wire (LAN) your PC into one of the Deco devices.

I have it as follows:

  • Cable modem/router wired into main Deco. The WiFi on my router is off so it doesn’t compete with the Deco system.
  • Secondary Deco is up in my office near the PC. The PC is wired into this Deco.

Now when I’m in the office, my Quest 2 connects to the nearby Deco which is cabled to the PC.

I don’t experience any latency.

Problem is my 2 deco adapters are not the same as the M4, therefore no RJ45 connection.

I think I maybe just solved my issue but have to purchase new hardware and test to be sure. My USB WiFi adapter is only 2.4GHz so not taking advantage of the 5GHz network!

But i don’t understand, the post linked at the start is for Oculus and link cable, not for VD ?

Plugged-in is still going to greatly outperform 5GHz Wi-Fi, so if the USB adapter is a similar price to an additional Deco with a LAN port, you’d be much better off going with another Deco.

See this: https://www.howtogeek.com/217463/wi-fi-vs.-ethernet-how-much-better-is-a-wired-connection/

It is, you’re right. I was referring to the in-game graphics settings from that post. If you scroll down a bit, you’ll see them.

I didn’t tweak anything additional for VD. It just worked. So well, in fact, that I was able to start moving in-game settings up.

If VD isn’t working for you, there are a couple of other troubleshooting-type threads going on right now. Turns out this is a hot topic.

Ok, but i have already tried link and VD, but all my tests with VD where with SteamVR, and maybe that’s where i miss something, is it possible to run VD without Steam and SteamVR ?